New Posts  All Forums:Forum Nav:

Phonak Audeo Defect Thread - Page 28

post #406 of 467
The other shop (null audio singapore) have a very tempting offer at roughly 100 USD for the phones (I guess now that it has been revealed the stocks won't last long thanks to head-fi ). That is why I was leaning towards it.

Thanks for the very helpful comparison there. PFEs are sounding like a wonderful deal if I can get my hands on the newer revision.

PS - I was wondering if the cable breaks and cracks are because of the hardening of the material during colder weather. Some people have reported that the cable gets harder ( i am guessing brittle as well) at low temperatures. If that is the case then I have no issues with the older revision either, if it comes substantially cheaper.
post #407 of 467
I just got a confirmation from them that it is indeed V0 and that is why has such discount. I am usually very careful with my phones and am so lazy that getting sweat on them is impossible for me . Will they last at least an year if that is the case?
post #408 of 467
Quote:
Originally Posted by manuvajpai View Post
I just got a confirmation from them that it is indeed V0 and that is why has such discount. I am usually very careful with my phones and am so lazy that getting sweat on them is impossible for me . Will they last at least an year if that is the case?
I babied mine but the cable split anyway (where they curve aorund the ear). I highly recommend the v1s.
post #409 of 467
Quote:
Originally Posted by schneller View Post
I babied mine but the cable split anyway (where they curve aorund the ear). I highly recommend the v1s.
I'm on my 3rd pair of PFE (v0) however I still love them despite issues. The first two broke due to the typical little plastic piece breaking. On these ones, the cable casing has come off at the connection to the earbud exposing the wire. I've emailed phonak tonight so we'll see their response soon.
post #410 of 467
I am pretty sure that my PFE's are broken. The right earbud does not produce sound at the same level as the left, its very noticeable.

How can I tell what version I have (V0 or V1)? Also is there anything different in the V1's other than just improved build quality?
post #411 of 467
Quote:
Originally Posted by MrTissues View Post
I am pretty sure that my PFE's are broken. The right earbud does not produce sound at the same level as the left, its very noticeable.
Did you replace the filter to rule that out?
post #412 of 467
Yeah take the fliters out and listen to this track to tell: Michael Knowles: Extras
post #413 of 467
Quote:
Originally Posted by GreatDane View Post
Did you replace the filter to rule that out?
Oh wow, I feel so stupid. I just replaced them and they work perfectly now. The filters just slipped my mind.
post #414 of 467
Quote:
Originally Posted by MrTissues View Post
Oh wow, I feel so stupid. I just replaced them and they work perfectly now. The filters just slipped my mind.
Great then.

The first time a filter went bad for me was with my ety a few years ago, I freaked out thinking they broke...then I remembered.
post #415 of 467
Hi all,

In this thread i saw those pictures of a PFE opened up:


How hard is it to do this myself on the 'old' version (V0), because i might want to do a recable?

Thanks in advance,

Frank
post #416 of 467

I've got it all. Cracked left earpiece, cracked wire on the left because of the stiff plastic. I could live with that. But yesterday the sound on the right stopped working completely >.>

 

Where do you go to contact them? I've checked audeoworld and there's only "contact us", is that it?

 

post #417 of 467

I have bought my PFE from a Hong Kong SAR retailer last year, and recently in the connecting part between the earphone monitor and the cable, the wires/cable got exposed to the air and the sound can't be heard from that monitor anymore. I went to the local offcial Phonak repair store for warranty, but after a week or so, they will reply that they will only repair the problems in the earphone monitor, but not the cables, so that isn't included in the warranty. So I would like to ask what can I do at this moment? I will upload the pictures of my earphone once I got it back from that repair store

post #418 of 467

I think you should contact Phonak HQ first and see how they responds

post #419 of 467

Another one bites the dust... my right earphone plastic cover is cracked. It's the black version without mic. They are 11 months old and I always babied them.

 

I contacted Phonak through www.audeoworld.com, they answered me blasting fast asking me to try to solve the situation with the shop where I bought them. I threw them an email a few minutes ago, hope I'll get an answer soon.

post #420 of 467

Hmmm, can anyone comment if the new Perfect Bass models have better build quality?

New Posts  All Forums:Forum Nav: