or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Buzzing sound coming from my Swans M200s?
New Posts  All Forums:Forum Nav:

Buzzing sound coming from my Swans M200s?

post #1 of 3
Thread Starter 

Hi guys,

 

I have had my Swans M200s for quite a while now and yesterday I came home and noticed a loud buzzing sound coming from my speakers. I have not been able to figure out what the cause of it might be and was hoping someone would be able to help me.

 

It is a pretty loud, lower frequency buzz that is not volume dependent. My speakers can still play music and other sounds but the buzzing never stops. the noise occurs if the power to the speakers is on, regardless of the source. I have checked the speaker wire and power cord and know none of those are the cause, so I am guessing it might be something inside the speaker.

 

Anybody have any ideas on how to figure out the cause? Or does anyone know how I can get these fixed? Thanks for any help!

post #2 of 3

might be a ground loop or something. Disconnect from the source and leave only the power cord plugged in. Turn it on to see if you hear less of the buzzing. If the buzzing is still there, then it might be a ground loop. If it's gone or have lessen, then the noise is from your source.

post #3 of 3
Thread Starter 

The buzzing sound is persistent with or without a source plugged in. Volume doesn't change. I'm guessing it's something internal... Anything I can do about this?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Buzzing sound coming from my Swans M200s?