Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › ATH-AD900 right ear speaker no longer working
New Posts  All Forums:Forum Nav:

ATH-AD900 right ear speaker no longer working

post #1 of 2
Thread Starter 

Hey All,

 

 

I've been lurking here for years, buying lots of gear based on recommendations.  But now I'm looking for some help!  I just put on my ATH-AD900 about 30 minutes ago and the right ear speaker is no longer working.  I swapped it out for another pair of headsets and confirmed its the headset.  I purchased them on 10/30/2011 and they only have a 2 year warranty.

 

 

Does anyone have any suggestions or advice? 

 

 

Thanks!

 

Bryan

post #2 of 2
Thread Starter 

I emailed their service department and got a pretty quick reply.  The repair costs seem pretty minimal, I'm pretty stoked about that.

 

Quote:

Thank you for contacting Audio Technica. The estimated cost to repair the AD900 headphone is going to depend on what we find wrong. We don’t know if the cable is bad, or your element is bad. The cable assembly is $17.33, the element is $13.10, $20 labor, and shipping. We recommend you send them in with the completed ATUS service form and request an estimate on the form.Please return your ATH-AD900 for repair along with a completed copy of our ATUS Service form and a copy of your proof of purchase if claiming warranty.

 

I'll keep this thread updated with my status.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › ATH-AD900 right ear speaker no longer working