or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Almi's Logitech Z-5500 Mod (High-End upgrade for the speaker system)
New Posts  All Forums:Forum Nav:

Almi's Logitech Z-5500 Mod (High-End upgrade for the speaker system) - Page 6

post #76 of 378

@andro6600 have you by any chance had the control pod open? and been in and out of there alot? i had a similar issue to what you are describing and mine was because i was moving the control pod LCD alot and the wires broke on me (the second time was hard to tell because i could not see under the white glue) but i replaced that connector with a plug and socket type connector i got of something else and never had that problem again. i thought to myself (not knowing how it works) would the display just not work? but twice it happened to me and twice it was fixed by repairing that connector. just check that connector and make sure it is ok... i know you have not said you have been in there in your post but i can remember that i had a problem like that... i was sat listening to music on low volume for about half an hour while i was on the laptop and the sound just went off... then i bypassed the pod and everything was fine... so i had a look at the pod and found the wire broke... so i fixed it once then it happened again so i swapped the connector for a more robust one that i could unplug when needed. did not do it again after that.

 

little update on mine... on my main system i broke the tracks for the front right and the front left and center (2 op-amps total) and getting them things in and out again was getting worse and worse and once they was in i had to use a link wire for the broken tracks. so i bought some soic to dip adapters from ebay and epoxied them to the board (near the original and not over any small ground points on the board) i then used ethernet cable (multi core cable not single strand) to link back over to the correct smd components (i used the test meter first to find out where everything went and which pins where joined) i removed all the tracks on both of these positions and just soldered the wires directly to the smd's... then tested continuity from the smd component to the chip leg... and then again tested the other side of the smd components to make sure the smd was ok and my solder joint (wire to smd) was connecting to the track on the board... all is ok and all wires are epoxied in place (does not look nice... but its a fix) all wires read very low resistance.

 

The new op-amps have arrived today and i will be taking extra care of installing these ones... the last ones i was rough with them.. no anti static wrist strap and had them in my hand... and when i put them in last time i had the op-amps hot... where you could not keep a finger on them... i have since got a new soldering iron (regulated one) and had practice on installing the op-amps without getting them hot (removing them is a bit different lol) so hopefully if nothing else is broke... it should be back up and running soon.

post #77 of 378

@jayjayuk, I've opened my pod 3-4 maybe 5 times, and yea, me too discovered that the cable from board to lcd is very thin, but, why the signal stopped? How it is related to lcd? And my pod not responding at all after that, i cannot turn of, neither from remote or button. Then after switch power off, and on it works again?!... So today i checked carefully all  my soldering  on the amp pcb with the multymeter for short circuits. No shorts! Re do some of them and solder the voltage regulators caps under pcb. Also apply new termal paste to TDA and new mica sheets, because i was thinking that the problem is maybe some overheating. And tested again. 

 

 

This time everything last a little longer, about 40 min. And again same story. I am going to put back the old caps for voltage regulators. Maybe  non polar caps aren't good for my system?... i don't know... Don't think that the bypass can be a problem? Or may be the big Sancon 4700uF 63V cap that i replaced before for the control pod is problematic? I remember @ramachandra

 said that this can cause problems pod lost settings? But before last intervention, i've had no problems?!? 

@jayjayuk, Hope, that everything will be fine with your new opamps. The are really pain in the @ss, to solder desolder without specialized tools. Can you post some pics from your mod of the pod cable, to got more visual?

 

Cheers

post #78 of 378

Ok, tested with old caps for voltage regulators= same effect!!! Damn! So, only two things remain - either the bypass caps causing it, or as @jayjayuk said, the problem is in the pod cable. Or worst, something unknown is malfunctioning(really hope not)


Edited by andro6600 - 6/19/14 at 1:47pm
post #79 of 378

if you dont go in the control pod that much that it is probably not that cable... and i thought why would the lcd cable stop the audio from working? i thought just the screen would go off or play up... but that was an issue before the issue i have now... i just thought i would mention it as it might help you.

 

i have all the op-amps in and i still have the same problem... what works is --- front right/left one of the rear speakers --- what does not work... one of the rear speakers and the sub... have not tested center yet as i am focusing on the sub mainly... i did notice a problem which was on the pre-amp board there is a 224j cap near the edge of the board on its own... i replaced it with a tall yellow propylene and from flipping the board over and stuff i created a bad joint on one pin and the other part actually broke the track (this is turning into a nightmare lol) but i have now fixed that... i put the ceramic back in as it wont take as much stress as i am moving it about. eventually i am sure i will get there.

 

@ramachandra i am not sure if that cap would have caused problems elsewhere... can you maybe shed some light on that? i can actually hear the sub... but i have to turn everything up full and even then it is very faint... i am not sure if it is the op-amps... i can remember when i took out the front right and the pad arced somewhere so i switched off and sorted that but the front right works and the sub does not... when the tda amps turn up i am just going to change the ones for the sub (as i will have three spare anyway) and go from there with the sub... as i cant really take these op-amps out without burning them up... if i try not to burn them up i use to much pressure and rip tracks. i am pleased that the fix i did for the already broken tracks have worked ok though... thats one thing... i am currently all over the board on diode test checking certain points for shorts and continuity... and when the op-amps was out i checked the smd's around the op-amps and they seemed to be ok and was connected to the track... so the only couple things i can think of is bad solder joints (which i am checking all over right now to try and find anything or the op-amps or the tda amps... we will see what comes of it.

 

i will post some pictures of my the main board but i wont it working before i start taking photos... i do need to put some more smd led's in my pod as the old ones are old and dimm so when i have it open to put them in i will take some photos of the inside of the pod for you to take a look at.

 

EDIT:

 

this is the flux i am using...

 

should i be cleaning this stuff off? or is it ok to leave on? the rosin core from my solder also leaves a residue on the board... sometimes it is sticky and other times it is hard like crystallized... should i also be cleaning this off? if so what should i clean with if i dont have alcohol to clean with? will this residue and flux paste cause a problem? when i was probing near the op-amp track i noticed that without touching the pad i could get a reading of something like 150k resistance when i put the probe close to the track but not touching it... i read that water can be used... is this ordinary tap water? and if i get some water that is suitable for cleaning the board... can i leave all the components on the board while i am cleaning it? like the caps and amps?

 

Cheers


Edited by jayjayuk - 6/20/14 at 6:22am
post #80 of 378

Man, i removed all the bypass caps, just to exclude them from the problem, but this was of no use. This time, the sound stopped even at 10 minutes! I am sad now. Don't know where else to look at, guess something gone wrong after i forgot to connect the two cables from the square element. This one

The yellow one(going to the between main filter caps), and the orange one(that is behind the black one) What is this element and what the two wire are responsible? 

It is very interesting, first with all the additional bypass and voltage regulators caps, sound stopped at 20 minutes,then after revert back the voltage regulator caps, the time before stopping was doubled(40), and after removing bypass caps, time was 10 min. Got no idea. I thing it is time for the system to go to service...sad day really. And my soviet military caps just came today...

 

@jayjayuk, i thing your problem with sub is at op amp. When i burned mine, a also hear a very quiet sound, almost none from the channel. 

 

EDIT: Now i tried again, and this time, sound stopped at 4-5 min. The swicth off, then again at one more bar volume, and stopped after 2 minutes. Guys, how this is look to you? There is something in relation with the caps of the tda maybe, is it possible that one or more are damaged, but no visible signs?


Edited by andro6600 - 6/20/14 at 6:52am
post #81 of 378

i have not tested it but i am sure that silver block is a bridge rectifier... if the orange was left off then there would be no power to it and that should not be a problem... just reconnect it and all should be fine in that area. to be honest i think you need to rule out your pod as a possible problem... to do that you need to solder the pins together on the d-sub connector and then attache a wire to one of the inputs and let it play and see if the problem is still present... i mite just be that your control pod is playing up and happend at the time you are modding stuff... i always rule the pod out first as i could be playing with the amp for no reason. you need to join pins 6 -> 7 -> 8 -> 13 to enable the amplifier... i then use some rca sockets i got of some donner equipment and solder them to where i want the input to go and plug the jack into the sound source... so the ground on the rca socket (or cable depending on what you have to use) should also be connected to pin 13 which is ground... then its just connect the center wire to one of the inputs... heres a picture that i use for reference every time i cut the pod out of the equation...

 

 

this always works for me... i use some telephone cable single strand to connect 6/7/8/13 together.

 

@ramachandra  would know more than me at this point... but i will do some reading... some caps block ac and let through dc while the others block dc and let through ac... also a polarized electrlytic capacitor releases energy one way and not the other (not sure about this) but if this is true then would there not be an issue putting a non polar cap in parallel with a polar cap? as for whatever the non polar cap could hold as charge would be allowed to be released anyway in the circuit (forward or backward) where a polar cap only releases forward? this is just something i thought about and will look into a little more as i am still fairly new to electronics... i would doubt what i just said would be your problem @andro6600 as @ramachandra  has already done alot of these boards and had no trouble with this setup or parallel caps (one as polar and one non polar) so probably nothing to worry about... just something i will read up on a little later. my 0.22uf's turned up today... will be getting them in once i have sorted this problem i have. hope you get your amp sorted aswell @andro6600

 

Cheers

post #82 of 378

heres some pics of the pod so far... the pics are a bit blurry as i am using a galaxy tab 3 7inch and the camera is not great.

 

 

 

 

the big heat sinks i cut using a hack saw lol but they are above any other components by a good bit or i would not of put them on. the smaller heat sinks i bought from ebay... the fan i cut the back grill out but left a cross section in with the bit that sticks up so it still supports the board as it was meant to. just puttin the led's in now :) 

 

Cheers

post #83 of 378

@jayjayuk, nice mods to the pod! Like the big heat sinks!  :wink_face:   I, myself too was thinking about the same.

 

About the rule the pod out, not a problem to do, but how is this going to help, i am pretty shure that the amp itself will work, because and now it does, just sops after a while. And if i cut the pod from the picture, what is going to tell me that something going wrong? When there is nothing to stop it? Obviously, the problem appears when something in the system getting more hot, or change self parameters, and this causing the pod freak out. That's just guessing though. I inspected the board carefully, and have doubts about voltage regulators.

 

 

 

They seems like been burned out, and the pcb tracks also look suspicious. Could it be the culprit of a problem? Also i removed my last mods and find out that the stopping is happening a lot quicker. Thus tells me, that the extra voltage of the new caps helps to hold a system for a longer period. But i do not know how to interpreting this?


Edited by andro6600 - 6/20/14 at 12:09pm
post #84 of 378

when you cut the pod out and use the sub headless... then you see if the sub does stay working and the sound does not go off... if the sub does work correctly then the problem might be in the pod... looks like black patches around those regulators? im no expert but like you say that might be something to look into... maybe run the system untill it does go off and then quickly check to see what those regulator are putting out.

 

it just seems so far that you are changing things in the sub a lot and if you say the sub will run on its own with no pod connected and still work ok then maybe you are looking in the wrong place? so your pod might of gone faulty just as you are modding... i have read some bad things about these pods online and i am just really waiting for mine to go :)

 

also from tests... if those regulators are under strain then running the system headless will keep those regulators next to cold as they dont have to run the control pod... so if you run the system headless and it works its either the pod or those v-regs that are staying cooler (possibly)

 

let me know how you get on.

 

Cheers

post #85 of 378
Thread Starter 

jayjayuk

 

I think there is some mess with the OpAmp, it was a typical symptom on SB X-Fi cards when they run without power. When i tried to bypass those OpAmps for the sub and i got the same result what you experience. Lets hope you have not damaged the SMD components with the previous iron you had. I have no solution for that situation, maybe a broken board useful to map and measure the surrounding circuits, create a PCB and hook up.

 

Cleaning off the flux is not essential, just the proper way to do the job. Months later it is getting more difficult. I like to be able to examine what i done, not just guess all fine. You can try to get alcohol, or clean petrol from the chemist, acetone or nail polish remover is also work. Stain removers usually the mixture of this materials and more effective. If you have nowhere else to turn use ordinary white spirit from paint shop. Smelly, dry slow but do the job. This liquids are not conductive so the devices can run without letting them dry properly, but most of them highly flammable so precaution is advised. Water is not really helfull, and not esay to get rid off the resin even with the materials i have previously mentioned.

 

You have done a pretty job with those heatsinks. :wink_face:    

 

andro6600

 

Looking the new photos i do not see what i mentioned earlier. On the preAmp board the burnt track is look like belong to the +18V going to the pod, and the smoke is also near the positive reg. The nearby resistor is under the cower of a black wire, and i will be not surprised if burnt or discolored. So i think you had a short circuit, and if i understand well the system was on when you connected the Pod. So one possibility is the metal screws or the metal on the connector itself caused it when ended up on the wrong spot of the D-SUB connector. Lucky for you the 78M18 voltage regulator is common enough and i suggest to replace. The Negative is looking alright and lets hope it is also from the inside, because I bought few of them and i paid almost 25€ for 5 pcs because they are rare and out of production. If I'm right any parts of the system around the Pin14 also a good subject to examination included the voltage regulator provide the +8V for the Pod (Pin10).

post #86 of 378

@ramachandra, do you know exact model and specs of the regulators, and resistors and eventually suggest alternatives, maybe even a better ones?And what the markings on the two pins side means? Are they some production numbers, or?

 

here, the picture more informative 

 

But look back in my pics before modifications, they look the same way

 

EDIT: Just tested without the pod, as @jayjayuk said, i soldered together 6-7-8-13 pins, and soldered mini jack cable to the (5-9 front left and right)-13 Ground pins. But only front left was working. Anyway, i played some music from my phone for 5-6 min, nothing stopped, but when i checked voltage regulators, they were extremely hot!!! And everything else was barely warm. Is it normal or not? I thing exactly this is the core of my problems, maybe something go wrong with them and they overheat, then maybe some internal temp protection is activating and they stopped? Is this make any sence? 


Edited by andro6600 - 6/21/14 at 2:36am
post #87 of 378
Thread Starter 

Here you find the datasheet of the regulator, and as you see it has an internal thermal overload protection indeed.

http://www.ic-on-line.cn/view_download.php?id=1678317&file=0340\ts78macpr0_2296562.pdf

At the moment there is nothing necessarily wrong with your Z other than that damaged regulator. Repairing electronic usually start with examination, taking measurement, than keep changing-checking the most suspicious components and hope you had a lucky guess until the faulty part(s) found.  You need a couple of instruments and spare parts around, and the pain coming with experience and you will find it useful if your study is electronic.

Before i have spent on the original regulator i used what i have around and i tried MC7818 and MC7918 the TO-220 type, and i had to install a heat sink to them. It was unstable, a recipe for disaster so I only used for testing a couple of times until i got the right parts. The L7818CV and L7918CV not as good for audio as the MC regs but they are common, dirt cheap, generate less heat, and you have a good chance to find it in a local store.

 

The trough hole resistors have a color code and you do not even need to memorize the codes and calculate, there are many websites to do it for you.

http://www.digikey.com/us/en/mkt/calculators/5-band-resistors.html

post #88 of 378

Damn, i was soldered wrong pins. 6-7-8-3 together, and 5 -15 for signal from jack. Now i corrected this and running the system over 1 h 30 min already, and the sound didn't stopped. The regulators, however are still extremely hot, especially the positive one! Nothing smells burned on the board. All the other parts seems to be in normal temps. So, what to think? Why these regs, don't stopped, being so hot? 

 

@ramachandra , @jayjayuk, what you think about this, is it good? I cannot find any other option for local order. But the operating max temp is only 85C instead of 125 in original ones? 

http://bg.farnell.com/rohm/ba178m18fp-e2/linear-reg-fixed-18v-0-5a-to-252/dp/2343131

 

I also checked the pod for signs of a problem, looks like it is ok. Nothing burned, smoky, smelly or melted.Caps looks alright too. But i am going to replace the two laydown 10uF16V  on  the upper side of the pcb with 10uF50V Panasonics, that left. I don't know what are they for, but the new caps are better than originals, so don' think it hurt something  

post #89 of 378

Some good stuff!  :smile:

 

 

So! In one word - AWESOME! For the little time that i can test before stop, my toughs are, that the overall sound is more realistic, the bass is deep and tight, soft but not overly. The midrange are somewhat more in front, the highs are little bit harsh, but i kinda like it. I suppose that caps need some time to burn in, so i have no patience to fix the problem with regulators.

 

Cheers

post #90 of 378

i have another board here... with basically everything off except SMD... i have checked alll components to the other boards readings and the all match up except for one capacitor where it reads fromm 220 to 0 and jumps between the two... where the other stay at a constant 170uf +- a few but some variables arnt the same... the caps are in on the second board where as on my main board the 47uf caps are out at the minute... dont know if that would make a difference but i will have to stick em in and check... other than that one cap all the smd's are reading fine according to the other board and all have good continuity to the board... something i have just noticed... is as i have been scratching the rosin away from the board... i have actually scratched the board away (where it should be green between the pins it is now brown and lower than the surrounding green board... not sure if this would create a problem but when i had probs with the front right and center+FL .. i have modded some boards in and removed there tracks right back upto the smd components... then soldered wires straight onto the smd components and they work fine... i have clearly been to rough with this and think the only way forward now is to check that one cap out (with both boards being the same and having same components on them) and then look at removing the tracks and doing what i did last time... it dunt look good but it worked... and these little adapters have bigger pads and are easier to work with... we will call this now my practice board :) lol as the other board is now in better condition (shame)... we will see what happens... i have noticed that the sub peices go under the board like you said and go to the caps on the underside and on the other op-amp return to the top side of the board to go to the square bulk of resistors on op-amp U14 ... i will take all tracks into acount (U14 being the only one more diffucult) and make sure things connect back up properly... in everything else i have done i have never had some many problems like these op-amps are giving me... i am sure in the end it will return to life :)

 

when i run the system with no pod... i know my regulators done even get hot... its only when i use the pod... then the regs burn up... i measured something like 75-85 C (cant remember) from the heatsink i have sat on my regulators... which from the datasheet is optimum temp range... i could not test properly without the heatsink as could not attach the probe properly. i found some v-regs from china... they are the exact same ones that are used in the z5500 (they are hard to find) but they are only sold in packs of 20... i messaged the guy and asked if he would do 10 of the 79m18 and 10 of the 78m18 and he said yes... but they was going to cost alot and i was just sourcing at that time just incase... if you want i can post you the links for the items... but when i added up it was going to be something like £20-£30 for 10 of each. if you end up wanting to get some in then please PM me.. as maybe we can put some money together and get some in of both types... upto you on that one.

 

the regs might just be getting old and running hot... then thermally cutting out... if they are getting hot with no pod connected then i would look into that as all i can tell you is mine run really cold when no pod is used... you might have to let the system use the pod and cut out like you say it does... the measure the voltage from the regs and see if they are putting the voltage out.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Almi's Logitech Z-5500 Mod (High-End upgrade for the speaker system)