Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 371

post #5551 of 9297

Hiss hasn't been an issue for me with IEM's such as IE800 or AKG K3003.

post #5552 of 9297

some may interested in DIY a Theme for his/her X3, here is the link  http://www.head-fi.org/t/684793/diy-your-own-theme-for-your-lovely-x3

 

and please discussing in the thread if you want to DIY your own Theme.

post #5553 of 9297
Quote:
Originally Posted by JamesFiiO View Post

some may interested in DIY a Theme for his/her X3, here is the link  http://www.head-fi.org/t/684793/diy-your-own-theme-for-your-lovely-x3

and please discussing in the thread if you want to DIY your own Theme.

Awesome news James! You and your team just keep coming through for this amazing device. I continue to have no qualms recommending this and other Fiio products.

I'll post in the other thread about my experience using the tools when I get a chance. One comment:

The tools are only for Windows. Any plans to develop Mac versions? I use both operating systems so it's not a problem for me, but it might be for others that are Mac exclusive.

Dale
post #5554 of 9297
Quote:
Originally Posted by BigAund View Post
 

Thanks. How is it with IEMs, does it suffer from being very 'hissy'? I have UM Merlins and I get a fair bit of Hiss from the Ipod, less from the Clip, and loads from My S4!

 

No hiss. I'm coming from the JH5 and UERM and both are sensitive customs probably similar to your Merlins. The volume control is great as well if you have issues with low headroom for volume like I usually do.

post #5555 of 9297

I sold the dx50 because of the hiss (and it's not that much), but the X3 is very very clean. no hissing issue with jh13 or 334.

 

 

oh and ofc James thx a lot. that's a brilliant idea.

post #5556 of 9297
This is fantastic James. I'd love to see some nice themes. I'll give it a look. Does this mean the firmware is open for development or will it only give access to the files in a way that themes are the o ly thing that can be customized? Iwonder because if we had source we could maybe help iron out errors and bugs
post #5557 of 9297
I've heard enough to give it a go and I've lost my Clip Zip so I'm ordering an x3.
post #5558 of 9297
Quote:
Originally Posted by BigAund View Post

I've heard enough to give it a go and I've lost my Clip Zip so I'm ordering an x3.
You won't regret it, I listen to it as much as possible.
post #5559 of 9297
Quote:
Originally Posted by castleofargh View Post

I sold the dx50 because of the hiss (and it's not that much), but the X3 is very very clean. no hissing issue with jh13 or 334.


oh and ofc James thx a lot. that's a brilliant idea.
What headphones were you using with it, I ask because I bought one, I have not received it yet so I have not heard it yet.
post #5560 of 9297

I received my X3 today.  The first thing I did was install the 1.31 firmware on a SD card and do the update like I saw in a youtube video that I found online.  After the update the Fiio splash screen comes up.  The writing is in Chinese.  Every time I try to press a button to move up or down I get a popup message with an exclamation point with the writing in Chinese so I have no idea what is wrong.  I charged it for 1 hour so could it possibly be a low battery message?  

 

Also, the screen protector has a Fiio white sticky tab on it that will not peel off without leaving a paper residue.  

 

I am frustrated and this is not a good first impression,  I cannot even select a different language like I saw in the youtube video so I can navigate.

post #5561 of 9297
Quote:
Originally Posted by GregC View Post

I received my X3 today.  The first thing I did was install the 1.31 firmware on a SD card and do the update like I saw in a youtube video that I found online.  After the update the Fiio splash screen comes up.  The writing is in Chinese.  Every time I try to press a button to move up or down I get a popup message with an exclamation point with the writing in Chinese so I have no idea what is wrong.  I charged it for 1 hour so could it possibly be a low battery message?  

Also, the screen protector has a Fiio white sticky tab on it that will not peel off without leaving a paper residue.  

I am frustrated and this is not a good first impression,  I cannot even select a different language like I saw in the youtube video so I can navigate.

It sounds like your player got put in Chinese language mode right after the update. Have you tried a reset using a paper clip or similar in the hardware reset hole on the top of the unit? After it reboots you should be able to choose the English language on the first screen that appears.

If that doesn't work, go back to Fiio's website and re-download the firmware and try the update again:

http://www.fiio.net/firmware_download/X3-FW1.31.zip

or

http://dl.vmall.com/c0h8xtv7wu

As for the sceen protector, sorry, peeled my first one off and never bothered with either of the other two that were included. Didin't like the look and feel of them.

Dale
post #5562 of 9297
Quote:
Originally Posted by GregC View Post
 

I received my X3 today.  The first thing I did was install the 1.31 firmware on a SD card and do the update like I saw in a youtube video that I found online.  After the update the Fiio splash screen comes up.  The writing is in Chinese.  Every time I try to press a button to move up or down I get a popup message with an exclamation point with the writing in Chinese so I have no idea what is wrong.  I charged it for 1 hour so could it possibly be a low battery message?  

 

 

 

You HOLD switch is on....

Move the hold switch on the side up to put the unit OFF hold.
you won't get the message with the exclamation mark then. 

post #5563 of 9297
post #5564 of 9297
Quote:
Originally Posted by AgentXXL View Post


It sounds like your player got put in Chinese language mode right after the update. Have you tried a reset using a paper clip or similar in the hardware reset hole on the top of the unit? After it reboots you should be able to choose the English language on the first screen that appears.

If that doesn't work, go back to Fiio's website and re-download the firmware and try the update again:

http://www.fiio.net/firmware_download/X3-FW1.31.zip

or

http://dl.vmall.com/c0h8xtv7wu

As for the sceen protector, sorry, peeled my first one off and never bothered with either of the other two that were included. Didin't like the look and feel of them.

Dale

 

Thanks for your tips.  The X3 is fully charged and I can do the 1.31 update and it says success.  When the first screen comes up with Language selection there is some box with an exclamation point and the device reboots without allowing me to choose a language.  As soon as I starts there is a screen with everything in Chinese and a message in a box with an exclamation point.  I cannot use the up or down arrows and I cannot read Chinese to know what the message says.    Nothing happens when I use the reset button.  This will most likely have to be returned and I will stick with my Sansa.  The E6 I got failed within hours and now this cannot even start up.  The E07K was very good quality and worked as expected.  I am disappointed.

post #5565 of 9297
Quote:
Originally Posted by GregC View Post

Thanks for your tips.  The X3 is fully charged and I can do the 1.31 update and it says success.  When the first screen comes up with Language selection there is some box with an exclamation point and the device reboots without allowing me to choose a language.  As soon as I starts there is a screen with everything in Chinese and a message in a box with an exclamation point.  I cannot use the up or down arrows and I cannot read Chinese to know what the message says.    Nothing happens when I use the reset button.  This will most likely have to be returned and I will stick with my Sansa.  The E6 I got failed within hours and now this cannot even start up.  The E07K was very good quality and worked as expected.  I am disappointed.

As undersys mentioned above, check your hold switch on the side of the unit. The only time you typically see the exclamation point (with a triangle around it) is with the hold switch engaged.

Dale
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.