Head-Fi.org › Forums › Equipment Forums › Computer Audio › How to automatically switch/bypass sample rate?
New Posts  All Forums:Forum Nav:

How to automatically switch/bypass sample rate?

post #1 of 15
Thread Starter 

This just might be a really dumb question, but is there a way to bypass the set windows sample rate, so when I play my music through Winamp, they are played in the same sample rate as the input?

 

I have a bunch of music and most of it is in 44khz but a also got a lot in 48khz and 96khz. Is it possible to have the sample rate automatically switched to that of the input signal?

 

I am running Winamp on Windows 7 and my soundcard is the Asus Xonar Essence ST.

 

Thanks a lot for the help.

post #2 of 15
Thread Starter 

Really? No one has a way?

post #3 of 15

With an Asus card such as yours ASIO output does just what you need. However it mutes all other sounds (but if you're ok with that then you can forget about the sampling rate settings as it will bypass them and send untouched audio straight to the card) There's also WASAPI (which bypasses the windows stuff) but it doesn't bypass the Asus Xonar control panel/mixer so you'd have still have to change the setting there. 


Edited by kalston - 7/15/12 at 11:43am
post #4 of 15
Thread Starter 

There are a couple different types of WASAPI. Which one should I get for Winamp and how do you set it up to automatically choose the sample rate of the input song without muting all other sounds?


Edited by DamageInc77 - 7/15/12 at 12:14pm
post #5 of 15
Thread Starter 

Bump. Is there really nothing to fix this?

post #6 of 15

ASIO, WASAPI, KS.

post #7 of 15
Thread Starter 
Quote:
Originally Posted by Szadzik View Post

ASIO, WASAPI, KS.

I tried ASIO and it will not work in my system. WASAPI blocks all other souinds, so that's useless. Kernal Streaming will work 50% of the time, but sometimes will block other sounds. I need something to do exaclty what WASAPI is doing, but without blocking other sounds.

post #8 of 15

Then Windows XP with DS or KS is the only thing that comes to my mind. On XP Directsound switches the sample rate on its own unlike in 7. And KS does not mute all other sounds in XP with a Xonar card (at least it never did for me). 

post #9 of 15
Quote:
Originally Posted by DamageInc77 View Post

I tried ASIO and it will not work in my system. WASAPI blocks all other souinds, so that's useless. Kernal Streaming will work 50% of the time, but sometimes will block other sounds. I need something to do exaclty what WASAPI is doing, but without blocking other sounds.

 

That is how they work. In order to bypass Win's sample rate conversion, they need exclusive access to the soundcard. Pretty obvious. 

 

Whatever you do, there is no way to do it without exclusive access to the hardware.

post #10 of 15

Just use Direct Sound guys, works fine, and probably you`ll hear no difference, with pc setup.

 

even Foobar FAQ (http://www.foobar2000.org/FAQ) recommends it, btw trash the asus card.

post #11 of 15
Quote:
Originally Posted by DamageInc77 View Post

I tried ASIO and it will not work in my system. WASAPI blocks all other souinds, so that's useless. Kernal Streaming will work 50% of the time, but sometimes will block other sounds. I need something to do exaclty what WASAPI is doing, but without blocking other sounds.


Will not work?  Are you using the latest drivers for your card from the ASUS site?  Early versions, did not automatically set the sampling rate when using ASIO but it was added to later driver revisions.  If WASAPi works better for you but you want to hear other sounds, you need to make a setting change in the system control panel for the card (not the Xonar panels), look for the setting "Allow applications to take exclusive control of this device."

 

If you uncheck that it should give you autosample rate adjustment and still allow other audio streams through.

 

Hope that helps.


Edited by ROBSCIX - 7/17/12 at 2:06pm
post #12 of 15
Thread Starter 
Quote:
Originally Posted by sonci View Post

Just use Direct Sound guys, works fine, and probably you`ll hear no difference, with pc setup.

 

even Foobar FAQ (http://www.foobar2000.org/FAQ) recommends it, btw trash the asus card.

Why would I trash the Asus card? It works brilliantly apart from the ASIO.

 

Quote:

Originally Posted by ROBSCIX View Post


Will not work?  Are you using the latest drivers for your card from the ASUS site?  Early versions, did not automatically set the sampling rate when using ASIO but it was added to later driver revisions.

Yeah. I turn it on in the Asus Audio Center and it does absolutely nothing.

 

I went and tried the DirectSound plugin, and I figured that it was the best compromise.

post #13 of 15
Quote:
Originally Posted by DamageInc77 View Post

Why would I trash the Asus card? It works brilliantly apart from the ASIO.

Yeah. I turn it on in the Asus Audio Center and it does absolutely nothing.

 

I went and tried the DirectSound plugin, and I figured that it was the best compromise.

Yes the ST is one of the best audio sources you can get for a PC at that price point.


You are supposed to set it to OFF so other programs can access the card.

If you are using directsound, you are getting resampling again which is why many started using ASIO in the first place to avoid the resampling forced by Direct sound and the Kmixer.

 

I am talking about the setting the main control panels for audio in your OS.  Not the Xonar panels.

It is a small check box "Allow applications to take exclusive control of this device."  You need to uncheck this.

 

However, you will only notice a difference is you are using a true Bit-perfect plugin such as ASIO and using the proper driver revision that allows

true ASIO support.

So what is going on with your ASIO, what happens when you try and use it?

Are you using the latest ST driver revision from ASUS?


Edited by ROBSCIX - 7/17/12 at 2:31pm
post #14 of 15
Thread Starter 

I am using the lastest drivers from the Asus website. 

 

The Exclusive control box IS unchecked.

 

When I try to use ASIO nothing at all happens. I turn it on and it's the exact same as off. Zero difference.

post #15 of 15

I have an Asus Xonar card and I'm experiencing problems...

Asus Xonar cards are infamous for their buggy drivers. We recommend getting a soundcard from another manufacturer instead.

If you're running foobar2000 older than 1.1.10, please update - version 1.1.10 introduces workarounds for certain known Xonar bugs.

 

..nothing personal

 

I think Foobar and Winamp should be pretty much similar, I remember using ASIO otachan plugin for winamp, which was good, dont know if they updated to an official plugin,

you should disable any DSP effects in the output.


Edited by sonci - 7/18/12 at 7:14am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › How to automatically switch/bypass sample rate?