Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › [Impression] FiiO E10
New Posts  All Forums:Forum Nav:

[Impression] FiiO E10 - Page 64

post #946 of 1259
Thread Starter 
Quote:
Originally Posted by H20Fidelity View Post

I received a faulty E10 today.


The volume pot doesn't work properly. When you plug it in sound comes straight out of it at 0 on the volume control, this continues until you turn it past 2 then it starts to perform normally. When turning the volume back down it does the same thing and continues to put out sound. After trying another USB cable I then noticed the amps input mini usb port is also loose and effects the sound if wiggled lightly. I have sent it back to be checked and replaced which I had to pay for.  


This is unfortunate, as I already had one in perfect working order and sold it. This was a repurchase. frown.gif
Sound like something bad happens in shipping that would cause that much damage. Hopefully yours will get replaced soon.
Quote:
Originally Posted by LoveKnight View Post

If yours is a reversion than you how you could notice that there has an sound improvement on old Fiio E10s? Do you have two Fiio E10? Is it better than the old version? I find out my Fiio E10 is fine as a DAC but the ampli function is just normal. My Fiio E10 can drive HD598 at decent volume but the smooth, mellow of HD598 are the parts that Fiio E10 can not bring it out. Maybe that is why I am saving money and looking for a new separate AMP.

Even if it is reversion, it is most likely just using a new brand of headphone jack (FiiO already talks about replacing the old jack with a different brand a few months back). It won't really affect the sound in that case,
post #947 of 1259
Thread Starter 
Confirmed with FiiO that the new batch is just a headphone jack change. The new jack will work with headphone that have the TRRS jack (iPhone mic, etc). The 7ms mute issue has also been solved. However, not on the new batch but on the previous batch. Other than these, the new E10 should sound just like the old E10.
Edited by ClieOS - 6/16/12 at 5:02am
post #948 of 1259

I have an early version (but certainly not the first one) without the gold plated jack but I have no problems with the jack or anything, except maybe it feels a bit flimsy. Am I one of the lucky few or what?

post #949 of 1259

My new E10 arrived! everything is working fine. I had a new one arrive in four days including the weekend. etysmile.gif

  

post #950 of 1259

I'm planning to buy an E10 in a couple of weeks, but I'd love if someone could confirm if the small delay or muting has been, in fact, fixed in the last batch. I thought it was a design problem and was not easily fixed.

post #951 of 1259
Thread Starter 
Quote:
Originally Posted by FreemanPhD View Post

I'm planning to buy an E10 in a couple of weeks, but I'd love if someone could confirm if the small delay or muting has been, in fact, fixed in the last batch. I thought it was a design problem and was not easily fixed.

That is a comparability issue between the USB chip and the SPDIF chip as they are not fully in sync. I believe FiiO redesigned the circuit to address that issue.
post #952 of 1259
Quote:
Originally Posted by Lausers View Post

For the Canadians on this forum,  Headphonebar out of British Columbia is selling Revision 3 of the Fiio E10 with the name "Olympus" displayed on the case: http://www.headphonebar.com/fiio-e10-olympus/

 

No issues with static while moving the headphone cable and cracking/popping noises in between songs.  Definitely can notice the difference in sound quality compared to the onboard DAC of my desktop.  Big thing i noticed is that the mids have more depth.  Everything is more controlled.   Pretty happy with my purchase. 

 

 

Are you getting this problem: http://www.head-fi.org/t/575084/impression-fiio-e10/930#post_8447677

post #953 of 1259
I need a replacement cable for my e10 . Would this do? http://www.meritline.com/usb-a-male-to-usb-min-5-pin-male-cable---p-40103.aspx
post #954 of 1259
Thread Starter 
Quote:
Originally Posted by semmio View Post

I need a replacement cable for my e10 . Would this do? http://www.meritline.com/usb-a-male-to-usb-min-5-pin-male-cable---p-40103.aspx

Yes.
post #955 of 1259
Quote:
Originally Posted by semmio View Post

I need a replacement cable for my e10 . Would this do? http://www.meritline.com/usb-a-male-to-usb-min-5-pin-male-cable---p-40103.aspx


Yep, it sure will. As long as it's a DATA cable, just be careful because some cheaper cables on ebay only run power not data.

It's exactly the same cable you would use to charge your PS3 controller.

Edit: ClieOS beat me to it. Hi ClieOS! *waves* smile.gif


Edited by H20Fidelity - 6/27/12 at 9:58pm
post #956 of 1259

Mod.

IMG_0004.JPG

 

Elna Silmic 2 + Wima FKP-2. 4.7UF was used Panasonic BP. It sounds much better now.


Edited by PDOT - 6/30/12 at 1:37am
post #957 of 1259
Thread Starter 
I don't suppose it will fit in the original case anymore? biggrin.gif
post #958 of 1259

Everything is fitted into the original box.


Edited by PDOT - 6/30/12 at 11:28am
post #959 of 1259
Quote:
Originally Posted by DudeBro View Post

 

 

Are you getting this problem: http://www.head-fi.org/t/575084/impression-fiio-e10/930#post_8447677


Hello,

 

I can confirm that with the new Fiio E10 Olympus that there is no 0.7 ms delay.  Hope this helps.


Edited by Lausers - 7/1/12 at 5:45pm
post #960 of 1259

I have never bought an amp or DAC... Im running my CALs just through my windows and while its juuuusst loud enough, im wondering if the e10 would sound alot better than a decent soundcard on a computer and low impedance phones like mine.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › [Impression] FiiO E10