Head-Fi.org › Forums › Misc.-Category Forums › Feedback & Bug Reports › Amazon.com ad is causing Head-Fi browser to respond extremely slow when it shows up.
New Posts  All Forums:Forum Nav:

Amazon.com ad is causing Head-Fi browser to respond extremely slow when it shows up.

post #1 of 26
Thread Starter 

The title says it all.  There is an Amazon.com ad which is an animated one which has bars showing its loading progress and scrolls through different products.  Everytime this happens the site virtually locks up.  Clicking or scrolling anywhere on the site is at a 5-10 second stand still until the ad loads.

 

This ad is obviously up because Head-Fi is an "AmazonAssociate" and has placed a widget on this site, showcasing headphones.  They get revenue from every item sold through the widget, but at what cost?  If it's causing this site to constantly lock up, surely it isn't something they'd want to keep around, would they?


Edited by IPodPJ - 4/1/11 at 10:34pm
post #2 of 26
Thread Starter 

Any response to this Jude?  I am not using Firefox 4.  This happens with Firefox 3.

While this widget is loading, I cannot do anything for about 5-10 seconds.  This reloads with every URL click.

 

Picture 2.png

 

 

Picture 1.png


Edited by IPodPJ - 4/12/11 at 2:58pm
post #3 of 26
Thread Starter 

Well this problem seemed to had gone away this past week, but now it's back and even worse than before.

post #4 of 26

I haven't bothered tracking down a specific ad, but I've noticed this problem with Head-Fi on several PCs. Firefox freezes for a few seconds while loading the page. It's so slow that I avoid Head-Fi if at all possible. No other sites I visit have this issue.

Reply
post #5 of 26
Thread Starter 
Quote:
Originally Posted by jseaber View Post

I haven't bothered tracking down a specific ad, but I've noticed this problem with Head-Fi on several PCs. Firefox freezes for a few seconds while loading the page. It's so slow that I avoid Head-Fi if at all possible. No other sites I visit have this issue.


Yes, it's really terrible.  I am forced to use Google Chrome when I visit Head-Fi which I do not like as much as Firefox.  No other website has this issue.  Other people have PMed me just telling me they use pop-up blockers to avoid it, but I don't think that's fair to the sponsors who pay for advertisement so I won't use them.  I do think Head-Fi needs to fix this problem though, and not sure why it only happens here but nowhere else.

 

post #6 of 26

I must agree - sadly, navigating Head-Fi has become like wading through treacle lately... mad.gif

post #7 of 26
This is a recurring theme unfortunately. Today was slow as molasses. It seems like about every week or so there's a day where the page doesn't even start to load until about 5- 8 seconds later.
post #8 of 26
Noticed it again today with the latest Firefox and Opera. The page loads but you sometimes have to wait 5+ seconds before you can click anything while the Amazon server is being accessed. I'm guessing it's probably on their side but still annoying.
Edited by Permagrin - 5/19/11 at 6:32pm
post #9 of 26

I'm not sure if its only the amazon site that is slowing everything down.  but its really becoming painful just checking a simple post.  If this doesnt get cleaned up quick, I may just jump ship.  I already come here about half as much as I used to.  This new format was supposed to be better.  Sure it looks shiny and new, but it pretty much sucks from a user standpoint.  Kind of like a car from GM..

post #10 of 26
Yeah I was thinking it's probably not just Amazon. Right now for me though it's loading like normal using Opera. You're saying it's slow right now Keith?
post #11 of 26

yes.  its taken me 12 seconds to go from the email link, to this page to write a comment.  the page was completely loaded by the time I finished writing this note.  so add an extra 10 seconds.  I'm using safari browser.  I will not change browsers just to make this site function correctly.  what a pain.

post #12 of 26
Thread Starter 
Quote:
Originally Posted by Permagrin View Post

Yeah I was thinking it's probably not just Amazon. Right now for me though it's loading like normal using Opera. You're saying it's slow right now Keith?


I think it is just the Amazon widget because you can't do anything on the site until you see the widget progress bar finish loading.  I hate Google Chrome because it's slow with everything else but it's the only browser that works on Head-Fi so I have to use it to come here.  Otherwise it is impossible to read through, like you said it takes over 10 seconds per page load.

 

post #13 of 26
I don't know whether this is the same problem, but I had to briefly use a friends PC today, and head-fi without ad-blocking was terrible. His firefox 4 froze on every page and the 'javascript hogging up resources' alert appeared (pretty much every head-fi page caused firefox to lock up). (blablabla the script on the page is not responding would you like to stop it. Or something of the sort)
Edited by svyr - 5/22/11 at 8:19am
post #14 of 26

I get the same thing sometimes, all sorts of script errors and the screen even flashes when I scroll. No other problems with any other websites. Even when it is not doing that the ads cause problems. annoying.

post #15 of 26

I recently started a thread asking about this as well.  It seems like there are some pretty major problems with the site.  I know I hardly come in here anymore as it is just painful to deal with the slower-than-dial-up speed of the site at this point.  I was timing the average load up time of pages (any page) and it was around 35 seconds.  As an example, just to log in to the home page and click on the forums tab and get to the listing of forum categories took close to two minutes.  That is pretty much a "broken" website IMHO.

 

I hate bitching about this as, in the larger scheme of things, having to wait for 40 seconds is hardly a horrifying situation.  It's just that, with this being such a great site and wealth of information, it is super frustrating to see it's functionality crippled like this.

 

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Feedback & Bug Reports
Head-Fi.org › Forums › Misc.-Category Forums › Feedback & Bug Reports › Amazon.com ad is causing Head-Fi browser to respond extremely slow when it shows up.