or Connect
New Posts  All Forums:Forum Nav:

null audio - Page 2

post #16 of 22

 

JiPod, any news on your order?

post #17 of 22

I asked Null a question about one of their cables over a week ago and have yet to receive a response.

post #18 of 22

 

Datapoint: I sent a query about their cables on May 17, and received a reply on May 20. 

 

I've since decided not to order the cable since I wasn't totally clear he understood what I was interested in and I didn't want to pay that much for something we weren't totally in sync about.

 

-john

post #19 of 22

hi has anyone received a response lately from null audio because i have sent about 3 different emails from their contact us section and still no response. once i get my triple fi 10 i want a cable from null but apparently no one is receiving responses so i dont want to purchase something and risk not getting it.

post #20 of 22
Its been over 4 years I know but had Null gained any more respect as online retailer? Would like to buy from them but some posts putting me off, thanks
post #21 of 22
Quote:
Originally Posted by KT66 View Post

Its been over 4 years I know but had Null gained any more respect as online retailer? Would like to buy from them but some posts putting me off, thanks

I ordered a cable from them a few weeks ago.  While shipping was quick and responsiveness pre-sale was great, something was definitely off.  They sounded almost hollow with strange, asymmetric imaging.  Finally, after listening for a few days, I decided to check the wiring -- lo and behold, the right channel had been mis-wired and polarity reversed.  

 

Kevin just told me they were making a replacement to ship to me; I will update when I get it.  Hard to extrapolate from a sample size of one, but that's been my experience.  

post #22 of 22
Hi guys need some help....

I bought the Null Audio Arete series cable for my JH16s.

Sound is fantastic.

The only problem is is that the right pin side of the cable is severely loose. As in, when I put them into my right JH16, they'll pretty much slip out in its own??!!

I've contacted Null Audio but so far they're unhelpful. I'd rather not have to send it back and wait anyway.

Anyone know of a way I can fix it??

Any help is very much appreciated

Ed
New Posts  All Forums:Forum Nav: