Why is ASIO4all so unreliable on my rig?
Mar 20, 2007 at 12:46 AM Thread Starter Post #1 of 15

makasin

100+ Head-Fier
Joined
Jun 28, 2006
Posts
465
Likes
0
Ok so I have been having the same problem for the longest time and I cannot seem to figure it out. I have an AlienDAC plugged into my laptop that FallenAngel made for me. When I first plug the dac into the power supply and connect it to my computer, windows recognizes it fine and when I open up ASIO4all, I see "USB Sound" in green. I start up some songs in Foobar and it all works gravy...until I stop playing. Then, the next time I want to play through ASIO, I get a "cannot start ASIO device" error in foobar and no sound. Kernel Streaming also refuses to work. Its weird because I even set it up so that windows doesnt map to the device, so things should work. Can anyone shed some light on this?
Im using the latest version of foob, and ASIO4all 2.7
 
Mar 20, 2007 at 12:53 AM Post #2 of 15

echo1

100+ Head-Fier
Joined
May 8, 2006
Posts
341
Likes
11
I cant get foobar to work on my UD-10 transport. What I did was try different players and was able to get it to work in winamp.I might have got it to work with reinstalling windows but that a pain.A suggestion is trying different players and maybe one will work. Winamp was the one for me.
 
Mar 20, 2007 at 1:15 AM Post #5 of 15

makasin

100+ Head-Fier
Joined
Jun 28, 2006
Posts
465
Likes
0
I installed 1.8 and got the same thing. I made sure to uninstall 2.7 and configured it properly. Are there any special settings I can mess with to make it so only foobar has permission to use the device or something? It's not ideal, but itll do. Are there any options in "System" that I should be aware of? I set to "do not map through this device" but was hesitant to click "do not use midi/sound/etc. features on this device" for fear of it not working at all. Is this what I want though?
 
Mar 20, 2007 at 2:15 PM Post #6 of 15

EnOYiN

Headphoneus Supremus
Joined
Jan 13, 2007
Posts
2,269
Likes
18
Most likely it's an energy saving problem. There is a fuction somewhere that says something like: the computer may shut this device down to save energy
I am not sure where to find it exactly anymore.

It could also be the power states intel and AMD have got. There is a power state that will try to shut down USB ports in order to save energy.
 
Mar 21, 2007 at 4:01 AM Post #7 of 15

makasin

100+ Head-Fier
Joined
Jun 28, 2006
Posts
465
Likes
0
Yeah but why would this state be triggered when I am running off AC?
Ive set my power saving stuff so it doesnt do any energy saving stuff when its plugged in basically.
 
Mar 21, 2007 at 11:14 AM Post #8 of 15

EnOYiN

Headphoneus Supremus
Joined
Jan 13, 2007
Posts
2,269
Likes
18
Quote:

Originally Posted by makasin /img/forum/go_quote.gif
Yeah but why would this state be triggered when I am running off AC?
Ive set my power saving stuff so it doesnt do any energy saving stuff when its plugged in basically.



You are using Windows XP? ( just to get it clear
biggrin.gif
)

It can't be the P-state transitions of intel or the equivalent of it coming from AMD.

However the other option is still active most likely. I am going to look it up for you since it is not even slightly near to the other energy saving options.

So, you should go to: (it's my own translation since I am not working on a English machine right now - forgive the mistakes there might be)
Configuration screen>System>Hardware>Device management

In the device management menu there should be something USB-controllers
Within this tab there are USB-mainhubs. Click on them with your right mouse button and select properties. There should be a tab called Energy management. There are only 2 functions in this tab. One of them is on by default and that is the "The computer is allowed to shut down this device in order to save energy" one. Disable it on every USB-mainhub. Check if it works right now.

**I explained this in a very simple way. Not that I think that you are a retard, but just because I have no idea how much you know about the inner workings of windows.

The only thing left to do is to check whether this made a difference.

Cheers.
 
Mar 21, 2007 at 2:25 PM Post #9 of 15

pedxing

1000+ Head-Fier
Joined
Aug 25, 2001
Posts
1,479
Likes
12
A bad combination of BIOS, Windows XP, and USB chip can ruin your day. Enoyin has a good point about this stuff. The implementation and behavior of USB defies logic. Sometimes it can be a simple configuration issue with the power that can fix all these strange problems. At this point, I think its pretty tough for any of use to troubleshoot this problem without trial and error.

But as time goes on, it seems like the manufacturers and vendors are fixing many of the problems. A few years ago, Windows XP had a uglyl patch just to prevent USB peripherals drawing full power at all time while the laptop is in hibernation/stand-by mode. That patch caused a lot of headaches with some older USB products.
 
Mar 23, 2007 at 7:01 AM Post #10 of 15

tbritton

500+ Head-Fier
Joined
Dec 2, 2006
Posts
702
Likes
81
Location
Elizabeth City, NC
There is another version of Asio4All that worked better for me with my Aardvark DirectPro 24/96, and additionally possessed some extra features than the Winamp download version. Please refer to this post to read about it.

Terry
750prolinebx3.png
 
Mar 24, 2007 at 6:49 AM Post #11 of 15

makasin

100+ Head-Fier
Joined
Jun 28, 2006
Posts
465
Likes
0
Quote:

Originally Posted by EnOYiN /img/forum/go_quote.gif
You are using Windows XP? ( just to get it clear
biggrin.gif
)

It can't be the P-state transitions of intel or the equivalent of it coming from AMD.

However the other option is still active most likely. I am going to look it up for you since it is not even slightly near to the other energy saving options.

So, you should go to: (it's my own translation since I am not working on a English machine right now - forgive the mistakes there might be)
Configuration screen>System>Hardware>Device management

In the device management menu there should be something USB-controllers
Within this tab there are USB-mainhubs. Click on them with your right mouse button and select properties. There should be a tab called Energy management. There are only 2 functions in this tab. One of them is on by default and that is the "The computer is allowed to shut down this device in order to save energy" one. Disable it on every USB-mainhub. Check if it works right now.

**I explained this in a very simple way. Not that I think that you are a retard, but just because I have no idea how much you know about the inner workings of windows.

The only thing left to do is to check whether this made a difference.

Cheers.



Thanks a lot! I think may just fix my problem. I will let you know what happens.
 
Mar 24, 2007 at 11:20 AM Post #12 of 15

tbritton

500+ Head-Fier
Joined
Dec 2, 2006
Posts
702
Likes
81
Location
Elizabeth City, NC
Quote:

Originally Posted by EnOYiN /img/forum/go_quote.gif
You are using Windows XP? ( just to get it clear
biggrin.gif
)

It can't be the P-state transitions of intel or the equivalent of it coming from AMD.

.................
In the device management menu there should be something USB-controllers
Within this tab there are USB-mainhubs. Click on them with your right mouse button and select properties. There should be a tab called Energy management. There are only 2 functions in this tab. One of them is on by default and that is the "The computer is allowed to shut down this device in order to save energy" one. Disable it on every USB-mainhub. Check if it works right now.



Wow! Thanks for that one! I'll definitely be filing that piece of info away!

Terry
750prolinebx3.png
 
Mar 24, 2007 at 10:19 PM Post #13 of 15

EnOYiN

Headphoneus Supremus
Joined
Jan 13, 2007
Posts
2,269
Likes
18
Quote:

Originally Posted by tbritton /img/forum/go_quote.gif
Wow! Thanks for that one! I'll definitely be filing that piece of info away!

Terry
750prolinebx3.png



Note that it could be. It doesn't have to be the cause, I am just guessing and since most people do not know of this energy setting or forget to look at it, it is likely it's the thing that is shutting USB-devices off.
 
Mar 28, 2007 at 1:22 AM Post #15 of 15

makasin

100+ Head-Fier
Joined
Jun 28, 2006
Posts
465
Likes
0
Yeah, this was the cause of the problem. It works now. Yay! thanks for the help!
 

Users who are viewing this thread

Top