USB DAC not detecting even through powered hub (Modi+Wyrd)

Discussion in 'Computer Audio' started by crapmonster, May 16, 2015.
Page 1 of 2
2
Next
 
Last
  1. crapmonster
    So I've been using a Modi for awhile now on my computer which hasn't gone through any recent changes.  However the DAC started to fail a couple weeks ago.  Upon turning on my computer, it would simply be undetected, and I would have to play a game of unplugging it, and plugging it back into various USB ports and this would usually resolve it.
     
    However as the week went by, one day it simply failed to detect properly no matter what I did.  At the time, I assumed this was likely a power issue so ordered a Wyrd to resolve this.  And sure enough once I got it and put it in, it immediately started to work again.  However the next time I powered on, I was faced with the exact same issue.  It wasn't detecting, and I had to unplug, turn it off/on, and try different ports until it magically detected.
     
    But now a few days later, no matter what I do once again it is no longer detecting.  It seems as if Wyrd is detected fine, as I get the generic usb hub installed message, but then its followed by "installing device driver software" then "....was not successfully installed."
     
    My next thought is to think something might be wrong with the DAC itself, but I've test it on my Macbook as well and it seems to function perfectly fine on there, even running off of USB power only.  Subsequently aside from the DAC failing, my USB ports seem to be fine.  I've tried plugging various other peripherals into them, and they seem to function without issue.
     
    At this point, completely at a loss at what to try next.  So any thoughts/ideas on the matter would be appreciated.
     
  2. Roseval
    Pretty hard to trouble shoot.
    Bad connector?
    DIfferent port?
    Different cable?
     
  3. crapmonster
    Yea I've already tried different ports.  The cables are fine as well. I've tested them on other things in addition to using them to hook up the DAC to my macbook instead of my PC, and it worked fine.
     
    In addition, after turning Wyrd off/on while waiting for random periods of time I did manage to get it to work finally.
     
    However the larger issue of why it has so much trouble detecting and running properly upon launch is still there.  I fully expect tomorrow when I turn my computer back on, I'll have to go through this whole game again of unplugging, turning off/on, until it detects.
     
  4. crapmonster
    So a few days later, still having issues with this.  I managed to get it to work til now by spending ten minutes or so unplugging and powering on/off repeatedly every time I powered on my computer, but today it seems like no matter what I do, the DAC doesn't want to recognize.
     
    And the issue does seem to be the DAC despite using Wyrd in between, as a generic usb hub does show up in the attached devices.  Also something strange I noticed was that if Modi is plugged in when I turn my computer on, it will lock up.  This is either Modi by itself, or powered through Wyrd.
     
    Obviously I figured this was just a case of boot order, so I verified in BIOS and sure enough USB was listed before HDD so fixed that.  However this behavior didn't go away.  With the correct boot order, if the DAC is powered, the system simply will lock up.  This isn't even just the OS not loading, I can't even get to the initial mobo screen where I can access BIOS.  I even tried to turn on Wyrd while in BIOS to see if anything would happen, and sure enough it froze in place.  I couldn't do anything until I turned it off again which I find really strange.
     
  5. Roseval
    That is the weirdest USB DAC problem known to me.
    I know if at boot time a USB storage device is the first, the boot will fail (if no OS on it)
    But a USB audio device seen as a USB storage?
     
    If you open de device manager, see anything weird?
     
  6. crapmonster
    Aside from simply listing it as an unrecognized device, no.  I did eventually get it to recognize today by once again spending half an hour just unplugging it, plugging it back in, switching Wyrd off/on repeatedly until finally Windows recognized it.  I guess I should also mention, that I already tried reinstalling my mobo usb drivers the other day, obviously didn't solve it.
     
    My best guess right now is that Windows must have changed something with the way it manages its ports in one of the recent updates.  I haven't changed anything about my setup and have been using this exact modi dac for a long time with no issues.  And testing it on my macbook, it runs perfectly fine there.  In addition, it doesn't seem as if Wyrd has any issue of being recognized immediately.  Windows always detects it as a generic usb hub, simply with the attached modi being unrecognized.
     
    Then again if that was the case, I'd imagine I wouldn't be the only one here with this issue so who knows....
     
  7. defbear
    I would go into Device Manager and delete the unrecognized device. Shutdown the computer and power everything off. Boot the computrr and wait for it to fully boot. Power on the Wyrd first and then plug it in. See whats in Device Manager. If all looks good, power on the dac and then plug it into the Wyrd.
     
  8. winxp
    1. Do you use fastboot in BIOS? If so, turn it off.

    2. Try to boot PC with DAC power off, and turn it on after login. Unplug the PC power cord for about 10s if necessary.

    I solved my similar problem by the above methods.
     
  9. crapmonster
    As far as I can tell, that isn't even an option for fastboot in my BIOS for my specific mobo.  I run an MSI P67A-G43 if it matters.  Also, as I've already described above, I can't even boot my PC with the DAC powered on anyways, so your second suggestion is irrelevant.  I always turn my DAC on "after" its finished booting.
     
  10. crapmonster
    Doesn't work at all.  If I simply plug in Wyrd by itself, it does detect as a generic usb hub.  This is both by itself and with Modi attached.  I tried your method step for step though, and it didn't make a bit of difference.  Wyrd works, then I plug in Modi and it comes up as unknown device.
     
  11. cdsa35000
    Maybe you got to boot with F8 into safe mode and look into device manager usb list and delete unused/unknown usb device/drivers, maybe too much usb driver crap preinstalled?.
    http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/usb-device-not-recognized-in-windows-7/8106a712-a13e-4ca5-b82e-c3961cc254b1
     
  12. crapmonster
    So as it turns out, I think the issue was Windows power management which is odd to say the least.  After failing to get it to work once again this morning, I tried disabling power saving in the device manager for the USB root hub, this instantly seemed to resolve the issue.  I guess I still have to see what happens the next time I turn my computer on.
     
    The thing is, I hadn't even tried this as both Schiit and pretty much everything else I've read seems to indicate that using a powered hub would get around this 100%.  But if this was the cause, what exactly did Wyrd achieve?  It was suppose to resolve this exact issue, yet it didn't at all.
     
    Also, I still can't figure why I can't have the DAC powered on before I boot my computer.  The fact that it seemingly freezes it is still a mystery.
     
  13. defbear
    Perhaps your computer is trying to boot from the dac.
     
  14. crapmonster
    So the problem came back.  It was seemingly resolved for a day or two once I changed the power settings in both device manager and by editing the registry but that could have honestly been a fluke.  Everyday since then, its been the same.  Boot up, doesn't recognize, and I have to dick around for an hour or so to get the darn thing to work by turning it off repeatedly and replugging cables.
     
    Completely at a loss at what to do at this point.  Contemplating just selling my Modi/Wyrd and trying something else.  However the issue likely remains given its at the point of connection.  Simply running another USB DAC, I have concerns that it will likely be unrecognized.
     
    Given I've been running a USB DAC of some sort for nearly a decade now, not really sure what other options I have past an internal sound card or using onboard mobo sound which is frankly atrocious.
     
     
     
    As stated above already, its something that other posters and I already mentioned.  I took it entirely out of my boot order in BIOS and that particular issue still remains regardless.
     
  15. youchew
    I have this same modi 2 issue, and I was debating whether a wyrd would fix it LOL
    I heard weird buzzing/static so I disconnected it From the USB port and tried connecting it back, now the PC won't recognize the modi at all
    and when it does recognize the modi, it just says "drivers failed to install" or something
     
Page 1 of 2
2
Next
 
Last

Share This Page