This Schiit is Bananas! $99 Schiit Magni Amp and $99 Modi DAC
post-9103956
Post #931 of 1,370

Defiant00

1000+ Head-Fier
Joined
Feb 26, 2011
Messages
1,442
Reaction score
214
Joined
Feb 26, 2011
Posts
1,442
Likes
214
Quote:
I just collected my Modi / Magni combo from Parcelforce this morning.

Couldn't wait to get it back to the office and I am not disappointed. These have a small footprint and sit on my work desk perfectly. The Modi connected to my PC first time and the Magni is unbelievably powerfull for its size.

These have replaced a uDAC2 and are a definate improvement sound and power wise with my HD650's.

Now I'm wondering whether the iPad will work with these connected via a camera kit with USB?
 
I have not tried it, but others have reported that it works.
 
     Share This Post       
post-9104557
Post #932 of 1,370

Barry S

1000+ Head-Fier
Joined
Jul 30, 2012
Messages
1,183
Reaction score
260
Joined
Jul 30, 2012
Posts
1,183
Likes
260
The Modi works fine with my iPad--just need to use a powered USB hub.
 
     Share This Post       
post-9108563
Post #933 of 1,370

STEALTH714

New Head-Fier
Joined
Jan 29, 2013
Messages
9
Reaction score
0
Joined
Jan 29, 2013
Posts
9
Likes
0
Loving the M&M stack with HD-650's and HE-400's.  Power input on the back of the Magni is tempermental.  Slightest touch and get snap, crackle and pops. 
 
     Share This Post       
post-9109134
Post #934 of 1,370

USAudio

500+ Head-Fier
Joined
Nov 7, 2007
Messages
674
Reaction score
32
Location
Seattle, USA
Joined
Nov 7, 2007
Location
Seattle, USA
Posts
674
Likes
32
Quote:
Loving the M&M stack with HD-650's and HE-400's.  ...
Agreed, with the HD-650's.
 
Quote:
Loving the M&M stack with HD-650's and HE-400's.  Power input on the back of the Magni is tempermental.  Slightest touch and get snap, crackle and pops. 
Mine doesn't have this issue, maybe contact Schiit to get a replacement.
 
     Share This Post       
post-9109763
Post #935 of 1,370

mucore

New Head-Fier
Joined
Jan 28, 2013
Messages
5
Reaction score
0
Joined
Jan 28, 2013
Posts
5
Likes
0
since I've got an amp while I'll keep an eye on the Asgard.
 
     Share This Post       
post-9111625
Post #936 of 1,370

Phalangees

New Head-Fier
Joined
Jul 8, 2010
Messages
32
Reaction score
10
Joined
Jul 8, 2010
Posts
32
Likes
10
Quote:
Loving the M&M stack with HD-650's and HE-400's.  Power input on the back of the Magni is tempermental.  Slightest touch and get snap, crackle and pops. 
 
Yeah, contact Schiit. Mine had a similar issue, as well as crackling in the left channel when touching the volume knob. I should have my replacement tomorrow. :)
 
They really have fantastic customer service.
 
     Share This Post       
post-9114769
Post #938 of 1,370

STEALTH714

New Head-Fier
Joined
Jan 29, 2013
Messages
9
Reaction score
0
Joined
Jan 29, 2013
Posts
9
Likes
0
I've read very good things about Jason & their customer service.  
 
I unplugged from the back of the Magni and back in and now cannot replicate the issue.  I'll keep it as is for now.  If it rears its head again, i'll contact Jason.  Reminds me of the old joke
 
Patient: Doc my arm hurts when I move it like this
Doc:  Well don't move it like that
 
:)
 
     Share This Post       
post-9114913
Post #939 of 1,370

Defiant00

1000+ Head-Fier
Joined
Feb 26, 2011
Messages
1,442
Reaction score
214
Joined
Feb 26, 2011
Posts
1,442
Likes
214
Quote:
I've read very good things about Jason & their customer service.  
 
I unplugged from the back of the Magni and back in and now cannot replicate the issue.  I'll keep it as is for now.  If it rears its head again, i'll contact Jason.  Reminds me of the old joke
 
Patient: Doc my arm hurts when I move it like this
Doc:  Well don't move it like that
 
:)
 
Curious, it's always possible you just didn't have a good connection that one time I suppose.
 
At least you know that if it does come back up you'll be taken care of, and hopefully you won't even have to worry about it.
 
     Share This Post       
post-9115044
Post #940 of 1,370

Barry S

1000+ Head-Fier
Joined
Jul 30, 2012
Messages
1,183
Reaction score
260
Joined
Jul 30, 2012
Posts
1,183
Likes
260
My Magni had to back to the shop.  The pot started acting completely wonky--I got a channel imbalance at any volume, which changed when I jiggled the knob.
  I'd gladly pay extra for a better pot with a more gradual taper--wonder if that's feasible?  Work is extra stressful these days, so I miss having my setup.
 
     Share This Post       
post-9115656
Post #941 of 1,370

xinghui0711

500+ Head-Fier
Joined
Apr 2, 2012
Messages
563
Reaction score
54
Joined
Apr 2, 2012
Posts
563
Likes
54
Quote:
My Magni had to back to the shop.  The pot started acting completely wonky--I got a channel imbalance at any volume, which changed when I jiggled the knob.
  I'd gladly pay extra for a better pot with a more gradual taper--wonder if that's feasible?  Work is extra stressful these days, so I miss having my setup.
I felt like I have the same issue for my newly arrived M&M stack. Even when it gets fairly loud, I felt like the left ear was louder than the right side. Me too lol, I want to pay extra for quality products rather than faulty gears for cheap.

 
     Share This Post       
post-9115744
Post #942 of 1,370

Phalangees

New Head-Fier
Joined
Jul 8, 2010
Messages
32
Reaction score
10
Joined
Jul 8, 2010
Posts
32
Likes
10
Got my replacement Magni today, but now the Modi seems to be faulty?!? It has horrible noise, and when music plays it sounds like the music is alien, and full of noise. Incredibly strange. I'm going to leave it unplugged from USB for a few hours, but I think I'm pretty unlucky here... Anyone else have a similar issue? It's been weeks since I've been able to listen to this stack.
 
     Share This Post       
post-9115859
Post #943 of 1,370

KamijoIsMyHero

1000+ Head-Fier
Joined
Oct 6, 2012
Messages
1,486
Reaction score
67
Joined
Oct 6, 2012
Posts
1,486
Likes
67
Check if the output is set to 24 bits, it does weird things at 16
 
     Share This Post       
post-9115866
Post #944 of 1,370

devhen

Headphoneus Supremus
Joined
May 16, 2012
Messages
2,282
Reaction score
96
Joined
May 16, 2012
Posts
2,282
Likes
96
Yeah it could be your configuration. For example the other day I had a program spitting out terrible crackling noises and it turned out that it just didn't like 24bit/48kHz. I changed my DAC output to 24bit/44.1kHz in the Windows sound control panel and it fixed it.
 
     Share This Post       
post-9115895
Post #945 of 1,370

fmuller

New Head-Fier
Joined
Nov 7, 2007
Messages
6
Reaction score
10
Joined
Nov 7, 2007
Posts
6
Likes
10
Hi people, long time lurker here!
 
I also noticed some crackling noises, not too loud but clearly perceptible, when using PowerDVD12 + Reclock. I tried changing configurations on both programs, but nothing worked. Turns out that switching Modi from a USB 3.0 to a 2.0 port seems to have solved the problem.
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top