The Nameless Guide To PC Gaming Audio (with binaural headphone surround sound)
post-10480783
Post #2,866 of 4,101

benbenkr

100+ Head-Fier
Joined
Jan 4, 2013
Messages
379
Reaction score
49
Joined
Jan 4, 2013
Posts
379
Likes
49
 
YES YES YES!  Thanks for bringing this to my attention.  When I emailed Schiit about a cheap DAC with optical a month ago they said one was coming soon.  I was expecting some kind of announcement, but this will have to do.  Time to order!
 
And now, it's official - http://www.head-fi.org/t/715525/avant-le-schiitstorm-a-couple-of-small-announcements
 
Yeap, time to buy a Modi.
 
     Share This Post       
  • Like
Reactions: Stillhart
post-10481166
Post #2,867 of 4,101

Murder Mike

100+ Head-Fier
Joined
Jan 15, 2013
Messages
276
Reaction score
32
Joined
Jan 15, 2013
Posts
276
Likes
32
  I didn't realize this until today, Schiit has a new option added when purchasing the Modi - Optical input.
 
That's kinda cool, but it would be a lot nicer if it had USB and optical, not just one or the other. 
 
     Share This Post       
post-10481182
Post #2,868 of 4,101

Stillhart

CanJam@RMAF 2015 Karting Champion
Joined
Feb 14, 2014
Messages
6,638
Reaction score
3,193
Location
Las Vegas
Joined
Feb 14, 2014
Location
Las Vegas
Posts
6,638
Likes
3,193
   
That's kinda cool, but it would be a lot nicer if it had USB and optical, not just one or the other.
There are plenty with both, but not at this price point.  And I doubt the Fiio E17 (the cheapest one I can think of with both) sounds as good (though I admit I haven't heard either yet).
 
     Share This Post       
post-10481321
Post #2,869 of 4,101

AvroArrow

100+ Head-Fier
Joined
Sep 4, 2013
Messages
124
Reaction score
38
Joined
Sep 4, 2013
Posts
124
Likes
38
I'm not sure if I should post this here, but I figured there should be a decent amount of X-Fi Titanium owners in this thread.  If it's the wrong place to post it, please let me know and I'll start my own thread asking for help.
 
So I managed to recently find a new old stock SB X-Fi Titanium SB0880 (non-HD) and am having some difficulty with it.  My problem is not the gaming part (that works great), but the music playback with the X-Fi Ti.  My setup is as follows:
 
Old:
onboard Realtek w/Dolby Headphone(SPDIF out) -> Audioengine D1 (RCA out) -> Schiit Asgard 2 -> headphones
 
New:
X-Fi (SPDIF out) -> Audioengine D1 (RCA out) -> Schiit Asgard 2 -> headphones
 
The issue I am having is when I try to use WASAPI mode/drivers in Foobar2000 and MediaMonkey my PC will hard lock/freeze and requires pressing the power button to reboot.  After some searching it appears that apparently WASAPI drivers + X-Fi cards + SPDIF out is not a working combo.  Most suggestions is to either use the DirectSound or ASIO drivers instead.  So I installed the ASIO plug-ins for foobar2000 and MediaMonkey and used the default Creative ASIO drivers (I also tried the ASIO4ALL drivers) and it doesn't hard lock anymore, sometimes it will freeze for a few seconds but there's NO AUDIO output from SPDIF anymore.  The D1 keeps clicking as if it's changing modes so the X-Fi is sending some sort of signal to it, but there's no audio.  Some posts regarding the ASIO driver suggest switching to Audio Creation mode from Game mode in the X-Fi control panel, but that didn't change anything for me, still no audio.  What I have ended up doing is remove the D1 from the chain and run it like this:
 
X-Fi (3.5mm out) -> (3.5mm to RCA cable) -> Asgard 2 -> headphones.
 
Now I have music and the WASAPI drivers work too (ASIO drivers work for a bit then it crashes Windows), except it sounded like crap compared to my old setup.  After another hour of googling I found that I need to disable CMSS-3D (I was still in Game mode) during music playback in the X-Fi control panel and then it sounded good again.  It still doesn't sound quite as good as when I use the D1 as the DAC, but better than before.
 
So currently for the best music and game audio I have it setup in a big mess like this:
 
X-Fi (3.5mm out) -> (3.5mm to RCA cable) -> (2-to-1 RCA splitter) -> Asgard 2 -> headphones.
motherboard (USB out) -> Audioengine D1 (RCA out) -> (2-to-1 RCA splitter) -> Asgard 2 -> headphones.
 
I have foobar2000 set to use the D1 WASAPI driver as default (Windows default audio playback device is X-Fi), but I have to power on the D1 and go into the X-Fi control panel and Untick CMSS-3D when I want to listen to music and re-tick it when I want to play games and watch movies/TV.  When I was running the old DH setup I did not have to mess with any of this.  It just worked without any of this fiddling.  The virtual surround wasn't as good as CMSS-3D, but it was a lot less hassle.
 
So my question after all this is, has anyone been able to run an X-Fi card with SPDIF out working with WASAPI/ASIO drivers in Win7 x64?  I'd really like to use the DAC on the D1 but with a cleaner wiring setup like my old DH setup than what I currently have working.  This reminded me why I stopped buying Soundblaster cards after my dearly departed Soundblaster16 with Roland MIDI daughterboard... the driver headaches.   
 
     Share This Post       
post-10481411
Post #2,870 of 4,101

MrEleventy

Headphoneus Supremus
Joined
Oct 24, 2012
Messages
2,329
Reaction score
158
Joined
Oct 24, 2012
Posts
2,329
Likes
158
Have you tried setting the D1 as the playback device in Foobar playback-output option or is the D1 not available? I'm not familiar with the way that the D1 operates. On Audioengine's site, it says that the optical is given preference when an optical cable is plugged in, but I'm not sure if it'll disable the USB entirely.

FYI : My setup is :
Laptop -> SB -> NFB12 (optical) +--- > HPs
Laptop -> NFB12 (USB) ______/

Foobar playback is NFB12 WASAPI Event.

Works like a charm, main difference is that the NFB12 has an input toggle switch.
 
     Share This Post       
post-10481494
Post #2,871 of 4,101

SaLX

500+ Head-Fier
Joined
Sep 25, 2013
Messages
607
Reaction score
29
Joined
Sep 25, 2013
Posts
607
Likes
29
  I didn't realize this until today, Schiit has a new option added when purchasing the Modi - Optical input.
 
Yes, that's pretty much a Godsend.
Those who has always been looking at the $200 Schiit stack, but didn't want to go down that route due to the lack of optical in, now you have no excuse anymore.
 
Now if only Schiit can make an all-in-one with optical input.....
Lol.... they took them this long. The O2 guys were whimpering on about this, but never got anywhere. Expect them to follow.
 
     Share This Post       
post-10481618
Post #2,872 of 4,101

lttlfld

Head-Fier
Joined
Dec 2, 2013
Messages
81
Reaction score
14
Joined
Dec 2, 2013
Posts
81
Likes
14
I'm not sure if I should post this here, but I figured there should be a decent amount of X-Fi Titanium owners in this thread.  If it's the wrong place to post it, please let me know and I'll start my own thread asking for help.

So I managed to recently find a new old stock SB X-Fi Titanium SB0880 (non-HD) and am having some difficulty with it.  My problem is not the gaming part (that works great), but the music playback with the X-Fi Ti.  My setup is as follows:

Old:

onboard Realtek w/Dolby Headphone(SPDIF out) -> Audioengine D1 (RCA out) -> Schiit Asgard 2 -> headphones

New:

X-Fi (SPDIF out) -> Audioengine D1 (RCA out) -> Schiit Asgard 2 -> headphones

The issue I am having is when I try to use WASAPI mode/drivers in Foobar2000 and MediaMonkey my PC will hard lock/freeze and requires pressing the power button to reboot.  After some searching it appears that apparently WASAPI drivers + X-Fi cards + SPDIF out is not a working combo.  Most suggestions is to either use the DirectSound or ASIO drivers instead.  So I installed the ASIO plug-ins for foobar2000 and MediaMonkey and used the default Creative ASIO drivers (I also tried the ASIO4ALL drivers) and it doesn't hard lock anymore, sometimes it will freeze for a few seconds but there's NO AUDIO output from SPDIF anymore.  The D1 keeps clicking as if it's changing modes so the X-Fi is sending some sort of signal to it, but there's no audio.  Some posts regarding the ASIO driver suggest switching to Audio Creation mode from Game mode in the X-Fi control panel, but that didn't change anything for me, still no audio.  What I have ended up doing is remove the D1 from the chain and run it like this:

X-Fi (3.5mm out) -> (3.5mm to RCA cable) -> Asgard 2 -> headphones.

Now I have music and the WASAPI drivers work too (ASIO drivers work for a bit then it crashes Windows), except it sounded like crap compared to my old setup.  After another hour of googling I found that I need to disable CMSS-3D (I was still in Game mode) during music playback in the X-Fi control panel and then it sounded good again.  It still doesn't sound quite as good as when I use the D1 as the DAC, but better than before.

So currently for the best music and game audio I have it setup in a big mess like this:

X-Fi (3.5mm out) -> (3.5mm to RCA cable) -> (2-to-1 RCA splitter) -> Asgard 2 -> headphones.

motherboard (USB out) -> Audioengine D1 (RCA out) -> (2-to-1 RCA splitter) -> Asgard 2 -> headphones.

I have foobar2000 set to use the D1 WASAPI driver as default (Windows default audio playback device is X-Fi), but I have to power on the D1 and go into the X-Fi control panel and Untick CMSS-3D when I want to listen to music and re-tick it when I want to play games and watch movies/TV.  When I was running the old DH setup I did not have to mess with any of this.  It just worked without any of this fiddling.  The virtual surround wasn't as good as CMSS-3D, but it was a lot less hassle.

So my question after all this is, has anyone been able to run an X-Fi card with SPDIF out working with WASAPI/ASIO drivers in Win7 x64?  I'd really like to use the DAC on the D1 but with a cleaner wiring setup like my old DH setup than what I currently have working.  This reminded me why I stopped buying Soundblaster cards after my dearly departed Soundblaster16 with Roland MIDI daughterboard... the driver headaches.   
You are using a sound card, an amplifier, AND a DAC and I'm wondering how common this is. I'm currently running with just an eclaro sound card and am looking into getting an amp but never considered getting a DAC as well. It seems like you're having problems and I'm wondering if this is an issue with anyone else doing the triple combo?
 
     Share This Post       
post-10481658
Post #2,873 of 4,101

AvroArrow

100+ Head-Fier
Joined
Sep 4, 2013
Messages
124
Reaction score
38
Joined
Sep 4, 2013
Posts
124
Likes
38
Have you tried setting the D1 as the playback device in Foobar playback-output option or is the D1 not available? I'm not familiar with the way that the D1 operates. On Audioengine's site, it says that the optical is given preference when an optical cable is plugged in, but I'm not sure if it'll disable the USB entirely.

FYI : My setup is :
Laptop -> SB -> NFB12 (optical) +--- > HPs
Laptop -> NFB12 (USB) ______/

Foobar playback is NFB12 WASAPI Event.

Works like a charm, main difference is that the NFB12 has an input toggle switch.
 
The way the D1 operates if both USB and SPDIF are plugged in is that it will only process the SPDIF signal, it will auto-disable USB audio input automatically, so I have to unplug the SPDIF cable to use it as a USB DAC. 
 
BTW, the funny thing is that my old DH wiring setup works fine with the X-Fi Surround 5.1 USB (SB1090) that I bought from you when using the WASAPI driver and via SPDIF output into the D1.  But that only has Entertainment mode, no Game or Audio Creation mode and I think it uses a different chip than the X-Fi Titanium.  Since I managed to find a new X-Fi Ti SB0880 I have since given the X-Fi Surround to my younger brother and he loves it.  Going from stock Realtek onboard to CMSS-3D was a revelation for him.  He can really kick ass now in Team Fortress 2 and other FPSes using the X-Fi Surround and Sennheiser PC360.  He games way more than I do since I have less time for games due to work. 
 
I guess if I can't find a nice solution then I'll swap cards with him since he has no use for the SPDIF output on the X-Fi and it will drive his PC360s fine straight out of the 3.5mm headphone jack. 
 
     Share This Post       
post-10481721
Post #2,874 of 4,101

AvroArrow

100+ Head-Fier
Joined
Sep 4, 2013
Messages
124
Reaction score
38
Joined
Sep 4, 2013
Posts
124
Likes
38
You are using a sound card, an amplifier, AND a DAC and I'm wondering how common this is. I'm currently running with just an eclaro sound card and am looking into getting an amp but never considered getting a DAC as well. It seems like you're having problems and I'm wondering if this is an issue with anyone else doing the triple combo?
 
This triple setup is not that uncommon... here at least, but not exactly mainstream either due to cost and complexity.  I'm using AKG K702 65th Annies so they require at least a semi-decently powerful amp.  The only reason I'm having issues is more than likely the fault of poorly writen Soundblaster drivers.  I had a setup with onboard Realtek sound with hacked Dolby Headphone drivers via SPDIF and it worked great with the D1.  If I were using a cheap Asus DGX with Dolby Headphone I suspect it would continue to work great with WASAPI, Dolby Headphone, and SPDIF out.  I just like the CMSS-3D virtual surround better than Dolby Headphone.  And neither the Realtek onboard nor the 2 different X-Fi cards I have sound as good for music than the Audioengine D1 IMHO.  Maybe it's expectation bias but to me the D1 sounds better playing my FLACs than the other soundcards.  I'm using those other soundcards just for their virtual surround headphone processing alone.     
 
     Share This Post       
post-10481758
Post #2,875 of 4,101

lttlfld

Head-Fier
Joined
Dec 2, 2013
Messages
81
Reaction score
14
Joined
Dec 2, 2013
Posts
81
Likes
14
This triple setup is not that uncommon... here at least, but not exactly mainstream either due to cost and complexity.  I'm using AKG K702 65th Annies so they require at least a semi-decently powerful amp.  The only reason I'm having issues is more than likely the fault of poorly writen Soundblaster drivers.  I had a setup with onboard Realtek sound with hacked Dolby Headphone drivers via SPDIF and it worked great with the D1.  If I were using a cheap Asus DGX with Dolby Headphone I suspect it would continue to work great with WASAPI, Dolby Headphone, and SPDIF out.  I just like the CMSS-3D virtual surround better than Dolby Headphone.  And neither the Realtek onboard nor the 2 different X-Fi cards I have sound as good for music than the Audioengine D1 IMHO.  Maybe it's expectation bias but to me the D1 sounds better playing my FLACs than the other soundcards.  I'm using those other soundcards just for their virtual surround headphone processing alone.     
This actually makes a lot of sense. Do any known soundcards provide a decent level of amp/DAC capabilities to justify a higher price?
 
     Share This Post       
post-10482484
Post #2,876 of 4,101
Joined
Mar 23, 2009
Messages
5,695
Reaction score
1,609
Joined
Mar 23, 2009
Posts
5,695
Likes
1,609
People say the flagship cards (ZxR, STX) have decent capabilities, but personally I went with an Omni for convenience (surround processing, plug in my speakers and headphones at the same time and software-switch between them, built-in stereo mics and volume knob, PC or Mac) and because I can connect an optical DAC and upgraded amp later, if I want. I'm looking at that new Schiit Modi with the optical option...
 
Sennheiser Stay updated on Sennheiser at their sponsor profile on Head-Fi.
 
https://www.facebook.com/SennheiserUSA https://twitter.com/SennheiserUSA http://www.instagram.com/sennheiser https://sennheiser.com/
     Share This Post       
post-10482633
Post #2,877 of 4,101

benbenkr

100+ Head-Fier
Joined
Jan 4, 2013
Messages
379
Reaction score
49
Joined
Jan 4, 2013
Posts
379
Likes
49
   
That's kinda cool, but it would be a lot nicer if it had USB and optical, not just one or the other. 
 
Because, there's no point to it?
If there were to be a USB input for power and data + optical, that would mean at any point the Modi would need to be fed off using USB. That creates juddering in audio tracks, whether or not that's audible that would depend on how dirty the power source is.
 
Just using an external power adapter would be much cleaner already.
 
 
  There are plenty with both, but not at this price point.  And I doubt the Fiio E17 (the cheapest one I can think of with both) sounds as good (though I admit I haven't heard either yet).
 
You doubt wrong.
The E17 sounds as "good" as the Modi. DACs sound same-ish these days anyway, there's not a huge difference in terms of "quality".
 
The E17 is on the warm side and the Modi is on the neutral side. If the O2 is taken as the baseline of a flat response (which it isn't), then the Modi is just a smidge warmer than the O2.
So no, the E17 doesn't sound inferior it just caters to a warmer signature that's all.
 
 
  Lol.... they took them this long. The O2 guys were whimpering on about this, but never got anywhere. Expect them to follow.
 
Yup way too long. But better late than never I'd say.
 
     Share This Post       
post-10483219
Post #2,878 of 4,101

MrEleventy

Headphoneus Supremus
Joined
Oct 24, 2012
Messages
2,329
Reaction score
158
Joined
Oct 24, 2012
Posts
2,329
Likes
158
The way the D1 operates if both USB and SPDIF are plugged in is that it will only process the SPDIF signal, it will auto-disable USB audio input automatically, so I have to unplug the SPDIF cable to use it as a USB DAC. 

BTW, the funny thing is that my old DH wiring setup works fine with the X-Fi Surround 5.1 USB (SB1090) that I bought from you when using the WASAPI driver and via SPDIF output into the D1.  But that only has Entertainment mode, no Game or Audio Creation mode and I think it uses a different chip than the X-Fi Titanium.  Since I managed to find a new X-Fi Ti SB0880 I have since given the X-Fi Surround to my younger brother and he loves it.  Going from stock Realtek onboard to CMSS-3D was a revelation for him.  He can really kick ass now in Team Fortress 2 and other FPSes using the X-Fi Surround and Sennheiser PC360.  He games way more than I do since I have less time for games due to work. 

I guess if I can't find a nice solution then I'll swap cards with him since he has no use for the SPDIF output on the X-Fi and it will drive his PC360s fine straight out of the 3.5mm headphone jack. 
Ahh, I see. Bummer. :\
 
     Share This Post       
post-10483302
Post #2,879 of 4,101
Joined
Mar 23, 2009
Messages
5,695
Reaction score
1,609
Joined
Mar 23, 2009
Posts
5,695
Likes
1,609
Because, there's no point to it?
If there were to be a USB input for power and data + optical, that would mean at any point the Modi would need to be fed off using USB. That creates juddering in audio tracks, whether or not that's audible that would depend on how dirty the power source is.

Just using an external power adapter would be much cleaner already.
-----
Huh? What's all this? The Modi always uses an external power adapter, and it's always used USB for data until yesterday, where you can order an optical port INSTEAD of USB.
-----


You doubt wrong.
The E17 sounds as "good" as the Modi. DACs sound same-ish these days anyway, there's not a huge difference in terms of "quality".

The E17 is on the warm side and the Modi is on the neutral side. If the O2 is taken as the baseline of a flat response (which it isn't), then the Modi is just a smidge warmer than the O2.
So no, the E17 doesn't sound inferior it just caters to a warmer signature that's all.
And what's this of comparing the O2 amp to the Modi DAC and E17 DAC/amp combo? You can't compare an O2 to a Modi. That's like comparing a car to a gas station.

It would be super convenient for me if the E17 was as technically capable as a Modi or more expensive DAC, but it sounds too good to be true and your statements above seem jumbled up, so I have to take them with a grain of salt.
 
Sennheiser Stay updated on Sennheiser at their sponsor profile on Head-Fi.
 
https://www.facebook.com/SennheiserUSA https://twitter.com/SennheiserUSA http://www.instagram.com/sennheiser https://sennheiser.com/
     Share This Post       
post-10483433
Post #2,880 of 4,101

genclaymore

Headphoneus Supremus
Joined
Jun 3, 2007
Messages
2,158
Reaction score
129
Location
MI
Joined
Jun 3, 2007
Location
MI
Posts
2,158
Likes
129
Age
37
     Share This Post       

Users Who Are Viewing This Thread (Users: 1, Guests: 7)

Top