The Koss ESP950 thread (ESP owners, please contribute! :)
Feb 14, 2021 at 12:52 PM Post #691 of 714

Markus9229

New Head-Fier
Joined
Nov 2, 2015
Posts
17
Likes
4
95x.jpg


Finally received mine... Had to wait an entire month! Tried them stock and now have the Oratory EQ, they're pretty nice but after the 2nd/3rd day the left driver started making a constant ticking noise that makes me unable to listen to slow/quiet music since its louder than the music itself :frowning2:
It sounds like a very fast tick-tick-tick (think 300bpm metronome) and idk how to get rid of it honestly, I already tried tapping on the cup and also leaving the energizer turned off for half a day but the exact same thing happens as soon as I turn it on. If I turn it off with the 95X still plugged in, then it progressively goes slower in BPM until it finally goes silent.

Also it can't be the wall plug since it's been sitting on the same plug since I got it and it didn't have this issue before...

No idea what to do really. I like them, but listening to them is so unnerving due to that...

ps: Can't really make use of the warranty since I've had to pay 100€ in customs fees just to get these imported from the US, can't imagine paying that 2 times more for the return each way...
 
Feb 14, 2021 at 4:17 PM Post #693 of 714
Joined
Mar 20, 2013
Posts
12,474
Likes
8,128
Location
Location: HQ in the UK, but spread far and wide.
95x.jpg


Finally received mine... Had to wait an entire month! Tried them stock and now have the Oratory EQ, they're pretty nice but after the 2nd/3rd day the left driver started making a constant ticking noise that makes me unable to listen to slow/quiet music since its louder than the music itself :frowning2:
It sounds like a very fast tick-tick-tick (think 300bpm metronome) and idk how to get rid of it honestly, I already tried tapping on the cup and also leaving the energizer turned off for half a day but the exact same thing happens as soon as I turn it on. If I turn it off with the 95X still plugged in, then it progressively goes slower in BPM until it finally goes silent.

Also it can't be the wall plug since it's been sitting on the same plug since I got it and it didn't have this issue before...

No idea what to do really. I like them, but listening to them is so unnerving due to that...

ps: Can't really make use of the warranty since I've had to pay 100€ in customs fees just to get these imported from the US, can't imagine paying that 2 times more for the return each way...

That's a very cool headphone stand. If I may ask, what is it?
 
iFi audio Stay updated on iFi audio at their sponsor profile on Head-Fi.
 
https://www.facebook.com/iFiAudio/ https://twitter.com/ifiaudio https://www.instagram.com/ifiaudio/ https://ifi-audio.com/ info@ifi-audio.com
Feb 15, 2021 at 7:39 AM Post #695 of 714
Joined
Mar 20, 2013
Posts
12,474
Likes
8,128
Location
Location: HQ in the UK, but spread far and wide.
Hi! This is a handmade headphone stand, my friend's dad is a skilled woodworker and he offered to make me a headphone stand for the 95X.

I gotta say, it fits like a glove!

Thanks! It fits great and looks awesome, but the fact that it's a one-off makes it even better :D
 
iFi audio Stay updated on iFi audio at their sponsor profile on Head-Fi.
 
https://www.facebook.com/iFiAudio/ https://twitter.com/ifiaudio https://www.instagram.com/ifiaudio/ https://ifi-audio.com/ info@ifi-audio.com
Feb 15, 2021 at 7:41 AM Post #696 of 714

JTori

100+ Head-Fier
Joined
Jan 20, 2008
Posts
302
Likes
304
Location
Michigan
95x.jpg


Finally received mine... Had to wait an entire month! Tried them stock and now have the Oratory EQ, they're pretty nice but after the 2nd/3rd day the left driver started making a constant ticking noise that makes me unable to listen to slow/quiet music since its louder than the music itself :frowning2:
It sounds like a very fast tick-tick-tick (think 300bpm metronome) and idk how to get rid of it honestly, I already tried tapping on the cup and also leaving the energizer turned off for half a day but the exact same thing happens as soon as I turn it on. If I turn it off with the 95X still plugged in, then it progressively goes slower in BPM until it finally goes silent.

Also it can't be the wall plug since it's been sitting on the same plug since I got it and it didn't have this issue before...

No idea what to do really. I like them, but listening to them is so unnerving due to that...

ps: Can't really make use of the warranty since I've had to pay 100€ in customs fees just to get these imported from the US, can't imagine paying that 2 times more for the return each way...

I experienced a similar issue with one of my Bottlehead amps, which I determined was due to its proximity to a wifi net extender. Is your setup near a router or extender by any chance?

Joe.
 
Mar 10, 2021 at 8:07 PM Post #699 of 714

Brahmsian

500+ Head-Fier
Joined
Feb 21, 2017
Posts
536
Likes
242
Location
Miami, Florida



Finally received mine... Had to wait an entire month! Tried them stock and now have the Oratory EQ, they're pretty nice but after the 2nd/3rd day the left driver started making a constant ticking noise that makes me unable to listen to slow/quiet music since its louder than the music itself :frowning2:
It sounds like a very fast tick-tick-tick (think 300bpm metronome) and idk how to get rid of it honestly, I already tried tapping on the cup and also leaving the energizer turned off for half a day but the exact same thing happens as soon as I turn it on. If I turn it off with the 95X still plugged in, then it progressively goes slower in BPM until it finally goes silent.

Also it can't be the wall plug since it's been sitting on the same plug since I got it and it didn't have this issue before...

No idea what to do really. I like them, but listening to them is so unnerving due to that...

ps: Can't really make use of the warranty since I've had to pay 100€ in customs fees just to get these imported from the US, can't imagine paying that 2 times more for the return each way...
I experienced the same issue. Bought mine new from Drop a few months ago, and now I'm returning my unit for the fourth time, once to Drop, and this will be the third return to Koss for warranty repair. I finally got the noise issue fixed. But earlier today I was listening to them when suddenly the volume dropped way low on both drivers so that I have to turn it up all the way to get a listenable level, and the left driver has distorted bass like when you blow out a speaker. Any ideas on what might have happened? A sudden volume drop on both sides and distorted bass on one, happening simultaneously.
 
Last edited:
Mar 11, 2021 at 9:15 AM Post #700 of 714

ursdiego

100+ Head-Fier
Joined
Oct 25, 2010
Posts
230
Likes
13
Received my sample today. From all full size headphones I owned up to now, its the only one I will probably keep for good. Soundwise, it is certainly one of the best headphones I have ever heard. The build, on the other hand, is probably the worst I ever had in my hands. Koss has obviously gone a long way since 1973, when their ESP-9 was described as "heavy, very business-like in appearance" in "Stereophile" . The plastic seems recycled and I hope it really is, so at least it helps to my footprint conscience. However, who minds once they are sit the had. Anyway, after my first impression, I believe that they don't totally get to the level to the Jecklin Float I used extensively many years ago. I feel that dynamics are a bit compressed. This could of course be due to the amplifier, that might be upgradeable by gifted technicians. However, unfortunately I don't have the Jecklins anymore to make a direct comparison.
 
Mar 11, 2021 at 5:13 PM Post #701 of 714

Markus9229

New Head-Fier
Joined
Nov 2, 2015
Posts
17
Likes
4
I experienced the same issue. Bought mine new from Drop a few months ago, and now I'm returning my unit for the fourth time, once to Drop, and this will be the third return to Koss for warranty repair. I finally got the noise issue fixed. But earlier today I was listening to them when suddenly the volume dropped way low on both drivers so that I have to turn it up all the way to get a listenable level, and the left driver has distorted bass like when you blow out a speaker. Any ideas on what might have happened? A sudden volume drop on both sides and distorted bass on one, happening simultaneously.

I ended up returning them for a full refund and now looking to invest that money into stax.
 
Apr 6, 2021 at 10:48 AM Post #704 of 714

MajorTom

New Head-Fier
Joined
Jul 11, 2010
Posts
19
Likes
2
Location
Great Britain
Thought I'd put this here too:
Was hoping someone here would be able to help me since Koss hasn't. So I purchased an ESP95X and was planning to swap out the stock power supply for a 9V 2A iFi iPower (which I notice a number of people on this thread have been successful with), however whenever I try to do so I get nothing. Just an occasional red blink from the power indicator. I've measured the iPower which is outputting a comfortable ~9.2V, whereas the stock power supply which comes with the unit is outputting over 13V. Was wondering whether anyone else has experienced this?

Damn, mine arrived today and I searched the thread to see if anyone else had experienced the same 'red blink'. How'd you fix this in the end? I tried swapping to an alternate charger that I measured at 9.1v and I get the same light behaviour.
 
Apr 6, 2021 at 12:14 PM Post #705 of 714

PointyFox

Headphoneus Supremus
Joined
Jun 20, 2010
Posts
2,566
Likes
1,629
My iFi adapter is putting out 9.391 V (no load) and I've had no issues.

Make sure you're using center positive polarity.
 
Last edited:

Users who are viewing this thread

Top