The iBasso DX50 Thread - Latest firmware: 1.9.5 - June 30, 2016
Apr 15, 2015 at 11:08 PM Post #16,816 of 18,635

sanakimpro

Previously known as atoniolin
Joined
Nov 27, 2014
Posts
226
Likes
71
   hey! iam looking since 2 hours a solution to install SU 1.3.3 on my dx50 and cannot find anything. do someone have a link to a tutotorial , or can someone explain me ? i found a link to a file:  https://github.com/dm1try/dx50_sound_unlocked is that the good place to get it?
thanks

Hi there, try this link. https://github.com/dm1try/dx50_sound_unlocked/raw/master/releases/dx50_sound_unlocked_1.3.3.7z 
 
Apr 16, 2015 at 4:29 AM Post #16,817 of 18,635

NightX

New Head-Fier
Joined
Mar 13, 2015
Posts
9
Likes
11
  There is a problem with ibasso dx 50 1.8.0
 
i have lot of one file music albums in flac or in ape.
 
problem:
if the first track ended, the ibasso can't continue the playback to the 2nd track.no. it plays again the first track.
i need go to the next track manually:frowning2:
it is big problem!

Yeah. And it applies, if I'm correct, to all music with cuesheets.
IBASSO -- 
deadhorse.gif
  WHERE'S MY NEW FIRMWARE?!
 
Apr 16, 2015 at 4:46 AM Post #16,818 of 18,635

glasscorp33

New Head-Fier
Joined
Apr 4, 2015
Posts
6
Likes
0

thanks antoniolin, i did the installation by following the official i basso instructions, and after the installation when i check the firmware in the settings , it says than i am in  firmware 1.5, is that normal? i dowloaded the file from your link , unzip it , an have put it in the internal memory. i was in the firmware 1.8 before the instalation . is there something wrong ? did i miss a step ? 
 
thanks .
 
Apr 16, 2015 at 5:12 AM Post #16,819 of 18,635

CoiL

Member of the Trade: Wood Audio Accessories & Modifications
Joined
Jan 23, 2013
Posts
6,335
Likes
3,185
Location
Estonia
Everything is ok. It just shows 1.5.0 because it is based on it.
 
Now go to hidden bootup settings and try FLAC-only / iir off / cpu default settings :wink:
 
Apr 16, 2015 at 12:56 PM Post #16,824 of 18,635
Joined
Jan 7, 2015
Posts
2,246
Likes
3,206
Location
ShenZhen, China
I get really bad popping and clipping sounds when I use the physical buttons on the DX50, anyone else?


This is not normal. Try a factory reset under advanced settings and see if that clears it.
 
iBasso Stay updated on iBasso at their sponsor profile on Head-Fi.
 
http://www.ibasso.com/ paul@ibasso.com
Apr 16, 2015 at 1:45 PM Post #16,828 of 18,635

cholero

100+ Head-Fier
Joined
Jul 9, 2011
Posts
481
Likes
78
from readme.txt:
 
Code:
 Improvements with this firmware: 1. Delete and add to playlist functions are enabled under Directory category. 2. Rectified bugs found on V1.8.0 firmware. 3. Improved M3U/M3U8 playlist support.
 

Users who are viewing this thread

Top