Super.fi 5 Pros distorted/hiss sound from laptop
Nov 10, 2008 at 2:34 AM Thread Starter Post #1 of 2

demo1

100+ Head-Fier
Joined
Aug 7, 2008
Posts
188
Likes
0
Hi,

I've had the Ultimate Ears Super.fi 5 Pros for almost a year and love them. At least with my iPod anyways. Ever since I got them I've avoided using them with my laptop (Toshiba M70 if it matters) because right when i plug them in, i hear a really very noticeable hiss. Also, when the hard drive spins, i hear a "clank" noise. This doesn't happen with my iPod. I've heard this issue has something to do with the power resistance or ohms, however, I could be wrong. I sometimes use the attenuator but it alters the sound dramatically in my experience. It reduces the bass just the overall ""pop" of the music. The sound card in my laptop is an AC97.

If anyone knows a way to solve the hissing problem that would be great!

deMO1
 
Nov 10, 2008 at 11:44 AM Post #2 of 2

jinx20001

Headphoneus Supremus
Joined
Jul 4, 2007
Posts
2,639
Likes
20
no thats the problem with laptops, my acer 5920g is the same, whenever my hard driver spins up you can hear it and theres noticeable hiss aswell.

my laptop does have a HD sound card but it dont really matter because they never pack high quality sound cards into computers, you usually have to buy upgrades. dont worry about it too much, it could also be down to the sensitivity of your headphones, alot of sources hiss with the super fi 5 pro trust me.

im using shure se530 which are rated the same sensitivity as your UE's
 

Users who are viewing this thread

Top