Sony Walkman custom firmware (non-Android)
Oct 1, 2021 at 8:59 AM Post #6,076 of 6,383

Queen6

1000+ Head-Fier
Joined
Mar 3, 2020
Posts
1,139
Likes
2,255
Location
Land of the Unexpected
Only the1Z ships with a hand strap. They got to justify the $2000 more by including something the 1A doesn't have. JK.
You boys are getting short changed then, my WM1A came with the Sony carry strap in the box.

Q-6
 
Oct 1, 2021 at 9:28 AM Post #6,077 of 6,383

MrWalkman

Headphoneus Supremus
Joined
Jun 9, 2020
Posts
2,489
Likes
8,676
Location
Space-Time
Only the1Z ships with a hand strap. They got to justify the $2000 more by including something the 1A doesn't have. JK.
You boys are getting short changed then, my WM1A came with the Sony carry strap in the box.

Q-6

I also got a strap with my first WM1A :D
 
Oct 1, 2021 at 10:10 AM Post #6,078 of 6,383

Queen6

1000+ Head-Fier
Joined
Mar 3, 2020
Posts
1,139
Likes
2,255
Location
Land of the Unexpected
Oct 1, 2021 at 1:17 PM Post #6,079 of 6,383

n00b

500+ Head-Fier
Joined
Aug 8, 2005
Posts
554
Likes
545
Location
Los Angeles, CA
I got 16 hours of continuous playback on a full battery on my WM1A, MX3, Plus mode 2, Walkman One Warm, playing CDQ and hi-res FLAC at 46 volume. I believe im using the other dac initialization too. is that about as much runtime as expected?
 
Oct 1, 2021 at 1:47 PM Post #6,080 of 6,383

MrWalkman

Headphoneus Supremus
Joined
Jun 9, 2020
Posts
2,489
Likes
8,676
Location
Space-Time
I got 16 hours of continuous playback on a full battery on my WM1A, MX3, Plus mode 2, Walkman One Warm, playing CDQ and hi-res FLAC at 46 volume. I believe im using the other dac initialization too. is that about as much runtime as expected?

Depending on the display and BT utilization, you could get that runtime.

Someone was suggesting completely discharging the battery, and then fully recharging it with the Battery Care setting disabled. While it's charging, don't use the player.
 
Last edited:
Oct 1, 2021 at 2:09 PM Post #6,081 of 6,383

n00b

500+ Head-Fier
Joined
Aug 8, 2005
Posts
554
Likes
545
Location
Los Angeles, CA
yep, that's what I did, and I had BT off. the unit is still kind of new, only 100 hours total playback so far so maybe theres some calibration in charging that needs to happen still. thanks for the sanity check
 
Oct 1, 2021 at 2:15 PM Post #6,082 of 6,383

nc8000

Headphoneus Supremus
Joined
Apr 30, 2007
Posts
10,701
Likes
5,853
Location
Kalundborg, Denmark
yep, that's what I did, and I had BT off. the unit is still kind of new, only 100 hours total playback so far so maybe theres some calibration in charging that needs to happen still. thanks for the sanity check
Have you got Source direct or are you using eq and/or effects ?

On the stock battery playing 16/44 flac I got about 20 hours play time and 7 days standby (I never turn it off) on a 90% charge
 
Oct 1, 2021 at 2:33 PM Post #6,083 of 6,383

n00b

500+ Head-Fier
Joined
Aug 8, 2005
Posts
554
Likes
545
Location
Los Angeles, CA
Ohhh true, I basically had every effect other than EQ on. That might explain it. I'll run another test sometime with direct source on. Thanks!
 
Oct 1, 2021 at 3:01 PM Post #6,084 of 6,383

feverfive

Headphoneus Supremus
Joined
Feb 17, 2006
Posts
2,198
Likes
2,384
Location
U.S.
FWIW (and I admit I am super anal/ridiculous when it comes to taking care of my device batteries), my typical WM1A usage is as follows:

I have Battery Care <On>
I exclusively use 4.4mm output; low gain, vol 65 - 70
Screen Brightness at 65
I listen to albums; screen is in use only when selecting new album; ~90% of my music is 16-bit ALAC, the remainder 24-bit ALAC.
I use my WM1A until I first notice only a single bar on the battery meter is showing OR when I've used >13 hours***.
**I have actually gotten down to a single bar only once since switching to WM1 Plus v2; alt DAC mode <On>; normal gain**

I put my battery on the charger last night under these conditions. Battery meter actually still showed two bars. At that point, I had used my WM1A for ~16 hours since the previous charge (yes, I keep track of hours used...<<kill me>> hahahaha)

I have run down the battery to auto shut-off only twice since i got mine brand new (Feb 2020 build date) this past April--after initial full charge out of the box, and a few weeks ago to calibrate battery. I have a calendar reminder set to calibrate battery every 9 months, but unsure if I'll do it even that often going forward.

EDIT: ***when I was previously using FEv2 in Plus Mode, I would typically only get ~10.5 hours of use before battery meter drained down to a single bar....so, WM1 Plus Mode v2 &/or different DAC initialization has significantly improved my battery life
 
Last edited:
Oct 1, 2021 at 5:30 PM Post #6,085 of 6,383

MrWalkman

Headphoneus Supremus
Joined
Jun 9, 2020
Posts
2,489
Likes
8,676
Location
Space-Time
Hi

Thank you for responding. I am really grateful you spending time to help me.

Will the wrong revert version brick my unit? i think i have the this version. -> see screenshot

i don't understand your reply "other Midnight v2". i downloaded the past stock revert. I only see "StockRevert_Midnight_Dawn" and "StockRevert_Midnight_(for_1A)". which one should I use?

1633081378901.png

A wrong StockRevert will just not install.

You first said that you tried "StockRevert_Midnight_(for_1A)", so the other Midnight v2 StockRevert is "StockRevert_Midnight_Dawn" - this is the one you should use in your case.
 
Oct 1, 2021 at 5:37 PM Post #6,086 of 6,383

MrWalkman

Headphoneus Supremus
Joined
Jun 9, 2020
Posts
2,489
Likes
8,676
Location
Space-Time
The Walkman One firmware is now also available
for the NW-ZX300Series players (ZX300/ZX300A)!


Big thanks to Nayparm at www.npaudio.uk for his generous donation of a WM1A
(after having to sell mine, unfortunately), and to everyone who supported me so far!
🍺

As always, if you're using some other custom firmware on the ZX300, you'll first have to
revert to stock, using the StockRevert package made for your installed firmware.

For more info about the settings file, firmware installation and reverting to
stock, changing the sound signature, and more, please check out the FAQ section.



Check out Walkman One (for ZX300), here.


Cheers!
 
Oct 1, 2021 at 7:26 PM Post #6,087 of 6,383

kukuhkd

New Head-Fier
Joined
Aug 31, 2018
Posts
5
Likes
25
Location
Indonesia
having some bugs here in my A55 connected to phone in LDAC, when playing music get interrupted by notification/alarm or accidentally plays Facebook videos, the music stops and loud interference sound never stop until i disconnect the bluetooth from my phone. I'm using zenfone 6. any idea @MrWalkman ?
 
Oct 1, 2021 at 7:36 PM Post #6,088 of 6,383

MrWalkman

Headphoneus Supremus
Joined
Jun 9, 2020
Posts
2,489
Likes
8,676
Location
Space-Time
having some bugs here in my A55 connected to phone in LDAC, when playing music get interrupted by notification/alarm or accidentally plays Facebook videos, the music stops and loud interference sound never stop until i disconnect the bluetooth from my phone. I'm using zenfone 6. any idea @MrWalkman ?

It should be mentioned in the settings file, at the Plus mode version option.
While using the Plus v2 mode and playing audio via BT Receiver while the screen is off, the audio may glitch. Force restart the player by holding the power button for 7 seconds if this happens.
 
Oct 2, 2021 at 3:18 AM Post #6,089 of 6,383

DenverW

1000+ Head-Fier
Joined
May 22, 2019
Posts
1,365
Likes
1,822
Location
San diego
So a few pages ago I mentioned that I was probably not doing something right. I figured out that I was not enabling the part in the settings with the hold button correctly, so the plus mode was not being enabled properly. Sorted! It seems to have helped :).

So I am running the firmware on a A45. I am very curious to hear from people who have listened to this fantastic firmware on multiple different sony devices. I would not expect any difference from the A35-A55 range, but how close can my A45 get to some of the higher models? How would an lower model sony walkman compare to a mid or higher range one that did NOT have the firmware running?

I always get the itch for upgraditis, especially when I find something I enjoy. Is there a consensus of a sweet spot, or is upgrading to the WM1A a no brainer? Love to get opinions!

Currently running stock settings, but I've also enjoyed bright with Mx3 plus 2, and Neutral with J plus 2.
 
Oct 2, 2021 at 6:30 AM Post #6,090 of 6,383

nc8000

Headphoneus Supremus
Joined
Apr 30, 2007
Posts
10,701
Likes
5,853
Location
Kalundborg, Denmark
So a few pages ago I mentioned that I was probably not doing something right. I figured out that I was not enabling the part in the settings with the hold button correctly, so the plus mode was not being enabled properly. Sorted! It seems to have helped :).

So I am running the firmware on a A45. I am very curious to hear from people who have listened to this fantastic firmware on multiple different sony devices. I would not expect any difference from the A35-A55 range, but how close can my A45 get to some of the higher models? How would an lower model sony walkman compare to a mid or higher range one that did NOT have the firmware running?

I always get the itch for upgraditis, especially when I find something I enjoy. Is there a consensus of a sweet spot, or is upgrading to the WM1A a no brainer? Love to get opinions!

Currently running stock settings, but I've also enjoyed bright with Mx3 plus 2, and Neutral with J plus 2.
Had I had my A55 with this fw I would probably never have bought my 1Z. Yes the 1Z (even more so with the Nayparm mod) is clearly better in direct comparison but when I’ve been just listening to the A55 for a while I don’t really miss anything
 

Users who are viewing this thread

Top