[SOLVED] USB microphone makes O2/ODAC stop working
May 29, 2015 at 6:50 PM Thread Starter Post #1 of 1

karljs

Head-Fier
Joined
Oct 27, 2010
Posts
84
Likes
13
PROBLEM SOLVED: For anyone who stumbles across this in the future, I resolved it by setting the O2/ODAC to be both the "default device" (which it already was) and the "default communications device".  I don't know what the latter actually means---not very intuitive---but it worked.
 
 
I've been trying to debug this for a while now.  I have one of the new Revision B versions of the O2/ODAC combo and it seems to work great.  However, if it's plugged in at the same time as my USB microphone, it continues working for a very short amount of time and then stops emitting sound.
 
This is NOT because the default output device is switched.  It actually causes the DAC to somehow fail.  It's still the default device, still recognized by Windows, but even running a simple test sound in the audio settings causes an error like "failed to play test tone".  The only way to fix it is to unplug the mic and reboot.
 
Crucially, I have the older O2/ODAC which works fine.  I was hoping to use the new one (with 1/4 inch jack and rear power) for my desk at home and bring the other to work, but that's looking unlikely now.  I found somebody describing a very similar problem elsewhere:
 
http://www.overclock.net/t/1307175/usb-microphone-usb-dac-amp-unable-to-work-together
 
But the only suggestion is to use an optical cable instead of USB, which the ODAC doesn't support.
 
Any suggestions would be greatly appreciated.
 

Users who are viewing this thread

Top