Shure IEM - not working properly... help!
post-7638521
Thread Starter
Post #1 of 7

mannn

New Head-Fier
Joined
May 24, 2011
Messages
26
Reaction score
10
Joined
May 24, 2011
Posts
26
Likes
10
i have a pair of Shure E3c from a few years ago, which i use once or twice every week for the last 1.5 yrs.  I have always stored it in the case that came with it.
I was using it last week which everything was fine... today when i took it out.. i noticed that the left channel doesn't have any sound while the right side sounds perfect.  as i turn up the volum on my ipod to max, i noticed that the left channel does have a very faint sound coming out, but nothing close to normal hearing volume....
 
is this a problem caused by a splitted wire somehwere along the lines?  fixable?  or am i looking for a new pair?
 
any help would be appreciated.. Thanks in advance!
 
     Share This Post       
post-7638859
Post #2 of 7

sethdude101

New Head-Fier
Joined
Aug 19, 2010
Messages
32
Reaction score
12
Joined
Aug 19, 2010
Posts
32
Likes
12
if it was a split wire, you would not be able to get any sound from the left earbud. it could be a broken driver. i think your best bet would be to call shure. their products useally have a 2 yr warranty anyway, so if they cant fix it hopefully they will replace it
 
     Share This Post       
post-7638898
Post #3 of 7

hamproof

New Head-Fier
Joined
Jul 1, 2006
Messages
8
Reaction score
0
Joined
Jul 1, 2006
Posts
8
Likes
0
Most likely ear wax built up :) Take the cleaning tool and see if you get the harden wax out
 
     Share This Post       
post-7639683
Post #4 of 7

mannn

New Head-Fier
Joined
May 24, 2011
Messages
26
Reaction score
10
Joined
May 24, 2011
Posts
26
Likes
10
Thanks guys... looks like it's the driver that gave out... cleaned the phones as well as wiggled the wires... nothing works.. :frowning2:
 
 
     Share This Post       
post-7641685
Post #5 of 7

hamproof

New Head-Fier
Joined
Jul 1, 2006
Messages
8
Reaction score
0
Joined
Jul 1, 2006
Posts
8
Likes
0
If this is out of warranty, you can contact Shure and they'll send you a  brand new SE315 for a cool $96 + tax. Shipping is included in the price. You just need to send the defective e3c to them.
 
I did the same 2 weeks ago with my e3g which is the same as e3c except for color and length of cable if I recall. However, if you are comfortable with the e3c, the SE315 may not be for you. I found out a bit too late that the SE315 size, though small, is quite a lot larger than the e3c/g. Memory wire/cable and detachable wires are nice as well as the bass tune port, but I can't get comfortable with the SE315 :frowning2:
 
Not sure what the rules are for offering them for sale, but I rather than offend the mods. I can't put them for sale yet in the forum as I haven't hit the min 15 required posts, though I've been a member since 2006 :frowning2:
 
Here's one more post count added for me :wink:
 
     Share This Post       
post-7642040
Post #6 of 7

mannn

New Head-Fier
Joined
May 24, 2011
Messages
26
Reaction score
10
Joined
May 24, 2011
Posts
26
Likes
10
Thanks so much for the info... are you in USA or Canada?  I wonder if that makes a difference as i am in Canada....
but this gives me hope... i will try and contact them after the weekend
 
 
     Share This Post       
post-7774438
Post #7 of 7

mannn

New Head-Fier
Joined
May 24, 2011
Messages
26
Reaction score
10
Joined
May 24, 2011
Posts
26
Likes
10
Just an update for those who might have similar situation like me.
 
I am located in Canada, when called Shure Canada about the out-of-warranty that Hamproof mentioned, they have no clue, they just send me away saying my IEMs are out of warranty and no repair can be done.  I believe they use a 3rd party repairing agency here in cananda.
 
So i called Shure USA, tell them about my IEM situation, the lady immediately tells me about the replacement program.  I asked if it applies if i ship from canada, and she confirmed she will.  I just need to fill in a form, send in the defect plus pre-authorized payment for the new 315s.
 
done that, 3 weeks later the 315 are at my door!  all for $96 and I was not charged custom or duty or tax
 
i am a happy man once again!  Thanks to Hamproof for the info, i almost throw these away to garbage!
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top