Shanling M0 - Smallest Hi-Res Portable Player - New Firmware V3.6
May 28, 2019 at 6:01 AM Post #5,178 of 6,274

TSch

New Head-Fier
Joined
Jan 10, 2019
Posts
26
Likes
21
Location
france
I would not expect the drained battery to help.

Indeed, if you open the SD card door, you'll see a tiny hole. This is an access to a reset button. I tried it and it resets the M0 to the same state: blocked on Shanling screen.
 
May 28, 2019 at 6:19 AM Post #5,179 of 6,274
Joined
Mar 26, 2015
Posts
3,608
Likes
4,067
Location
Shenzhen, China
Huge apology to everybody.

Apparently there was glitch in update file, so when you updated from M0 set with white theme, it caused these problems on startup.

We are right now uploading fixed system update file, so no other uses should be affected by this.

For currently affected M0, software team will during night and tomorrow look into possible recovery update, that would fix your M0.
 
Shanling Have any question about our players? Just PM me or send me email. Stay updated on Shanling at their sponsor profile on Head-Fi.
 
https://www.facebook.com/Shanling-Audio-603230783166845/ https://twitter.com/ShanlingAudio https://www.instagram.com/shanlingaudio/ http://en.shanling.com/ frankie@shanling.com
May 28, 2019 at 6:43 AM Post #5,180 of 6,274

TSch

New Head-Fier
Joined
Jan 10, 2019
Posts
26
Likes
21
Location
france
Huge apology to everybody.

Apparently there was glitch in update file, so when you updated from M0 set with white theme, it caused these problems on startup.

We are right now uploading fixed system update file, so no other uses should be affected by this.

For currently affected M0, software team will during night and tomorrow look into possible recovery update, that would fix your M0.

Well...I'm not 100% sure (and I cannot check anymore) but I think I was using the "black" theme, not the white one. I hope there is still some way to chat with the M0.
 
May 28, 2019 at 9:26 AM Post #5,182 of 6,274

Rafs

Head-Fier
Joined
Mar 13, 2018
Posts
60
Likes
55
Location
-
Huge apology to everybody.

Apparently there was glitch in update file, so when you updated from M0 set with white theme, it caused these problems on startup.

We are right now uploading fixed system update file, so no other uses should be affected by this.

For currently affected M0, software team will during night and tomorrow look into possible recovery update, that would fix your M0.

FW3.0 is fixed now? Looking into downloading it right now.
Please confirm.
 
May 28, 2019 at 9:35 AM Post #5,183 of 6,274

Mike-WI

500+ Head-Fier
Joined
Oct 31, 2011
Posts
669
Likes
892
Location
WI, USA
FW3.0 is fixed now? Looking into downloading it right now.
Please confirm.
I wouldn't use it unless/until it has a new FW number
 
May 28, 2019 at 12:13 PM Post #5,187 of 6,274

neodante

New Head-Fier
Joined
Dec 11, 2018
Posts
18
Likes
5
Location
Spain
Unfortunately, our software team has limited amount of people and while working on system for M0, then for M2X, M5s, always adding new features people are asking for, they simply do not have enough time to do everything at once, so app was little bit sidelined.

And it's not in planning phase, we have working beta in Chinese.



So in total, we should have 3 different shuffles? Shuffle as it's now, shuffle that ends after current songs are played and then completely random?



Not planning to add rewind on pause to current playback mode.



Please what background you mean exactly? In menu there is no background and on now playing screen it should be showing album art.



My assumption, it's trying to charge from M0, which is not possible and M0 do not recognize it for that reason. Looking at website of Vifa, they do not mention running it over USB from phone, so I think they simply set it to work with more powerful USB output on computer and do not optimize it to be used with portable USB sources.



Some USB-C headphones work with our players.
Actually our Chinese customers wanted to use their USB-C headphones with M0 so much, we needed to add separate USB output mode with variable volume.
Actually I only see on settings a shuffle mode , not another random mode ( so my petition will add a second mode not three )

About the new firmware, Very Thanks to Shanling , now the interface ui is very cool ! Congratulations !
 
May 28, 2019 at 2:38 PM Post #5,189 of 6,274

roebeet

500+ Head-Fier
Joined
Feb 20, 2008
Posts
577
Likes
18
Might want to pull the update file as well, until this is resolved? I usually go there first before reading the forum here and downloaded the 3.0 update five minutes ago.

Going to obviously hold off on using it given what I'm reading here but again suggest you pull that download link for anyone who doesn't peruse this forum.

I wouldn't use it unless/until it has a new FW number

Same feeling. The download I grabbed looked like a 5/28/19 5:44AM time on the update.bin file. So I am assuming it's still this problematic one.
 
Last edited:
May 28, 2019 at 3:12 PM Post #5,190 of 6,274

Rafs

Head-Fier
Joined
Mar 13, 2018
Posts
60
Likes
55
Location
-
Might want to pull the update file as well, until this is resolved? I usually go there first before reading the forum here and downloaded the 3.0 update five minutes ago.

Going to obviously hold off on using it given what I'm reading here but again suggest you pull that download link for anyone who doesn't peruse this forum.



Same feeling. The download I grabbed looked like a 5/28/19 5:44AM time on the update.bin file. So I am assuming it's still this problematic one.

Oh, I got bored of waiting and just risked using the file from google drive, hahaha.
Update went smoothly using the black colored theme, but maybe I just had good luck.

Update.bin and firmware notes had different times as last modified, so maybe it's really fixed, IDK.
My PC is using Spanish timezone so actual time may look different on another computer.

upload_2019-5-28_21-10-56.png


Gotta say EQ is pretty sweet, new-ish UI looks nice.
 
Last edited:

Users who are viewing this thread

Top