1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Shanling M0 - Nano size, touch screen, LDAC & aptX BT, USB DAC/transport and ESS Sabre ES9218P, FW 3.2

Discussion in 'Portable Source Gear' started by Shanling, Mar 16, 2018.
First
 
Back
363 364 365 366 367 368 369 370 371 372
374 375 376 377 378 379 380 381 382 383
Next
 
Last
  1. TopKatz
    Thanks for the micro sd card advice, I've seen some good deals on Amazon, l will probably get 256GB Micro SD Card from Integral for about £28 or a 200GB from SanDisk Ultra for about £22.
     
    keenids likes this.
  2. Shanling
    For replacement cable, please contact your seller.

    Or you can use any other cheap USB-C cable.
     
    Shanling Have any question about our players? Just PM me or send me email. Stay updated on Shanling at their sponsor page on Head-Fi.
     
    https://www.facebook.com/Shanling-Audio-603230783166845/ https://twitter.com/ShanlingAudio https://www.instagram.com/shanlingaudio/ http://en.shanling.com/ frankie@shanling.com
  3. Resuna
    I bought through Amazon, and they limit my access to the reseller. I can ask for a refund on the product but that's about it as far as I can tell.
     
  4. Nolbert0
    @augustr double and triple clicks don't work and the screen defaults to 'clean minimalist' with a massive bt symbol without controls while in bt receiver mode with 3.0 update. And they didn't appear to address the issue in the subsequent 3.1 update.

    So if you're using BT receiver mode on 3.0/1 and you want to skip tracks or pause, you have to click the wheel once to turn on the screen, then need to tap the screen to get the controls to appear. Then, you can pause or skip tracks. So if somebody starts to say something to you, it can be real faff to try and pause the music in time. On FWs prior to 3.0, double clicks can pause the music no problem, which is why I reverted.
     
  5. Shanling
    You can't see who was your seller you bought from? You can reach to them directly.
     
    Shanling Have any question about our players? Just PM me or send me email. Stay updated on Shanling at their sponsor page on Head-Fi.
     
    https://www.facebook.com/Shanling-Audio-603230783166845/ https://twitter.com/ShanlingAudio https://www.instagram.com/shanlingaudio/ http://en.shanling.com/ frankie@shanling.com
  6. augustr
    Oh, i see. This isn't a big issue for me, but I understand why you'd revert.
     
  7. barondla
    @Shanling hooked the M0 to a dac. Dac uses USB type B (printer) connector. Couldn't find a cable with B and C ends in my small town. So I bought an ihome adapter ( female A to C) and used it on the dac's supplied cable. Plays great and sounds even greater.

    Problem is playtime. A full M0 battery is dead in less than an hour! The dac has its own power supply and plugs into ac. Is there something wrong with my adapter cable? Is there circuitry in a simple adapter? If a USB B to C cable would solve the problem I'd order one immediately. Thanks for the help.
     
  8. Shanling
    We saw such behavior only in cases that DAC was still taking power from USB. It might be powered, but still take power over USB. You can try to reach out to DAC manufacturer with this question.

    For USB C to USB B, search on ebay/amazon for Macbook printer cable. That's what we use.
     
    Shanling Have any question about our players? Just PM me or send me email. Stay updated on Shanling at their sponsor page on Head-Fi.
     
    https://www.facebook.com/Shanling-Audio-603230783166845/ https://twitter.com/ShanlingAudio https://www.instagram.com/shanlingaudio/ http://en.shanling.com/ frankie@shanling.com
    barondla likes this.
  9. technobear
    Make sure you turn on the DAC first before connecting to M0 or before turning on M0.
     
    barondla likes this.
  10. tashikoma
    Hello.
    I had this issue with 1.5 FW, but's it's OK since 2.0 (If I recall good) for me.

    Sorry if the question already had and answer, but this topic is pretty long now.... Will the EQ is planned to works with HR files someday ?
     
  11. keenids
    I did some extensive testing on GAPLESS play. I made 8 sound files of sine waves (different pitches) all with a duration of exactly 6.00 seconds. They have no silence at beginning and end, and no fades.
    I saved them in .WAV and .MP3 format and put them on an empty SD card in the M0 player.
    I made 2 albums, a MP3 album and a WAV album.
    I played these files with different settings, recorded the output and measured the length of the sound and the gaps. I also checked if the waveform was faded in or out at beginning and end.
    These are the results:

    GAPLESS only works in LIST PLAY, with an ALBUM selected.

    With any other setting (even when repeating one single file), the M0 plays back as follows:
    - All tracks are faded in and faded out (fade length 15-25ms)
    - Tracks are shortened by 100-500ms, average 300ms.
    - Between tracks, gaps are created with an average length of 400ms, minimum 350ms, max 550ms.

    With my .WAV album selected, LIST PLAY, and GAPLESS ON, gapless play was perfect. No gaps, all files exactly the right length (total playing time of 8 tracks was 48 seconds).

    With my .MP3 album selected, LIST PLAY, and GAPLESS ON, gapless play was as follows:
    - No fade ins, no fade outs
    - Gaps are there, but much shorter than normal: about 35ms. This is audible, but very short.
    - Tracks are shortened by average 100ms (despite the gaps, total playing time was 47.5 seconds)

    My recommendations for Shanling:
    - If possible, find a solution for the small gaps that are still there when playing gapless .mp3 albums
    - If possible, find out why mp3 files are shortened when played gaplessly.
    - Try to eliminate the fades and file length reduction in normal playing mode. The 0.4s gaps are no problem.
    - Please please please make GAPLESS also work when playing in SHUFFLE (or any other) mode. That would be a simple way to get rid of shortened files and fades, too.
     
    Last edited: Sep 19, 2019
    endgame4, Nolbert0 and DBaldock9 like this.
  12. endgame4
    With 'LIST PLAY' you mean the 'Folders' way, not through 'My Music'?

    Thanks for doing the experiments. The fading confirms what I believed to be hearing. It is really not a great solution.
     
    keenids likes this.
  13. Nailgun
    @keenids I'm not sure what you mean with "Try to eliminate the fades and file length reduction in normal playing mode. The 0.4s gaps are no problem." and "GAPLESS only works in LIST PLAY, with an ALBUM selected."

    But I can confirm that a small audible gap between mp3 is there in any listening mode (I'm using folder play now since the id3 tag album artist was messing up my collection) and it should be eliminated for smooth play.

    Thanks for the analysis! I hope it will help software team fixin this.
     
  14. keenids
    sorry, I posted twice out of clumsiness
     
    Last edited: Sep 20, 2019
  15. keenids
    With LIST PLAY, I mean the setting in the menu PLAY MODE
    Here there are 4 options: LIST PLAY, REPEAT TRACK, SHUFFLE and REPEAT ALL.
    Gapless play only works when LIST PLAY is selected in the menu (PLAYBACK>PLAY MODE) - AND when an "Album" is selected in the menu MY MUSIC.
    (When you "Select All" in the menu MY MUSIC, and choose LIST PLAY in the menu PLAYBACK, gapless still does not work.
    Gapless also does not work when you do select an album in the My Music menu, but put PLAYBACK on SHUFFLE.)

    Maybe the developers thought that a 20ms fade would not be audible, but it is - leave alone the 35ms gap between mp3 files in Gapless play...
    The reason that the fades are so prominent, especially at the end of files, is that part of the file (300-500 ms) is actually cut off on top of that. This often results in a fade out when the music is still playing.
    But exactly the same fade is occurring at the beginning of all files when played in normal mode. When there is no silence at all at the start of the file, this is also audible.

    Note that fading (and cutting off half a second) does not occur when Gapless works. Unfortunately it only works with very specific settings.
    Hence my recommendation to make GAPLESS work with all selections and play settings.
    It would not harm anyone, since GAPLESS can always be turned off if it has undesired effects.
    Right now, normal play has undesired effects, which cannot be undone by turning on GAPLESS.

    Thanks for your remarks, especially about playing from a folder. I did not check that.
    I also did not check the performance when REPEAT ALL is selected - I will do that and come back with thte results.
     
    Last edited: Sep 20, 2019
First
 
Back
363 364 365 366 367 368 369 370 371 372
374 375 376 377 378 379 380 381 382 383
Next
 
Last

Share This Page