1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Shanling M0 - Nano size, touch screen, LDAC & aptX BT, USB DAC/transport and ESS Sabre ES9218P, FW 3.2

Discussion in 'Portable Source Gear' started by Shanling, Mar 16, 2018.
First
 
Back
291 292 293 294 295 296 297 298 299 300
302 303 304 305 306 307 308 309 310 311
Next
 
Last
  1. dimmockg
    Selling a new in box office blue case for the shanling M0

    Listed in the portable source gear for sale section
     
  2. paddler57
    20180712_202850.jpg Speaking of which, I found a small handful of those little Acco clips I posted with my case if anyone is interested. Happy to mail one for a buck.
     
    SteveOliver and DBaldock9 like this.
  3. roladyzator
    My impression is that at 32 ohm output impedance the current output limitation comes into play. 80 mW at 32 ohm means 1.6 V and 50 mA. If 50 mA is the output limit, max voltage of 2V can be reached at 40 ohms output inpedance.
    Likewise, with even smaller output impedance the output power would be even smaller, for example with 16 ohms output impedance and 50 mA current output, the power would be just 40 mW and voltage would be just 0.8 V
     
  4. Shanling
    @fish1050 Interesting problem with M0, didn't get any similar report, but glad reflashing firmware fixed it.

    Our software team did some changes to the way how are M0 and M5s charging, to prevent overcharging. But they didn't set it properly, so if you now connect 100% charged device to charger or computer, you were not able to turn it on. Need to remove cable, turn it on and then put it on charger again.
    It's error and will be fixed.

    Interesting idea for touch screen. Just thinking how would you need to set scrolling? You need precise movements, so highlight can get on the exact item you want. But at the same time, that would extremely slow down any browsing of bigger lists.

    M0 has only USB out. TO use this cable, device need to have inside different hardware set for coaxial output.

    All of them using USB cable. We even make one specially for Mojo, Shanling L2.

    Firmware 2.3 have some improvements to overall BT connectivity and especially some additional fixes to SBC codec.

    USB DAC delay is unfortunately problem of M0.
     
    Shanling Have any question about our players? Just PM me or send me email. Stay updated on Shanling at their sponsor page on Head-Fi.
     
    https://www.facebook.com/Shanling-Audio-603230783166845/ https://twitter.com/ShanlingAudio https://www.instagram.com/shanlingaudio/ http://en.shanling.com/ frankie@shanling.com
    gobin and barondla like this.
  5. gobin
    Thanks for taking time and directly answer all users questions. It's rare for me to see a company is this in touch with the customers.

    So is this DAC delay problem a hardware limitation or software issue that will hopefully be addressed in the future?
    For the most part I've been very please using the M0 as a portable solution to filter out static and get a clean signal from pc with crappy old sound cards; and I'm very much intent to continued using it as such for a long time.

    I also updated my M0 to the latest firmware (2.3) but the cut out and statics still persist, and it occurs a bit more frequent now. Is there any other thing I could try to remedy this?
     
  6. Shanling
    Probably something that needs fixing in software.

    Can you try it in BT receiver mode with different source and with different codec than just basic SBC?
     
    Shanling Have any question about our players? Just PM me or send me email. Stay updated on Shanling at their sponsor page on Head-Fi.
     
    https://www.facebook.com/Shanling-Audio-603230783166845/ https://twitter.com/ShanlingAudio https://www.instagram.com/shanlingaudio/ http://en.shanling.com/ frankie@shanling.com
  7. gobin
    So I tried it with my phone which use AAC, same problems, heavy static and cut off every 5 min.

    However, I tried resetting to factory setting and the problem seems to subdue.

    SBC stills have that statics and sometimes, and complete silence for a good 30 sec every now and then but at much more acceptable rate now (I'd say every 1-2 hours). So I guess that's normal for Bluetooth connection? But the effective range is very short, I have to sit within 5 feet from my sources, otherwise the static will come in and cut out happens constantly, which won't go away until I restart the Bluetooth (turn off and on) on M0.

    AAC on the other hand seems to work fine even at long range.

    One last thing, is shutting itself down when it's fully charged normal behavior for the M0?
     
  8. Rafs
    Hi all,
    Just bought an M0 (coming from a previous M1). Love the thing. Seems there's still some issues with the m3u playlists when the song has special characters in the metadata.Saw previous comments that you're still working on both things so I don't care much.

    Example: In the below file the M0 only shows until song 3 (releaser). As if the playlist only included those 3 songs. FW: 2.3 so it's on the latest update.
    M1 can handle it okay (no problems whatsoever with this same playlist), and even when it can't handle it, shows as a file that can't play or some errors in the name and skips it.
    {38109733-A32F-47C9-81BD-D370E26DE7BC}.png.jpg

    Also, felt that the leather case would benefit from a lanyard attachment so I modded mine. Even made me a leather Shanling lanyard from an old elastic lanyard I had around. Ended up all super solid and secure (Don't wan't to drop this little guy).
    Pictures below. :slight_smile:

    IMG_20190123_124804.jpg IMG_20190123_124818.jpg IMG_20190123_124847.jpg IMG_20190123_125030_1.jpg IMG_20190123_125113_1.jpg
     
    Last edited: Jan 23, 2019
  9. DBaldock9
    It looks like there are two things that happen simultaneously in the fourth song title - The name has a character with an accent, and there's now three "periods / decimal points" in the file name (one after the "04", one after "Feat", and one before "mp3").
    I suppose either of these could cause issues with the embedded Linux OS and Music Player software.
     
    barondla likes this.
  10. hornytoad
    Shanling , could you please write a script so that when playing the MO in the car the artist and track information come up with
    a Bluetooth connection ?

    Thanks .
     
  11. Rafs
    Can't be the triple period since I just checked on other playlists with the same scenario "0x. Song Name [Feat. someone].mp3" and I could play it without problems.
    I actually think it's the accented letters, but it's not in the file name, it's on the metadata.

    All this playlist were made for the M1 and it plays them all correctly. I know it's a different OS and all, but it's all linux based I think.
    So I guess it could be corrected via firmware?
     
    Last edited: Jan 23, 2019
    barondla and DBaldock9 like this.
  12. DBaldock9
    Yes, most all of the compact DAPs are running some sort of embedded Linux under the hood (even Android is based on Linux).
    So, the difference is the Music Player software - the M1, M2s, M3s all run HiBy Music Player; and the M0 & M5s both run the Shanling in-house developed Music Player.
    The new units have some known issues with accented fonts, which I believe @Shanling is working on.
     
    Rafs likes this.
  13. Rafs
    I believe so too. Been reading this thread while waiting for my M0 to arrive from China (I know warranty and whatnot).
    Seems special characters are an ongoing bug still, and m3u playlist adoption is very recent.

    So I guess OS still needs some maturity but the DAP is great. Lots of power and battery.
    Whenever the app works for the link thing, that'll be very welcome.

    I used to use the OTG from the M1 with a USB drive all the time when checking the metadata.
    Hope that option comes in the future.
     
    DBaldock9 likes this.
  14. TSch
    It is likely that this is a problem of character encoding (UTF8/Unicode vs ISO8859 or ASCII for example). It may be non-trivial to detect this from the appearance of the text alone. For a triple period, for example, it can be represented either as three independent dots "..." or as the Unicode character U+2026 (HORIZONTAL ELLIPSIS) here: … It would need a test for sure, but it's not unlikely that the M0 will choke on the second one, not the first.
     
    barondla and Rafs like this.
  15. Rafs
    Yeah I got you. Saw something similar happening with apostrophes. Some were okay, some would make the player struggle.
    All this happened before when making the whole media library work well for the M1. So I think that now it's all some quirks from the M0.

    File names were all batch rewritten using the Mp3tag program. Characters are all same encoding. I also did some batch removing accented characters from the filenames (and correcting apostrophes, heh).
    I keep thinking that it is the accented characters from the metadata. All playlists consistently fail when there are special characters in the metadata. The one above is just an example.

    Franky ( @Shanling ) what do you think?
     
    Last edited: Jan 23, 2019
First
 
Back
291 292 293 294 295 296 297 298 299 300
302 303 304 305 306 307 308 309 310 311
Next
 
Last

Share This Page