Schiit 'Magnius' - new $199 fully balanced headphone amp
Oct 8, 2020 at 3:08 PM Post #151 of 225

taipan254

New Head-Fier
Joined
Dec 13, 2015
Posts
8
Likes
2
Agreed. Fully balanced I don't have an issue. Once in a while I would hear a buzz for like 2 seconds and then it would go away. However, I wanted to be able to switch between my open back and closed back cans easily, which is why I decided to connect the Sundara to the SE output. Honestly, it sounds fine to me and I don't get any noise if I'm only using the SE output (this is all with balanced input). However, the moment I use both outputs, then it's noise city. :disappointed:


I hear you. it becomes really loud when i put my finger on the chassis. When i'm not touching the chassis, the sound is barely audible. Annoying, but I guess that's what you get with an ungrounded $199 amp!
 
Oct 8, 2020 at 3:15 PM Post #152 of 225

lord_tris

1000+ Head-Fier
Joined
Jun 16, 2006
Posts
1,161
Likes
76
Location
westerville
I hear you. it becomes really loud when i put my finger on the chassis. When i'm not touching the chassis, the sound is barely audible. Annoying, but I guess that's what you get with an ungrounded $199 amp!
Question, how long is your finger touching the chassis of the amp while you are listening to music?
 
Oct 8, 2020 at 3:19 PM Post #153 of 225

taipan254

New Head-Fier
Joined
Dec 13, 2015
Posts
8
Likes
2
Question, how long is your finger touching the chassis of the amp while you are listening to music?

hahaha - don't get any dirty thoughts. not too long! I was switching a lot of inputs and cables and so that involved touching the chassis. Also the noise returned when touching the pot to adjust volume (which is fairly frequent). Sucks that this happens, but for $199, and given how good balanced in and out sounds, I'm not gonna complain much.
 
Oct 8, 2020 at 3:24 PM Post #154 of 225

lord_tris

1000+ Head-Fier
Joined
Jun 16, 2006
Posts
1,161
Likes
76
Location
westerville
hahaha - don't get any dirty thoughts. not too long! I was switching a lot of inputs and cables and so that involved touching the chassis. Also the noise returned when touching the pot to adjust volume (which is fairly frequent). Sucks that this happens, but for $199, and given how good balanced in and out sounds, I'm not gonna complain much.

Still weird, I have not heard any of these problems with mine. Even touching the pot or switching from my loxjie p20 to the magnius for comparing sounds. Maybe you have something wrong with your wall wart or something is wrong with the amp.
 
Oct 8, 2020 at 3:25 PM Post #155 of 225

lord_tris

1000+ Head-Fier
Joined
Jun 16, 2006
Posts
1,161
Likes
76
Location
westerville
hahaha - don't get any dirty thoughts. not too long! I was switching a lot of inputs and cables and so that involved touching the chassis. Also the noise returned when touching the pot to adjust volume (which is fairly frequent). Sucks that this happens, but for $199, and given how good balanced in and out sounds, I'm not gonna complain much.
Also you hear this sound over your music?
 
Oct 8, 2020 at 3:32 PM Post #156 of 225

taipan254

New Head-Fier
Joined
Dec 13, 2015
Posts
8
Likes
2
Also you hear this sound over your music?

Finding ground loops can be a pain. But a defective unit or transformer unit could also be the culprit. My main system has excellent power conditioning... it may be worth testing the schiit stack on that in SE mode and Balanced to see if this is just some weird grounding issue at my work desk where this system is located, or perhaps symptomatic of something wrong with the unit or transformer. I'll try to do that tonight and report back.
 
Oct 8, 2020 at 4:40 PM Post #157 of 225

HumdrumPenguin

100+ Head-Fier
Joined
Dec 1, 2014
Posts
219
Likes
189
Location
Toronto, Canada
Agreed. Fully balanced I don't have an issue. Once in a while I would hear a buzz for like 2 seconds and then it would go away. However, I wanted to be able to switch between my open back and closed back cans easily, which is why I decided to connect the Sundara to the SE output. Honestly, it sounds fine to me and I don't get any noise if I'm only using the SE output (this is all with balanced input). However, the moment I use both outputs, then it's noise city. :disappointed:

Interesting to see that you get a buzz for even 2 sec when running balanced. I’ve never hear anything like that on the Asgard 3 (fed by the Bifrost 2).
 
Oct 8, 2020 at 7:05 PM Post #158 of 225

MakubexGB

100+ Head-Fier
Joined
Feb 27, 2005
Posts
266
Likes
172
Interesting to see that you get a buzz for even 2 sec when running balanced. I’ve never hear anything like that on the Asgard 3 (fed by the Bifrost 2).
Yeah, I wonder what it could be. At first I thought it was the DAC so I changed the Modius' USB power cable and the data cable but it didn't help. Getting that buzz when I use both outputs on the Magnius at the same time, leads me to believe it was always the amp.
 
Oct 10, 2020 at 11:09 AM Post #159 of 225

MakubexGB

100+ Head-Fier
Joined
Feb 27, 2005
Posts
266
Likes
172
Interesting to see that you get a buzz for even 2 sec when running balanced. I’ve never hear anything like that on the Asgard 3 (fed by the Bifrost 2).

I think I figured it out or at least part of it. This "2 sec buzz" that happens once in a while seems to be interference happening when my phone is near by. I can sometimes trigger it on demand by hovering my phone over the amp, especially near the cable. It doesn't happen all the time, though. I'm not sure what exactly triggers it. Sometimes I try making phone calls, playing videos, browsing, etc. with my phone near the amp and nothing happens. Other times I simply hover my locked phone over it and it buzzes in rhythm with my movements.

I get my Topping A90 today. We'll see how that compares.

PS. I made sure this is on the amp by unplugging the power and data from the DAC while the buzz was occurring.
 
Last edited:
Oct 10, 2020 at 1:45 PM Post #160 of 225

HumdrumPenguin

100+ Head-Fier
Joined
Dec 1, 2014
Posts
219
Likes
189
Location
Toronto, Canada
I think I figured it out or at least part of it. This "2 sec buzz" that happens once in a while seems to be interference happening when my phone is near by. I can sometimes trigger it on demand by hovering my phone over the amp, especially near the cable. It doesn't happen all the time, though. I'm not sure what exactly triggers it. Sometimes I try making phone calls, playing videos, browsing, etc. with my phone near the amp and nothing happens. Other times I simply hover my locked phone over it and it buzzes in rhythm with my movements.

I get my Topping T90 today. We'll see how that compares.

PS. I made sure this is on the amp by unplugging the power and data from the DAC while the buzz was occurring.

Previously on an old computer, I would hear interference on the case right before my phone started ringing. Try calling yourself with the phone nearby the amp and see what happens. Was that T90 a typo?
 
Nov 5, 2020 at 7:56 AM Post #163 of 225

adydula

Headphoneus Supremus
Joined
Dec 14, 2010
Posts
3,458
Likes
2,838
I had the Topping D90 AKM dac here for a week with a pair of Hi-Fi man Susvaras.....it was on the bright side for me...thin etc...but other than that ok. It has several roll off filters that did not do anything for me at all....

Runs hot IMO..

Bifrost 2 definitely the more desired of the two for me,

Alex
 
Nov 29, 2020 at 3:20 PM Post #164 of 225

iMongui

100+ Head-Fier
Joined
Jan 25, 2017
Posts
381
Likes
177
Hi mates, I’m close to buy one Magnius and I would like to know something, is there any chance that I could use the XLR output on the back side to connect to an Edifier 1700BT to the RCA port using a cable with thus schema? I know that I would going from XLR balanced to RCA unbalanced but more than loose the balanced it’s just to use the output for this purpose and left the RCA output for another use and know that I’m not going to break or damage anything so, any tip?
 
Nov 29, 2020 at 3:37 PM Post #165 of 225

lord_tris

1000+ Head-Fier
Joined
Jun 16, 2006
Posts
1,161
Likes
76
Location
westerville
Hi mates, I’m close to buy one Magnius and I would like to know something, is there any chance that I could use the XLR output on the back side to connect to an Edifier 1700BT to the RCA port using a cable with thus schema? I know that I would going from XLR balanced to RCA unbalanced but more than loose the balanced it’s just to use the output for this purpose and left the RCA output for another use and know that I’m not going to break or damage anything so, any tip?
Those are inputs though... The 4pin on the front is output. Do you mean the Modius dac?
 

Users who are viewing this thread

Top