Schiit Jotunheim Review / Preview - Head-Fi TV
post-14740747
Post #6,016 of 6,452

sixstringmonk

New Head-Fier
Joined
May 28, 2018
Messages
10
Reaction score
8
Location
Saint Paul, MN
Joined
May 28, 2018
Location
Saint Paul, MN
Posts
10
Likes
8
So I just experienced the infamous "ringing" glitch with my Jot multi-bit / Windows 10. This is the first time I've noticed it having owned the unit since late June 2018. I heard a faint ringing noise in the left channel on some newly purchased hi-res tracks. I initially thought it was the file, but I switched to my speakers running off of my onboard sound card and the ringing was not present. I then went into Sound control panel -> playback tab -> Schiit -> properties -> advanced -> test. The ringing was really obvious on the left / right audio test. Turning the unit off and back on again immediately fixed the issue. The best way I can describe the ringing is that it sounded like a "crystalize" or "sitar" patch on a cheap guitar effects unit. ...kind of like a resonating ring filter or similar.
 
Last edited:
     Share This Post       
post-14740825
Post #6,017 of 6,452

Dabbaranks

Head-Fier
Joined
Dec 29, 2017
Messages
82
Reaction score
99
Location
Ontario, Canada
Joined
Dec 29, 2017
Location
Ontario, Canada
Posts
82
Likes
99
So I just experienced the infamous "ringing" glitch with my Jot multi-bit / Windows 10.
This is actually the first time I’ve heard of this, and I thought I’ve been going crazy since I’ve experienced it twice.
 
     Share This Post       
  • Like
Reactions: sixstringmonk
post-14755783
Post #6,018 of 6,452

connieflyer

Headphoneus Supremus
Joined
Aug 23, 2012
Messages
3,534
Reaction score
1,119
Joined
Aug 23, 2012
Posts
3,534
Likes
1,119
Hi Scutey, see you are considering a Jotenhiem, a new member on the Euforia thread, triggsviola, has experience with what you are looking for you may want to reconsider. His thoughts are on page 366, he is online right now if you care to engage. He just got his Euforia and has some nice equipment with lots of phones. Good luck.
 
     Share This Post       
  • Like
Reactions: Scutey
post-14755914
Post #6,019 of 6,452

MikeW

Headphoneus Supremus
Joined
Nov 4, 2005
Messages
1,786
Reaction score
235
Joined
Nov 4, 2005
Posts
1,786
Likes
235
So I just experienced the infamous "ringing" glitch with my Jot multi-bit / Windows 10. This is the first time I've noticed it having owned the unit since late June 2018. I heard a faint ringing noise in the left channel on some newly purchased hi-res tracks. I initially thought it was the file, but I switched to my speakers running off of my onboard sound card and the ringing was not present. I then went into Sound control panel -> playback tab -> Schiit -> properties -> advanced -> test. The ringing was really obvious on the left / right audio test. Turning the unit off and back on again immediately fixed the issue. The best way I can describe the ringing is that it sounded like a "crystalize" or "sitar" patch on a cheap guitar effects unit. ...kind of like a resonating ring filter or similar.
They all do this occasionally. It's pretty rare, a power cycle clear's it up. I emailed schiit about it awhile back and they played dumb, but I know they can't not know about it. I think modi-multibit users sometimes experience it too with USB. My theory is just usb driver foolery. I've not experienced it since I turned off usb power management in windows settings.
 
Last edited:
     Share This Post       
post-14755944
Post #6,020 of 6,452

Dabbaranks

Head-Fier
Joined
Dec 29, 2017
Messages
82
Reaction score
99
Location
Ontario, Canada
Joined
Dec 29, 2017
Location
Ontario, Canada
Posts
82
Likes
99
They all do this occasionally. It's pretty rare, a power cycle clear's it up. I emailed schiit about it awhile back and they played dumb, but I know they can't not know about it. I think modi-multibit users sometimes experience it too with USB. My theory is just usb driver foolery. I've not experienced it since I turned off usb power management in windows settings.
I’ll report that mine hasn’t done the right channel ringing for over a month now, happened to me twice since installing the multi bit (installed Dec 12th, 2018) but both times was within the first two weeks of install. On windows 10.
 
     Share This Post       
post-14756325
Post #6,021 of 6,452

the finisher

1000+ Head-Fier
Joined
Feb 13, 2018
Messages
1,145
Reaction score
2,350
Location
Nearfield, MN
Joined
Feb 13, 2018
Location
Nearfield, MN
Posts
1,145
Likes
2,350
Hi Scutey, see you are considering a Jotenhiem, a new member on the Euforia thread, triggsviola, has experience with what you are looking for you may want to reconsider. His thoughts are on page 366, he is online right now if you care to engage. He just got his Euforia and has some nice equipment with lots of phones. Good luck.

https://www.wikileaf.com/strain/euforia/

Kinda not even similar things here except both are headphone amps.

Love my Jot :L3000:
 
Last edited:
     Share This Post       
  • Like
Reactions: jimmers
post-14756758
Post #6,022 of 6,452

Tuneslover

Headphoneus Supremus
Joined
Jun 26, 2014
Messages
1,839
Reaction score
812
Location
SW Ontario, Canada
Joined
Jun 26, 2014
Location
SW Ontario, Canada
Posts
1,839
Likes
812
They all do this occasionally. It's pretty rare, a power cycle clear's it up. I emailed schiit about it awhile back and they played dumb, but I know they can't not know about it. I think modi-multibit users sometimes experience it too with USB. My theory is just usb driver foolery. I've not experienced it since I turned off usb power management in windows settings.
Schiit knows about it and they were the ones that recommended power cycling to clear up the ringing. Incidentally I only use Toslink and Coaxial inputs and have experienced the ringing. Yep, power cycle your Mimby once in a while and it will be fine.
 
     Share This Post       
post-14756792
Post #6,023 of 6,452

the finisher

1000+ Head-Fier
Joined
Feb 13, 2018
Messages
1,145
Reaction score
2,350
Location
Nearfield, MN
Joined
Feb 13, 2018
Location
Nearfield, MN
Posts
1,145
Likes
2,350
 
     Share This Post       
post-14759203
Post #6,024 of 6,452

Scutey

Headphoneus Supremus
Joined
Feb 21, 2012
Messages
2,343
Reaction score
1,736
Location
Plymouth, England
Joined
Feb 21, 2012
Location
Plymouth, England
Posts
2,343
Likes
1,736
Hi Scutey, see you are considering a Jotenhiem, a new member on the Euforia thread, triggsviola, has experience with what you are looking for you may want to reconsider. His thoughts are on page 366, he is online right now if you care to engage. He just got his Euforia and has some nice equipment with lots of phones. Good luck.
Hi cf, apologies for not replying sooner, thanks for letting me know, I will take a look, I was after another amp, for casual listening, so it will be valuable info!.
 
     Share This Post       
  • Like
Reactions: connieflyer
post-14786747
Post #6,025 of 6,452

tamleo

100+ Head-Fier
Joined
Jul 13, 2010
Messages
217
Reaction score
33
Joined
Jul 13, 2010
Posts
217
Likes
33
Hello guys,
I have been listened to the ModiMultibit/Magni3 combo for 6 months. I like the combo because it is very detailed. But now I find its sound to be too thick and have a dim in the upper mids range paired with my LCD-2 and v-shaped paired with my DBA-02 iem.
Can you guys please tell me how much the Jot sounds less thick and v-shaped compared to the Magni3?
Sorry for my English and thank you!
 
Last edited:
     Share This Post       
  • Like
Reactions: the finisher
post-14786847
Post #6,026 of 6,452

the finisher

1000+ Head-Fier
Joined
Feb 13, 2018
Messages
1,145
Reaction score
2,350
Location
Nearfield, MN
Joined
Feb 13, 2018
Location
Nearfield, MN
Posts
1,145
Likes
2,350
I have not compared the two.

But the jotunheim is certainly not thick. It is very neutral.
 
     Share This Post       
  • Like
Reactions: KLJTech and tamleo
post-14787735
Post #6,027 of 6,452

Tuneslover

Headphoneus Supremus
Joined
Jun 26, 2014
Messages
1,839
Reaction score
812
Location
SW Ontario, Canada
Joined
Jun 26, 2014
Location
SW Ontario, Canada
Posts
1,839
Likes
812
Hello guys,
I have been listened to the ModiMultibit/Magni3 combo for 6 months. I like the combo because it is very detailed. But now I find its sound to be too thick and have a dim in the upper mids range paired with my LCD-2 and v-shaped paired with my DBA-02 iem.
Can you guys please tell me how much the Jot sounds less thick and v-shaped compared to the Magni3?
Sorry for my English and thank you!
I started out with the original Magni (and Modi), then upgraded to the Magni 2U. Eventually upgraded to the Jotunheim (because I was interested in going balanced) when it came out. I still have the Jotunheim and have no plans on replacing it. It is a cleaner sounding amp than the Magni's but still a bit on the bright side but no where as harsh sounding as the those Magni's. I tried various headphones with it but my favourite combo is with the HD6XX (stock cable re-terminated to XLR) with Dekoni Elite Velour (which nicely calms down the treble) and the Modi MB.
They all do this occasionally. It's pretty rare, a power cycle clear's it up. I emailed schiit about it awhile back and they played dumb, but I know they can't not know about it. I think modi-multibit users sometimes experience it too with USB. My theory is just usb driver foolery. I've not experienced it since I turned off usb power management in windows settings.
They do know about it! They recommended the reboot to fix the problem...which it does.
 
Last edited:
     Share This Post       
post-14830952
Post #6,028 of 6,452

Anonimar

New Head-Fier
Joined
Mar 2, 2019
Messages
2
Reaction score
0
Location
USA
Joined
Mar 2, 2019
Location
USA
Posts
2
Likes
0
Picked up a Jotunheim used from @ACDOAN , so far I'm liking it.

My unit has the balanced DAC module. I noticed it was giving some faint noise/hiss only audible when cranking the dial up all the way when nothing playing. Out of curiosity I switched the input to my Topping D30 and the hiss was gone when fully turning the knob. I've heard that combined DAC/Amps sharing the same power supply like they inherently do in all-in-one units can lead to some noise being introduced into the chain, so it makes sense I guess.

I still plan on A/B'ing both the integrated DAC and the Topping, I wouldn't be surprised if the external DAC ends up winning out though, as an integrated DAC is more for convenience than performance is the impression I get. Other than that, the amp itself has been pairing great with Focal Clear. My biggest reason for upgrading from my Magni 3 was wanting a more substantial amp, the magni is so dinky and cheap feeling, especially the scratchy pot. The more substantial Jot feels so nice in comparison.
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Top