Question on Ubuntu output to DAC + volume on OS and Spotify client
Jan 21, 2016 at 10:11 PM Thread Starter Post #1 of 3

thk3421

New Head-Fier
Joined
Jan 19, 2010
Posts
36
Likes
0
I have an Ubuntu desktop with an external Modi DAC that outputs into my headphone amplifier.  It works and plays music.  My question is:  If the computer is outputting music before amplification to the external DAC, why does the volume slider on the Spotify client change the volume?  Similarly, the Linux volume slider also changes the volume.  I would expect only my headphone amplifier to be able to adjust the volume.
 
Is this expected behavior?  It suggests to me that I'm not outputting 'bit-perfect' audio to my DAC.
 
I've gone over (and over and over) this thread:
http://www.head-fi.org/t/561961/bit-perfect-audio-from-linux
 
and when I play music from gmusicbrowser, it sounds fantastic, a noticeable upgrade.  So how can I get the same bit perfect output when listening to Spotify?
Any help from someone knowledgeable about these things would be GREATLY appreciated.  Thank you so much ahead of time.
 
Thomas
 
ps.  here are a few details in case it helps:  
 
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: 92HD73E1X5 Analog [92HD73E1X5 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: 92HD73E1X5 Digital [92HD73E1X5 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Device [Schiit USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
 
 
and I can select the device in the Ubuntu Sound Output menu and it plays.  I'm not sure what else needs to be done to ensure bit-perfect audio output to the DAC.  I have configured gmusicbrowser to use ALSA as my output device, as instructed in the thread mentioned above.  Of course, Spotify has no such output selection in its settings.
 
Jan 22, 2016 at 9:32 AM Post #2 of 3

thk3421

New Head-Fier
Joined
Jan 19, 2010
Posts
36
Likes
0
I figured out the issue:  I was using PulseAudio without realizing it. The only way I can figure out how to get Spotify to use ALSA is to run the windows version with wine and use winecfg to select the ALSA audio output.  
 
Does anyone know how to get the native Linux Spotify client to use ALSA?
 

Users who are viewing this thread

Top