QUAD ERA-1 Thread
post-14971092
Post #511 of 856

menuki

500+ Head-Fier
Joined
May 26, 2015
Messages
600
Reaction score
458
Location
Germany - Deutschland
Joined
May 26, 2015
Location
Germany - Deutschland
Posts
600
Likes
458
I felt like the vibrating diaphragm was stuck and then it failed to output any music. Some hard taps on the outer shell or tuning up with volume helped putting it back to business...
Just got them an hour ago. Disappointed to say the least, as the right side is not working.

Gave the right side a few taps, now they played Music again on that side... but only for a few minutes, and, I shouldn't have to do that on a 700€ headphone.. The sound is really really good, but I'm afraid I'll have to return them since there seem to be some QC issues going on. Hope they get this resolved, because these have a lot of potential, but I will probably stay away from them for now. :/

EDIT: Even getting sad right now to be honest. :D I just tap them while listenting right now and they sound oh so good... it's confusing to me how something like this can happen. If I could be 100% sure that a replacement model wouldn't have this issue, I'd be in, but I can never know can I..
 
Last edited:
     Share This Post       
post-14971164
Post #512 of 856

ipiipi923

New Head-Fier
Joined
Jan 5, 2017
Messages
23
Reaction score
14
Joined
Jan 5, 2017
Posts
23
Likes
14
Just got them an hour ago. Disappointed to say the least, as the right side is not working.

Gave the right side a few taps, now they played Music again on that side... but only for a few minutes, and, I shouldn't have to do that on a 700€ headphone.. The sound is really really good, but I'm afraid I'll have to return them since there seem to be some QC issues going on. Hope they get this resolved, because these have a lot of potential, but I will probably stay away from them for now. :/

EDIT: Even getting sad right now to be honest. :D I just tap them while listenting right now and they sound oh so good... it's confusing to me how something like this can happen. If I could be 100% sure that a replacement model wouldn't have this issue, I'd be in, but I can never know can I..
I contacted IAG Group and swapped for a new pair (half of shipping cost on me)... luckily the replacement works perfectly fine now. Yea it sounds soooo good man..
 
     Share This Post       
  • Like
Reactions: menuki
post-14971170
Post #513 of 856

menuki

500+ Head-Fier
Joined
May 26, 2015
Messages
600
Reaction score
458
Location
Germany - Deutschland
Joined
May 26, 2015
Location
Germany - Deutschland
Posts
600
Likes
458
I contacted IAG Group and swapped for a new pair (half of shipping cost on me)... luckily the replacement works perfectly fine now. Yea it sounds soooo good man..
Glad to hear that man! Hope it'll stay that way, because right now both sides don't produce any sounds anymore. xD Tried a different cable, no luck. When I tap them lightly they produce sound for a second and then turn silent again. It's so strange... I must've gotten a really bad pair, maybe I'm also just really unlucky in this case but it's still so strange...

I effectively cannot listen to them anymore now. If they work, they work for a few minutes and the sound even pans from the left to the right, gets louder, quieter, without me doing anything. What the heck. :D
 
     Share This Post       
post-14971294
Post #514 of 856

ipiipi923

New Head-Fier
Joined
Jan 5, 2017
Messages
23
Reaction score
14
Joined
Jan 5, 2017
Posts
23
Likes
14
Glad to hear that man! Hope it'll stay that way, because right now both sides don't produce any sounds anymore. xD Tried a different cable, no luck. When I tap them lightly they produce sound for a second and then turn silent again. It's so strange... I must've gotten a really bad pair, maybe I'm also just really unlucky in this case but it's still so strange...

I effectively cannot listen to them anymore now. If they work, they work for a few minutes and the sound even pans from the left to the right, gets louder, quieter, without me doing anything. What the heck. :D
You may try driving the cans with high current....sometimes it works for me (like sneezing) lol
 
     Share This Post       
post-14971301
Post #515 of 856

menuki

500+ Head-Fier
Joined
May 26, 2015
Messages
600
Reaction score
458
Location
Germany - Deutschland
Joined
May 26, 2015
Location
Germany - Deutschland
Posts
600
Likes
458
You may try driving the cans with high current....sometimes it works for me (like sneezing) lol
Hmmmmm. I'll connect them to a much more powerful source at home. My LG V30 drives the Meze 99 or Sennheiser 660s to ear bleeding levels, the ERA-1 only to basically a normal listening volume. Let's see what happens...

EDIT: Connected them to my Xonar Asus STX at home, which can drive them to ear-bleeding level, still, the right channel only works sometimes..

Oh well. Might just be bad luck - I wish everyone who owns them a lot of fun for the coming years, and I hope that neither side will fail. :) I'll return them and be happy with my Sennheiser 660s, which sound phenomenal as well.
 
Last edited:
     Share This Post       
post-14978531
Post #516 of 856

iFi audio

Sponsor: iFi Audio
Joined
Mar 20, 2013
Messages
5,893
Reaction score
3,029
Location
Location: HQ in the UK, but spread far and wide.
Joined
Mar 20, 2013
Location
Location: HQ in the UK, but spread far and wide.
Posts
5,893
Likes
3,029
Website
ifi-audio.com
     Share This Post       
  • Like
Reactions: menuki
post-14983174
Post #517 of 856

Asahi Templar

100+ Head-Fier
Joined
Jul 19, 2017
Messages
251
Reaction score
189
Location
Osaka, Japan
Joined
Jul 19, 2017
Location
Osaka, Japan
Posts
251
Likes
189
Just got them an hour ago. Disappointed to say the least, as the right side is not working.

Gave the right side a few taps, now they played Music again on that side... but only for a few minutes, and, I shouldn't have to do that on a 700€ headphone.. The sound is really really good, but I'm afraid I'll have to return them since there seem to be some QC issues going on. Hope they get this resolved, because these have a lot of potential, but I will probably stay away from them for now. :/

EDIT: Even getting sad right now to be honest. :D I just tap them while listenting right now and they sound oh so good... it's confusing to me how something like this can happen. If I could be 100% sure that a replacement model wouldn't have this issue, I'd be in, but I can never know can I..

i had this same issue with a Brainwavz Alara I just tried. Right driver would randomly cut in and out, may be a common defect with the Yogada headphone they are both based on. I decided to exchange it and give another try, but these posts are worrying me about the Alara too!

Not had a chance to try the Quad ERA-1 yet sadly but that is worrying if many people are having that issue.
 
     Share This Post       
  • Like
Reactions: menuki
post-14983202
Post #518 of 856

menuki

500+ Head-Fier
Joined
May 26, 2015
Messages
600
Reaction score
458
Location
Germany - Deutschland
Joined
May 26, 2015
Location
Germany - Deutschland
Posts
600
Likes
458
i had this same issue with a Brainwavz Alara I just tried. Right driver would randomly cut in and out, may be a common defect with the Yogada headphone they are both based on. I decided to exchange it and give another try, but these posts are worrying me about the Alara too!

Not had a chance to try the Quad ERA-1 yet sadly but that is worrying if many people are having that issue.
Oh. No. Please. Not.. I've ordered the Alara's since the Quad has so many problems, in the hopes that the Brainwavz model does not have these problems.

Let's see.. you don't have the Alara's with you anymore, right? Cause if you do, what happens when you push the driver to your ears? The Quads just stopped producing sounds on both sides.. it was always just gentle pushs.. :/
 
     Share This Post       
post-14983283
Post #519 of 856

Asahi Templar

100+ Head-Fier
Joined
Jul 19, 2017
Messages
251
Reaction score
189
Location
Osaka, Japan
Joined
Jul 19, 2017
Location
Osaka, Japan
Posts
251
Likes
189
Oh. No. Please. Not.. I've ordered the Alara's since the Quad has so many problems, in the hopes that the Brainwavz model does not have these problems.

Let's see.. you don't have the Alara's with you anymore, right? Cause if you do, what happens when you push the driver to your ears? The Quads just stopped producing sounds on both sides.. it was always just gentle pushs.. :/

No I already sent them back and am awaiting my replacement. I never tried pushing them in at all. My left driver always worked without issues. I even walked around outside with them and it had no issues at all. Just the right one. I suspect it was the right earcups 3.5mm connector as moving around a lot or walking made it cut out a lot more often. Tried a different cable so it wasnt the cable.

Hopefully mine is a isolated case. At least it had the issue right out the box so it was easy to realize the defect. I am hoping mine is a rare case as I havent seen anyone else complaining about that issue with the Alara but these Quad posts having the same issue definitely worried me.

I think there are not too many Alara owners based on the few reviews and comments about them. Seems to be more Quad owners so more samples out there.
 
     Share This Post       
  • Like
Reactions: menuki
post-14983288
Post #520 of 856

menuki

500+ Head-Fier
Joined
May 26, 2015
Messages
600
Reaction score
458
Location
Germany - Deutschland
Joined
May 26, 2015
Location
Germany - Deutschland
Posts
600
Likes
458
No I already sent them back and am awaiting my replacement. I never tried pushing them in at all. My left driver always worked without issues. I even walked around outside with them and it had no issues at all. Just the right one. I suspect it was the right earcups 3.5mm connector as moving around a lot or walking made it cut out a lot more often. Tried a different cable so it wasnt the cable.

Hopefully mine is a isolated case. At least it had the issue right out the box so it was easy to realize the defect. I am hoping mine is a rare case as I havent seen anyone else complaining about that issue with the Alara but these Quad posts having the same issue definitely worried me.

I think there are not too many Alara owners based on the few reviews and comments about them. Seems to be more Quad owners so more samples out there.

Hmm. Yeah, lets see. I'll be waiting for them tomorow since they'll arrive that day. It's gonna be nice and sunny outside but I'll probably just wait for the delivery guy. :D Then I will gladly post if I experience any of the Quad issues with the Alaras. I really hope for you, me, and every other Alara owner that this was actually just a rare case. Cheers!
 
     Share This Post       
  • Like
Reactions: Asahi Templar
post-14985925
Post #521 of 856

iFi audio

Sponsor: iFi Audio
Joined
Mar 20, 2013
Messages
5,893
Reaction score
3,029
Location
Location: HQ in the UK, but spread far and wide.
Joined
Mar 20, 2013
Location
Location: HQ in the UK, but spread far and wide.
Posts
5,893
Likes
3,029
Website
ifi-audio.com
Hmm. Yeah, lets see. I'll be waiting for them tomorow since they'll arrive that day. It's gonna be nice and sunny outside but I'll probably just wait for the delivery guy. :D Then I will gladly post if I experience any of the Quad issues with the Alaras. I really hope for you, me, and every other Alara owner that this was actually just a rare case. Cheers!
Do let us know about your findings once your package arrives, thanks!
 
     Share This Post       
post-14986732
Post #522 of 856

menuki

500+ Head-Fier
Joined
May 26, 2015
Messages
600
Reaction score
458
Location
Germany - Deutschland
Joined
May 26, 2015
Location
Germany - Deutschland
Posts
600
Likes
458
Received the Alaras yesterday.. instant love, really. Bass is as thick, dense, detailed and fast as expected and wished for. The soundstage is kind of house-like, picking up details is so easy and it's not too narrow for me at all. Since I'm gonna use them to make Music as well, it's pretty much perfect.

Without straying too off topic, the point is, these have NONE of the issues which the Quads I own have.. I can push the drivers closer to my ears as hard as I like and the sound doesn't cut off at all. Both channels work properly and matching is great. The Quads will now be going back. Already packaged up and I won't look back. I really hope they get to resolve the QC issues - I kind of feel sorry for Quads, there must've been something going wrong badly. To anyone who has a fully working unit though, enjoy! Both the Alara and Quads (if they work) are spectacular headphones! I have to add that I actually prefer the Alaras over the Quads since the Bass response is just so fantastic. Directly compared it feels the Quads could use a lil Bass boost via EQ, but YMMV of course! Just my opinion as I always wanted to have that really nice planar magnetic Bass which hits well, the Quads may even be a touch more refined in that area though. :)
 
Last edited:
     Share This Post       
  • Like
Reactions: trellus
post-15024036
Post #525 of 856

babyoh

100+ Head-Fier
Joined
Feb 23, 2005
Messages
343
Reaction score
21
Joined
Feb 23, 2005
Posts
343
Likes
21
I read the ERA-1's sonic signature is modeled after the ESL-57 electrostatic speakers. Should I even bother with ERA-1 if I already own the Baby O?
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 1, Guests: 6)

Top