1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Problems with Wadia 27

Discussion in 'Dedicated Source Components' started by jarmel, Aug 6, 2009.
  1. Jarmel
    So I just got my Wadia back from the mod shop and I'm getting no audio. The guy is on vacation till August 16th and I have no clue what to do. I tried isolating the problem to see if it could be the cables but nope. His website claims that each unit goes through rigorous testing so I don't know what happened or if I'm missing something. Are Wadia's known to be complicated to set up or does it need to burn in before sound starts coming out? Am I supposed to have a special configuration?
     
  2. Covenant Contributor
    Quote:

    Originally Posted by Jarmel /img/forum/go_quote.gif
    So I just got my Wadia back from the mod shop and I'm getting no audio. The guy is on vacation till August 16th and I have no clue what to do.



    Ack, you had your Wadia modded and now its not working, and the guy who did the mod for you is "on vacation"?

    I'd be very angry to say the least. Do you mind disclosing who the modder was?
     
  3. Jarmel
    I knew he was going to be on vacation before it shipped so I'm not really mad at him per say, it's just a major incovenience if its not working. Again I'll hold off on citing names and stuff until I'm sure its not my own fault or something. I just ordered a XLR to RCA cable to test to see if both of the outputs are caput. If the outputs aren't working then there is a problem in the DAC while it might just be the RCA outputs.
     
  4. Jarmel
    Ok did some tests, the Wadia is accepting an input but I'm not getting an output. Even sometimes when I would get a signal by pure luck after around 2 minutes, it would just randomly cut off and I can't get it back. Anyone know how to take apart a Wadia?
     
  5. mrarroyo Contributor
    I would not do it, instead I would wait until the "guy" is back and fixes it. I would make sure to tell him how disappointed I was w/ his performance. Hopefully he will refund you some of the money.
     
  6. Jarmel
    Already opened the top, and I think I already know the problem. I hear a click and the audio comes on and randomly after two minutes or so, another click and the audio goes off.
     
  7. scootermafia
    Do you see anything amiss under the hood? What kind of morons don't test a heavily modded DAC after doing $3000+ worth of work on it.
     
  8. Jarmel
    Everything looks fine except for that clicking sound
     

Share This Page