Porta Corda distortion
post-177185
Thread Starter
Post #1 of 4

balcar

Head-Fier
Joined
Aug 5, 2002
Messages
70
Reaction score
0
Joined
Aug 5, 2002
Posts
70
Likes
0
I just purchased a Porta Corda amp from another Head-Fi'er, in "new in the box" condition. It has some sort of distortion, a warble-like effect, at normal and higher volumes. I've checked it with several different CDs and different headphones, including Ety ER-4S. This happens with crossfeed processor in or out.

I've compared it to a TAH I own, and the difference is significant. The TAH outputs crystal-clear sound.

I've searched the forums about this, and read that others have experienced this as well. I wonder if it's a defect in some units? I noticed that there were suggestions to increase the power to 18 volts, but (1) I can't figure out how to do this, and (2) I want to retain the small self-contained size of the amp.

Any suggestions?

Thanks,

balcar
 
     Share This Post       
post-177199
Post #2 of 4

puppyslugg

Headphoneus Supremus
Joined
Jan 31, 2002
Messages
1,642
Reaction score
10
Joined
Jan 31, 2002
Posts
1,642
Likes
10
Try emailing Jan Meier. If it is a 'defect', I'm sure Jan would be aware of it. He is a nice person and very helpful.
 
     Share This Post       
post-177201
Post #3 of 4

balcar

Head-Fier
Joined
Aug 5, 2002
Messages
70
Reaction score
0
Joined
Aug 5, 2002
Posts
70
Likes
0
puppyslug wrote
Quote:

He is a nice person and very helpful.


I have read here that what you say is quite true. I did email him. Thanks.
 
     Share This Post       
post-177389
Post #4 of 4

taoster

Headphoneus Supremus
Joined
Dec 12, 2001
Messages
1,868
Reaction score
10
Joined
Dec 12, 2001
Posts
1,868
Likes
10
The Porta Corda starts clipping badly when battery is low.. its very noticable.. try recharging the old batteries and trying again?
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top