Popping from m50x with multiple devices. Need help.
post-14520699
Thread Starter
Post #1 of 2

amithjc

New Head-Fier
Joined
Mar 21, 2015
Messages
5
Reaction score
10
Joined
Mar 21, 2015
Posts
5
Likes
10
Edit: I have heard it with multiple songs. I don't hear the same with my other IEMs. I did try higher quality sources.

Could someone who own an ATH m50x, listen to the linked song from 9:17 for a few seconds and report back? I hear a popping/cracking sound which either stops or gets drowned by the instruments after the initial few seconds. I'm not sure if it's static sound but I encountered this with every device I own(None of which has a high end DAC but I've read on various threads that the m50x can be decently driven by most smartphones.). I can somewhat control it if I EQ down at around 8k. Please keep the EQ flat while testing. I know I'm asking for too much. I'm from India and Audio Technica doesn't have a service center here. While they do provide 1 year warranty I have been told it can be a lengthy process. I need to make sure if they are defective before I RMA.
 
Last edited:
     Share This Post       
post-14520956
Post #2 of 2

armink

Head-Fier
Joined
Jul 24, 2018
Messages
53
Reaction score
12
Location
United States
Joined
Jul 24, 2018
Location
United States
Posts
53
Likes
12
hear a popping/cracking sound which either stops or gets drowned by the instruments after the initial few seconds. I'm not sure if it's static sound but I encountered this with every device I own(None of which has a high end DAC but I've read on various threads that the m50x can be decently driven by most smartphones.)
Don't worry I hear it with my M40x's. It is definitely the source and not youe headphones.
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top