Popping between songs when using ASIO or Kernel Streaming
Aug 2, 2008 at 9:17 PM Thread Starter Post #1 of 5

crispyambulance

New Head-Fier
Joined
Jun 5, 2008
Posts
20
Likes
0
I set up Kernel Streaming on Winamp some time ago to output through an analogue connexion, and it struck me as sounding a little better, but between songs, and just when my music player segues from noise to complete silence, there is one distinct pop to mark the transition to silence and one distinct pop to mark the inverse. I've just been living with this for the last month or two, as it did sound better, but it--well, I just want to know if there is any way to get it to stop. I googled extensively and found nothing, and I ended up toying with pretty much every setting in my Kernel Streaming plug-in, and then I even installed ASIO4ALL, which behaves identically. I fear that this might be an innate quality of bypassing KMixer, so some confirmation would at least save me some time searching for a solution.

I'm using an AV-710 sound card going directly to my headphones right now. This might sound strange, but I was wondering if getting a DAC and using digital out would maybe solve this, too? I ordered an amplifier a few days ago with the intention of picking up an external DAC eventually, and if this is the case it would probably speed up my plans considerably.

If anyone wants my settings for ASIO or Kernel Streaming (I don't care which one I end up using) or any other technical specifications, I'll be happy to oblige. And thanks for any help, muchly.
 
Aug 3, 2008 at 6:36 AM Post #2 of 5

jiiteepee

Headphoneus Supremus
Joined
Apr 5, 2005
Posts
1,579
Likes
53
Quote:

Originally Posted by crispyambulance /img/forum/go_quote.gif
I set up Kernel Streaming on Winamp some time ago to output through an analogue connexion, and it struck me as sounding a little better, but between songs, and just when my music player segues from noise to complete silence, there is one distinct pop to mark the transition to silence and one distinct pop to mark the inverse. I've just been living with this for the last month or two, as it did sound better, but it--well, I just want to know if there is any way to get it to stop. I googled extensively and found nothing, and I ended up toying with pretty much every setting in my Kernel Streaming plug-in, and then I even installed ASIO4ALL, which behaves identically. I fear that this might be an innate quality of bypassing KMixer, so some confirmation would at least save me some time searching for a solution.

I'm using an AV-710 sound card going directly to my headphones right now. This might sound strange, but I was wondering if getting a DAC and using digital out would maybe solve this, too? I ordered an amplifier a few days ago with the intention of picking up an external DAC eventually, and if this is the case it would probably speed up my plans considerably.

If anyone wants my settings for ASIO or Kernel Streaming (I don't care which one I end up using) or any other technical specifications, I'll be happy to oblige. And thanks for any help, muchly.



Have you checked if there really is a spike in the beginning and the end of those source files giving pops? You could try by trimming (fade) a bit the begin and end of those files (normally, a recording software fades in/out a bit as default (picture showing Reaper options):





Maybe DC-offset issue is involved as it may give symptoms like popping? Harmony Central - DC Offset: The Case of the Missing Headroom

jiitee
 
Aug 3, 2008 at 3:22 PM Post #3 of 5

crispyambulance

New Head-Fier
Joined
Jun 5, 2008
Posts
20
Likes
0
OK, reading around, I'm pretty sure you're right with the pop's being a part of the file. That page you linked recommended using, um, some sort of automatic fade in and out to drown out the pop, but looking through Google, there's only really information on how to do this with Winamp's Directsound plug-in from what I can tell. How would I do this on one of the other plug-ins in Winamp? I can't find anything in the setting for either, so might this call for my using Foobar or something?

Thanks for your help.
 
Aug 3, 2008 at 3:58 PM Post #4 of 5

jiiteepee

Headphoneus Supremus
Joined
Apr 5, 2005
Posts
1,579
Likes
53
Yes, it looks like there's no fade option available on Winamp w/ ASIO nor KS output plug-in ... could there be a separate fade (cross-fade) plug-in available? Best would be to use an audio-editor but, that's a lot of work if there are lots of files to edit.

If you don't like the DirectSound device driver then, you could try if the 'realtime' fading improves anything by trying the (freeware) NI TRAKTOR player (ASIO capable) listed in my sig. You can adjust the auto-cross-fade option down to under 1 ms (nearly gapless playback). Another ASIO capable player w/ fading feature would be J. River's Media JukeBox (also freeware)
player.

jiitee
 

Users who are viewing this thread

Top