O2+Odac issues
Jul 13, 2015 at 10:00 PM Thread Starter Post #1 of 1


New Head-Fier
Nov 17, 2013
I just got my O2+Odac last week, and it worked out of the box, but over the last few days it hasn't been working right. The first time it happened I was trying to make a skype call and heard nothing. Turned out that it wasn't just in Skype, it was everywhere, no internet sounds, system sounds, nothing. I tried to fiddle with the windows volume control in the task bar and it froze and jumped around, it was all glitchy and screwed up.
I wondered if maybe I had too many USB devices in at once, since the problem started when I added a blue snowball mic into the mix. Yanked it and everything worked fine, so I blamed the mic, or a USB conflict of some sort. Today it's happened again. I had a skype call, hung up, when for a run, came back and the O2 is messed up again. Same thing as before, volume slider in windows task bar is stuck and glitching out, Foobar freezes up and throws the error Unrecoverable playback error: Incorrect function.   (0x80070001).
This is really disappointing, people always say that the benefit of a standalone dac is that you don't have to fiddle with drivers, but so far the O2 is more finicky than my Xonar DG. It seems like it only happens when I'm making skype calls, but I haven't had it happen often enough to be certain of that.
If anyone knows why this happens, or knows of a solution, please let me know.

Users who are viewing this thread