Noble Audio - the Wizard returns!
Oct 9, 2018 at 10:27 PM Post #28,309 of 33,583

Watagump

Twizzler King
Joined
Dec 29, 2011
Posts
7,641
Likes
1,835
Location
Orange County CA
Well, dammit, I got my K10's back today after being on the road again for a while. That is suppose to make a good day even better, BUT, I head out for my bike ride, I get about 10 minutes in and realize the sound just isnt right. The balance is off, more sound in my left ear, normally this is an issue of a bore being clogged. But since I didnt even have them for over a month, how could that be it? Well, that was it, I didnt even have my glasses on so it was hard to see but I found some what was probably ear wax in the smallest bore.

I stopped in a place where there just so happened to be a used toothpick in the crack of the sidewalk, yup that will work. :fingers_crossed:I stick it in, notice the hole is open again and audio bliss was restored. 30 minutes later, I run over a sheet metal screw and have to swap my tube out. Same area I ran over the exact type of screw months ago, anyhow, made it home, cleaned the bores again with a better sharper end, some day I might just get a jodivac.
 
Oct 9, 2018 at 10:42 PM Post #28,310 of 33,583

FullCircle

The Wizard
Sponsor: Noble Audio
Joined
Jul 11, 2008
Posts
6,274
Likes
4,435
I had to use a 100 Taiwan dollar bill and a wad of fresh bubble gum to fix a flat once

I was out in the middle of nowhere, luckily the patch worked well enough to get me out of the mountains and back to civilization.


Screenshot_20181010-093842_Google.jpg

Screenshot_20181010-094142_Google.jpg
 
Noble Audio Stay updated on Noble Audio at their sponsor profile on Head-Fi.
 
https://www.facebook.com/NobleAudio https://www.twitter.com/noblebywizard https://www.instagram.com/nobleaudio https://nobleaudio.com/en/ contact@nobleaudio.com
Oct 10, 2018 at 9:46 AM Post #28,313 of 33,583

Redcarmoose

Headphoneus Supremus
Joined
Dec 11, 2008
Posts
22,533
Likes
20,078
Location
.
B76072BF-29B1-4D2D-B182-4D9C70C4942B.jpeg


The fastest I ever went downhill was 46mph. What’s startling was the difference the wind noise is from the spokes from 40mph to 46mph?

In a way I reference my Encore and old Colnago the same way.....simply...art.
 

Attachments

  • 8E3DBE59-208F-4DDC-96E4-BC502CE6F62E.jpeg
    8E3DBE59-208F-4DDC-96E4-BC502CE6F62E.jpeg
    43.4 KB · Views: 0
Last edited:
Oct 10, 2018 at 10:02 AM Post #28,314 of 33,583

Redcarmoose

Headphoneus Supremus
Joined
Dec 11, 2008
Posts
22,533
Likes
20,078
Location
.
A4AC2DC6-98C1-45C4-9439-E6EFDFD9EFFE.jpeg
Ibasso IT04 universal iem looks like almost a custom.
Fit a lot better than my Encore.
Encore needs to keep adjusting every 30 min or an hour.
Once IT04 plugged in then rarely needs adjusting.
I think iBasso company is putting more effort into it. Noble needs to do more than that.

I have tried the IT04, what your saying is you would like a motorcycle with a 454 Chevy engine. It’s simply not physically possible. The Encore does more because it has more. One trick about fitting is to understand what changes you have to make to get your Encore to fit right. If your like me the nozzle was ever so slightly too short. I found a set of SpinFit tips which were exceptionaly long. Then I took an old IEM tip and cut the inner rubber shaft into a small O ring. It’s a super small ring that I put on before placing the SpinFit tip on. Now I have increased the nozzle area creating a perfect fit. It’s been a couple months and all is well.

I actually have some semi-custom chi-fi IEMs like the IT04 and yes, they are comfortable because they are small and fit inside against the ear, still there is no comparison when it gets to overall sound.
 
Last edited:
Oct 10, 2018 at 12:54 PM Post #28,315 of 33,583

krismusic

Headphoneus Supremus
Joined
May 10, 2009
Posts
4,342
Likes
710
Location
London
Well, dammit, I got my K10's back today after being on the road again for a while. That is suppose to make a good day even better, BUT, I head out for my bike ride, I get about 10 minutes in and realize the sound just isnt right. The balance is off, more sound in my left ear, normally this is an issue of a bore being clogged. But since I didnt even have them for over a month, how could that be it? Well, that was it, I didnt even have my glasses on so it was hard to see but I found some what was probably ear wax in the smallest bore.

I stopped in a place where there just so happened to be a used toothpick in the crack of the sidewalk, yup that will work. :fingers_crossed:I stick it in, notice the hole is open again and audio bliss was restored. 30 minutes later, I run over a sheet metal screw and have to swap my tube out. Same area I ran over the exact type of screw months ago, anyhow, made it home, cleaned the bores again with a better sharper end, some day I might just get a jodivac.
I was going to buy a Jodivac. I think it was John warned me off. Danger of dislodging the dampers.
 
Oct 10, 2018 at 3:55 PM Post #28,319 of 33,583

proedros

Headphoneus Supremus
Joined
Aug 24, 2010
Posts
7,822
Likes
6,198
Location
Athens , Greece
I was going to buy a Jodivac. I think it was John warned me off. Danger of dislodging the dampers.

is this about customs or universal shells (or bth) ?

do we have any more on the matter ? has this happened to anyone ? really curious about it as many people here own jodivac
 

Users who are viewing this thread

Top