New DT990s clicking on heavy bass songs?
May 16, 2015 at 8:32 PM Thread Starter Post #1 of 21

sardonicus

New Head-Fier
Joined
May 16, 2015
Posts
23
Likes
10
I'm fairly new to this, but I just spent what I consider to be irresponsible amounts of money on a DAC, an amp and these cans. Right off the bat I was frightened but how terribly, brain-bleedingly bright these headphones are, but I rectified that by ordering the HD650s and taking the 6k and 12k equalizer things down a notch, and now I'm having a blast with these DT990s!
 
But upon listening to Charlotte Gainsbourg's bass happy cover of Hey Joe on high volume, I hear clicking noises! Is that just the phones hitting their bass limit? Is this maybe something that should be solved once they're broken in? Can another owner of this pair check this song out to see if they get clicks?
 
Thanks!
 
May 17, 2015 at 12:53 AM Post #2 of 21

PurpleAngel

Headphoneus Supremus
Joined
Sep 1, 2011
Posts
29,140
Likes
1,852
Location
California
What sources and what DAC and what amplifier are you using with the headphones?
Any chance the HD650 are showing imperfections in the music audio file(s)?
 
May 17, 2015 at 4:11 AM Post #3 of 21

sardonicus

New Head-Fier
Joined
May 16, 2015
Posts
23
Likes
10
I'm using a LIttle Dot DAC_I with a Little Dot MKII tube amp. The source is lossless and official, and I don't think is to blame. The clicks are quite loud and mechanical sounding, and don't show up gradually when slowly turning up the volume, but rather appear suddenly when a certain volume threshold is passed.
 
The HD650 have not arrived yet.
 
Are you really not able to reproduce those clicks with that song and your own DT990s at any volume? Mine is the "Premium" edition, but it shouldn't matter, right? I have the 250 ohm version too.
 
Thanks!
 
May 17, 2015 at 4:56 AM Post #4 of 21

PurpleAngel

Headphoneus Supremus
Joined
Sep 1, 2011
Posts
29,140
Likes
1,852
Location
California
  I'm using a LIttle Dot DAC_I with a Little Dot MKII tube amp. The source is lossless and official, and I don't think is to blame. The clicks are quite loud and mechanical sounding, and don't show up gradually when slowly turning up the volume, but rather appear suddenly when a certain volume threshold is passed.
 
The HD650 have not arrived yet.
 
Are you really not able to reproduce those clicks with that song and your own DT990s at any volume? Mine is the "Premium" edition, but it shouldn't matter, right? I have the 250 ohm version too.
 
Thanks!

 
I own both the DT990 600-Ohm and 250-Ohm, never heard clicks.
But as they are currently buried in a storage locker, can't double check them.
 
May 17, 2015 at 6:52 AM Post #5 of 21

Shaffer

Headphoneus Supremus
Joined
Sep 7, 2013
Posts
2,740
Likes
272
[...]

Are you really not able to reproduce those clicks with that song and your own DT990s at any volume? Mine is the "Premium" edition, but it shouldn't matter, right? I have the 250 ohm version too.

Thanks!


I own DT990/250. No clicking at any volume. I'm actually wearing them right now playing a bass-heavy album.
 
May 17, 2015 at 7:43 AM Post #7 of 21

Shaffer

Headphoneus Supremus
Joined
Sep 7, 2013
Posts
2,740
Likes
272
Even that specific Hey Joe cover? I'm not sure what you're talking about. Because that's about the only one I've had clicking with yet, its bass is literally making my ears wiggle. If it's only on one track, why worry about it? Are you amplifying it hard enough? Yes. My gear is listed in my profile :rolleyes:


...in bold.

What are you using for source material, DAC, and amp?
 
May 17, 2015 at 11:19 AM Post #10 of 21

PurpleAngel

Headphoneus Supremus
Joined
Sep 1, 2011
Posts
29,140
Likes
1,852
Location
California
  Even that specific Hey Joe cover? Because that's about the only one I've had clicking with yet, its bass is literally making my ears wiggle. Are you amplifying it hard enough?

 
So you only have one song with the clicking?
But not with other songs?
So it might be you have one faulty recorded song?
 
May 17, 2015 at 11:22 AM Post #11 of 21

sardonicus

New Head-Fier
Joined
May 16, 2015
Posts
23
Likes
10
   
So you only have one song with the clicking?
But not with other songs?
So it might be you have one faulty recorded song?


The headphones are very new, so I've yet to have the chance to listen to a whole lot of songs you see. I don't believe there is a problem with the track itself, so I'm wondering if my DT990s are behaving normally and whether maybe there's something wrong with them.
 
May 17, 2015 at 11:32 AM Post #12 of 21

PurpleAngel

Headphoneus Supremus
Joined
Sep 1, 2011
Posts
29,140
Likes
1,852
Location
California
 
The headphones are very new, so I've yet to have the chance to listen to a whole lot of songs you see. I don't believe there is a problem with the track itself, so I'm wondering if my DT990s are behaving normally and whether maybe there's something wrong with them.

Your only having clicking issues with one song.
How about try listening to a bunch of other songs, see if there is clicking.
 
May 18, 2015 at 1:15 PM Post #13 of 21

JuanseAmador

1000+ Head-Fier
Joined
May 26, 2012
Posts
1,206
Likes
76
 

So you only have one song with the clicking?
But not with other songs?
So it might be you have one faulty recorded song?



The headphones are very new, so I've yet to have the chance to listen to a whole lot of songs you see. I don't believe there is a problem with the track itself, so I'm wondering if my DT990s are behaving normally and whether maybe there's something wrong with them.


Is your song a rip of yours?
 
May 18, 2015 at 1:44 PM Post #14 of 21

sardonicus

New Head-Fier
Joined
May 16, 2015
Posts
23
Likes
10
Is your song a rip of yours?

Nope, it is an official lossless digital release bought online. I'm getting the very same problem with the YouTube version of this track. The clicks are not in the track itself, guys, they're clearly the headphones messing up past a certain volume. Maybe that's normal, but I was hoping someone could test it out with their own pair. Again, the song in question is linked in the original post.
 
Thanks!
 
May 18, 2015 at 1:58 PM Post #15 of 21

Shaffer

Headphoneus Supremus
Joined
Sep 7, 2013
Posts
2,740
Likes
272
Nope, it is an official lossless digital release bought online. I'm getting the very same problem with the YouTube version of this track. The clicks are not in the track itself, guys, they're clearly the headphones messing up past a certain volume. Maybe that's normal, but I was hoping someone could test it out with their own pair. Again, the song in question is linked in the original post.

Thanks!


I listened to the Youtube track with my 990s and a uDAC2. No clicking. The song is very heavily compressed. How loud are you playing it?
 

Users who are viewing this thread

Top