My SlimX died!
post-151396
Thread Starter
Post #1 of 5

bubbaj

100+ Head-Fier
Joined
Mar 29, 2002
Messages
121
Reaction score
0
Joined
Mar 29, 2002
Posts
121
Likes
0
I am so bummed out. It was working fine and then the left channel went dead. Only from the jack on the remote. Plugging into the main unit still works. I called iRiver and they were very nice. They say that they will have a distributor contact me with return information and I will be sent a replacement unit. They also said that it was a common problem. I hope the new one doesn't do it too.
bj
 
     Share This Post       
post-151411
Post #2 of 5

Ken

100+ Head-Fier
Joined
Nov 27, 2001
Messages
414
Reaction score
0
Joined
Nov 27, 2001
Posts
414
Likes
0
what can you do
put it in for repair
 
     Share This Post       
post-151435
Post #3 of 5

acs236

Headphoneus Supremus
Joined
May 24, 2002
Messages
3,308
Reaction score
25
Joined
May 24, 2002
Posts
3,308
Likes
25
You mean you can plug into the the main unit and the headphone out works fine? Why don't they just send you another remote? They sell them for $30 on the website, why would they bother repairing?
 
     Share This Post       
post-151441
Post #4 of 5

andrzejpw

May one day invent Bose-cancelling headphones.
Joined
Jun 25, 2001
Messages
6,636
Reaction score
10
Joined
Jun 25, 2001
Posts
6,636
Likes
10
Meh, my sony remote became very scratchy once on my E900. I called sony, and they sent me a new one!
 
     Share This Post       
post-151500
Post #5 of 5

Duncan

Headphoneus Supremus
Moderator
Joined
Jun 26, 2001
Messages
13,161
Reaction score
1,250
Joined
Jun 26, 2001
Posts
13,161
Likes
1,250
Quote:

Originally posted by andrzejpw
Meh, my sony remote became very scratchy once on my E900. I called sony, and they sent me a new one!


Are we talking CD or MD for the E900 andrzejpw?

and, I agree ~ if the remotes are sold seperately, just get them to do a swap out on the remote only
 
     Share This Post       
Top