My CreAtive X-Fi Titanium Fatality Champion Series sound card produces a deafening high-pitched sound with headphones. Help?
Jun 23, 2012 at 1:02 AM Thread Starter Post #1 of 7

TyTB

Head-Fier
Joined
Jun 17, 2012
Posts
70
Likes
10
Hey all,
 
For Christmas, I got the Creative X-Fi Titanium Fatality Champion series sound blaster for my computer: http://us.store.creative.com/Creative-Sound-Blaster-XFi-Titanium-Fatal1ty/M/B001BDPLJA.htm
 
While the speaker sound quality has increased, headphones are basically un-usable. Whenever the volume is turned up very high on the speakers, even if no music is playing, and whenever I'm listening through headphones, regardless of the volume, there is a audible high-pitched squeal that sounds almost exactly like someone doing electronic morse code from the cold war. It just Beep be-beep beep beeeeeep beeeeeep beep beep etc... I can't stand wearing the headphones because my ears end up ringing after only a few minutes if there's no loud music playing through the phones. 
 
I'm wondering if anyone here knows why this is happening and can help. 
 
Any advice is welcome, thank you for your time.
 
Jun 23, 2012 at 4:28 AM Post #2 of 7

stv014

Headphoneus Supremus
Joined
Jul 17, 2011
Posts
3,493
Likes
271
This sounds like an interference or ground loop problem. Are you using the front panel headphone jack on your computer ? What happens if you disconnect the speakers, and try the headphones directly from the card (not using the front panel) ?
 
Jun 23, 2012 at 3:16 PM Post #3 of 7

TyTB

Head-Fier
Joined
Jun 17, 2012
Posts
70
Likes
10
Quote:
This sounds like an interference or ground loop problem. Are you using the front panel headphone jack on your computer ? What happens if you disconnect the speakers, and try the headphones directly from the card (not using the front panel) ?

I tried a few times, and it seems that the hissing disappears when i attach them directly to the sound card. I've also noticed that I can hear whenever the computer does something. Like i can actually HEAR the sound of the mouse wheel scrolling. And I know it's not the real-life sound that im hearing, because it increases when i turn the volume up. So what's causing this? Electromagnetic interferance? 
 
Jun 23, 2012 at 5:38 PM Post #4 of 7

PurpleAngel

Headphoneus Supremus
Joined
Sep 1, 2011
Posts
29,249
Likes
1,893
Location
California
Quote:
Hey all,
 
For Christmas, I got the Creative X-Fi Titanium Fatality Champion series sound blaster for my computer: http://us.store.creative.com/Creative-Sound-Blaster-XFi-Titanium-Fatal1ty/M/B001BDPLJA.htm
 
While the speaker sound quality has increased, headphones are basically un-usable. Whenever the volume is turned up very high on the speakers, even if no music is playing, and whenever I'm listening through headphones, regardless of the volume, there is a audible high-pitched squeal that sounds almost exactly like someone doing electronic morse code from the cold war. It just Beep be-beep beep beeeeeep beeeeeep beep beep etc... I can't stand wearing the headphones because my ears end up ringing after only a few minutes if there's no loud music playing through the phones. 
 
I'm wondering if anyone here knows why this is happening and can help. 
 
Any advice is welcome, thank you for your time.

Not sure if this helps.(but usually a good idea anyway).
Have you turned of on-board sound the in bios?
Delete on-board sound software?
 

Users who are viewing this thread

Top