More isolation in one side?!
May 14, 2012 at 1:33 AM Thread Starter Post #1 of 2

afinch1992

100+ Head-Fier
Joined
Dec 21, 2010
Posts
417
Likes
14
Ive had my PRO 900s for a few days now and noticed something kind of strange and dont know how to explain it. The right earcup seems to have more isolation. I have no idea how or why. I bought them from another user that actually just bought them but didnt like the bass and treble. Has anyone else ever found this? I switched ears to make sure I wasnt going crazy and the exact same phenomina was present in the same cup. Its not a cable or source issue either. It is still there even when not connected to a thing. I even went so far as to unplug the cable from the headphones. still there. The sound from both sides seems right, but it sounds a little off when listening to both. anyone have any thoughts on how to explain this or fix it?
 
May 15, 2012 at 1:23 AM Post #2 of 2

afinch1992

100+ Head-Fier
Joined
Dec 21, 2010
Posts
417
Likes
14
well i solved the problem! while investigating whether something was blocking the driver I placed the earpads back on and everything was fixed! I unknowingly had turned them back to what i assume is the right position. One of the earpads was just off. I have never experienced anything like this before and never would have guessed it as i assumed there was no difference how the earpads were on a circular based design. Anyways if anyone else comes into a weird situation as i did, maybe this will help. 
 

Users who are viewing this thread

Top