Matrix Audio X-Sabre Pro

Discussion in 'Dedicated Source Components' started by mtoc, Nov 11, 2016.
First
 
Back
2 3 4 5 6 7 8 9 10 11
13 14
Next
 
Last
  1. JeffMann
    I decided to update my firmware yesterday and the experience was very problematic, and very frustrating.

    I first dowloaded the RAR file, which I unzipped with WinZip - see attached jpg showing the extracted contents contained in that RAR file.

    I then went into upgrade mode without any problem using a paper clip.

    I then used the update tool to connect to the device. However, when I looked in the folder (icon 1) there was only one subfolder called "platforms" which contained a few hex files related to an OPPO and a PWT device. I couldn't locate the 1.82 hex file. I finally found the 1.82 file in my downloads and when I clicked on it, it loaded as shown in figure 5.

    I then clicked on the start button (middle icon) and it initiated the erase, program and verify sequence, but it ended up with a message stating that the device failed to verify (instead of stating "Verify Complete" as seen in image 6). I then repeated the process by again clicking on the start button, but it still gave a "Verify Failed" message. I didn't know what to do at that point, so I decided to click on the 3rd icon to start the device - even though device verification failed. The screen then displayed a message stating that the device was disconnected. I presumed that it self-aborted the upgrade process and I expected the device not to start. However, when I started the device (Matrix Sabre-X Pro DAC), it worked and played music and the firmware read 1.82. I didn't truly know if the firmware update was really completed succesfully, so I decided to start the whole update process again from the beginning - even though firmware 1:82 was now apparently loaded into my device. This time the update process worked perfectly, and the device was successfully verified and reset (as shown in images 6 and 7).

    I then decided to update the XMOS to version 6.6.

    I started off by unplugging the power to my device and then connecting my laptop to the device with an USB cable. I then entered standby mode by plugging the power cable plug back into the device. When I was in standby mode (not upgrade mode), I was then stuck and I didn't know how to proceed. Instruction 1 stated that I should double-click "Matrix-Audio DFU" in the driver root directory. However, I didn't know how to find the driver root directory. It then stated that I should open the driver installation package to find the upgrade program tool, but I couldn't locate that package or the upgrade program tool.

    How do I solve this "update XMOS" problem?

    Jeff.
     
    Last edited: Sep 30, 2017
  2. JeffMann
    Matrix RAR file contents. I have re-attached the jpg to this post because I cannot see it my previous message.

    However, I still cannot see it attached to this post.

    Why?

    Anyway, here is a link to that jpg - http://perfectgolfswingreview.net/MatrixUpdate.JPG

    Jeff.
     
    Last edited: Sep 30, 2017
  3. JeffMann
    I solved the problem of updating the XMOS chip.

    My audio system is entirely CD-based and I have never used a computer as a musical streaming device. I therefore didn't have the Matrix drivers for Windows in my laptop. I went to the Matrix website and downloaded the driver package. It contained a program to install the old firmware version (version 4.12) in my laptop and also the Matrix DFU loader program for updating the firmware. I initially thought that I didn't need to first load the old firmware version into my laptop before I used the DFU loader program to update to version 6.6, but I was wrong. The DFU loader program couldn't communicate with my device because of a missing DLL file. I therefore first had to install the old firmware version into my laptop in order to get the DFU loader to be able to communicate with my device. After that, it was very easy to update to firmware version 6.6.

    I think that Matrix did a poor job of explaining the update process and they presumed that all users would already have pre-loaded the driver package.

    Jeff.
     
    Last edited: Oct 1, 2017
  4. Barbapappa
    Thanks for the info on the firmware update. Just successfully updated my x-sabre pro (from 1.3 which was what it orginally came with).
     
  5. MINORISUKE
    The Windows driver 4.12 is the latest. What you had done was upgrading the firmware for XMOS and has nothing to do with the Windows driver.
     
  6. ArthurPower
    JeffMann I wish you would have contacted us through the Matrix website, I would have gladly walked you through the process on the phone.

    I'm glad to hear you successful completed both updates. Some computer knowledge is required to perform the upgrade. The tools for these upgrades are provided by the chip manufacturers. It's unfortunately not always an intuitive process.

    With that said we have not had any customers who were unsuccessful or who experienced any failed updates.
     
  7. ArthurPower
    There's no need to install the old firmware however the latest driver should be installed to allow proper communication with the device.
     
  8. JeffMann
    I agree. However, I needed to install the driver package into my laptop in order to allow the DFU Loader program to update the firmware for XMOS. The DFU loader program couldn't connect to my device without the necessary dll file that is apparently part of the driver package.

    Jeff.
     
  9. purk Contributor
    @JeffMann ,

    Thanks for accounting on installation of the older driver. I went thru the same trouble. Upgrading the firmware is straight forward but the XMOS updating instruction could have been better.
     
  10. bclark8923
    Can anyone recommend an interface to use this dac w/ the I2S input from PC/USB? Either a PC card or a DDC
     
  11. DarKu
    How about the newest X-SPDIF2 from Matrix, I was told it will further improve the performance. I might get one soon.
     
    bclark8923 likes this.
  12. bclark8923
    Nice! Any idea what would be something for an external LPS for it? something hopefully 150 or less
     
  13. MINORISUKE
    I use SU-1 simply because I own it before my purchase of X-Sabre Pro.
    The difference between SU-1 and X SPDIF 2 is:
    (1) SU-1 with better clock Crystek CCHD-575
    (2) SU-1 compatible with more models such as Gustard, Holo, especially those DACs that require DC5V on No.18 and DSDOE (DSD/PCM toggle)
    (3) SU-1 with built-in AC power transformer
    (4) X SPDIF 2 with a driver that has latency settings as of today
     
  14. DarKu
    X-SPDIF2 also uses excellent clocks - Accusilicon AS318-B, according to specs those are about on the same level as with with CCHD-575.
    Internal clocks of X-Sabre PRO are also great already, don't be mistaken: one Crystek CCHD-957 and two Crystek CCHD-950.
    SU-1 (F1 version) is also more expensive than X-SPDIF2, I don't know but I am temped more by X-SPDIF2
     
    Last edited: Oct 11, 2017
  15. LoryWiv
    I am also using Singxer SU-1 with my X-Sabre Pro, very pleased with results.
     
    Last edited: Feb 25, 2018 at 3:21 PM
First
 
Back
2 3 4 5 6 7 8 9 10 11
13 14
Next
 
Last

Share This Page