Master & Dynamic MW07 connectivity
Dec 4, 2018 at 12:29 PM Thread Starter Post #1 of 11

ggibby

New Head-Fier
Joined
Nov 22, 2012
Posts
40
Likes
18
Hey Y'all,

I searched the site several ways and did not find a thread dedicated to these,
apologies if I missed it.

SO, I have a fairly good collection of over-ear and IEMs,
but resisted the Truly Wireless because Bluetooth.
Black Friday changed my mind and I picked up the Master & Dynamic MW07.

Overall the fit and sound signature are what I like (Viper4Android helps a bit),
but the actual Bluetooth connectivity is troublesome.

Examples - while watching TV and connected my Amazon Fire TV box,
taking the pods out pauses playback (as expected), but then it will start up again.
I suspect this has to do with the pods' proximity and they think I've re-inserted them.

Then I switch the connection back to my Moto G5 (Android 8.1) which takes some fiddling,
and go to fold laundry.
Several times the connection blips, then one channel drops, then then resumes.
Assuming this had to do with the steel laundry machines (which were off),
I set the 'phone in the dryer drum - no issues.
But then the same thing happens when taking out the trash, just walking up the driveway.
Through all this the 'phone was in my baggy shorts' pocket, no belt buckle, maille, or tinfoil hat.

Sitting at my desk with the 'phone in reach, no issues,
until I accidentally turned off the Bluetooth on the 'phone,
and the MW07 wouldn't reconnect.

Did I get a bum set?

M&D don't have an app or any mention of firmware updates,
so should I expect this sort of thing forever?

-G
 
Dec 6, 2018 at 1:18 PM Post #2 of 11

ggibby

New Head-Fier
Joined
Nov 22, 2012
Posts
40
Likes
18
Followup - the MW07 claimed battery life is shorter than most others,
and I have not tested with notes, but that matches my experience.

This is relevant because the battery level is shown on the 'phone as an icon,
and it seems that when the battery level gets into the 30% range, reconnecting is bothersome.

Dropping them into the case clears it up, but that's annoying.

Also, when I drop them in the case, the LEDs show battery level - green/yellow/red.
Even when the case reports red, connecting to the 'phone shows 100% charge.

There is no apparent ability or plan to update the firmware on the MW07,
which is a pretty serious flaw.
 
Dec 9, 2018 at 11:17 AM Post #3 of 11

PolliSoft

New Head-Fier
Joined
Jan 21, 2013
Posts
2
Likes
1
I got mine a week ago, and I have similar problems as well.
Pretty often, my left headphone drops the sound completely while the right continues to play. This makes me think that is not the proximity sensor that is faulty, but that the left/right connection drops.
In order to get the connection back I have to do the following steps:
1. Turn off the BT on my phone
2. Hold the button on the right headphone until it starts searching for a BT connection. Slow LED blinking...
3. Hold both volume buttons on the left headphone for about 10 sec, until the left one starts searching for the right one. Slow LED blinking until it finds the right headphone.
4. Start BT on the phone and connect to the MW07.

This is quite tedious to do, as it happens once per hour or so. I've also reported this via the Web site as a support ticket ,but so far no answer. I would love a fw update.
 
Dec 13, 2018 at 10:07 AM Post #4 of 11

ggibby

New Head-Fier
Joined
Nov 22, 2012
Posts
40
Likes
18
I couldn't deal with the annoyance, especially given how many wired ear/headphones I have with zero connection issues and perfect firmware :)

The MW07 went back, and the Jabra Elite 65t I got for comparison probably will, too.
More stuff to charge, software to frown at, problems I can't solve with a meter and soldering iron?
No thanks.

Glad I tried them out so my opinion is mine and not borrowed.
 
Jan 2, 2019 at 10:34 PM Post #5 of 11

Closingracer

100+ Head-Fier
Joined
Sep 3, 2013
Posts
306
Likes
21
I am using an iPhone X with these if that makes a difference but I haven’t had any of these issues with the MW07. SQ wise I find these the best I have used so far. Maybe try the Sennheiser momentum true wireless ?
 
Jan 13, 2019 at 5:18 PM Post #6 of 11

WolandG

New Head-Fier
Joined
Jan 12, 2019
Posts
1
Likes
0
Location
Boston, MA
Do any of you guys with MW07s hear disbalanced white noise from them (left one has louder white noise than the right one for me)? Sound quality is excellent, but this is an issue that is bothering me a bit when listening to quieter music.
 
Jan 14, 2019 at 12:19 AM Post #7 of 11

Tommy C

Headphoneus Supremus
Joined
Aug 22, 2011
Posts
1,565
Likes
814
Hey Y'all,

I searched the site several ways and did not find a thread dedicated to these,
apologies if I missed it.

SO, I have a fairly good collection of over-ear and IEMs,
but resisted the Truly Wireless because Bluetooth.
Black Friday changed my mind and I picked up the Master & Dynamic MW07.

Overall the fit and sound signature are what I like (Viper4Android helps a bit),
but the actual Bluetooth connectivity is troublesome.

Examples - while watching TV and connected my Amazon Fire TV box,
taking the pods out pauses playback (as expected), but then it will start up again.
I suspect this has to do with the pods' proximity and they think I've re-inserted them.

Then I switch the connection back to my Moto G5 (Android 8.1) which takes some fiddling,
and go to fold laundry.
Several times the connection blips, then one channel drops, then then resumes.
Assuming this had to do with the steel laundry machines (which were off),
I set the 'phone in the dryer drum - no issues.
But then the same thing happens when taking out the trash, just walking up the driveway.
Through all this the 'phone was in my baggy shorts' pocket, no belt buckle, maille, or tinfoil hat.

Sitting at my desk with the 'phone in reach, no issues,
until I accidentally turned off the Bluetooth on the 'phone,
and the MW07 wouldn't reconnect.

Did I get a bum set?

M&D don't have an app or any mention of firmware updates,
so should I expect this sort of thing forever?

-G

Have you tried here? Many MW07 owners.
https://www.head-fi.org/threads/goi...re-we-there-yet.861024/page-280#post-14716763
 
May 18, 2019 at 2:21 PM Post #10 of 11

bheld

New Head-Fier
Joined
May 17, 2019
Posts
14
Likes
0
Location
Marietta, Ga.
I have the iPhone X as well. I am extremely interested in purchasing the M&D MW07 EarPods. Virtually every review speaks to their incredible sound, comfort, quality, etc. I currently use 1st generation Apple AirPods.
I will be using these in my office (private & quiet) most of the time and therefore I will be using them for business calls. The little info I have found reviews them as very poor, sub par quality for phone calls??? I would really appreciate any information regarding call quality and sound especially for the person on the other end of the call......especially if you purchased them in the last few months. I read they are tinny, static, and tunnel effect?
THANKS! Bh
 
Nov 25, 2019 at 9:55 PM Post #11 of 11

LuisG

New Head-Fier
Joined
Oct 20, 2019
Posts
1
Likes
0
Location
US
I got mine a week ago, and I have similar problems as well.
Pretty often, my left headphone drops the sound completely while the right continues to play. This makes me think that is not the proximity sensor that is faulty, but that the left/right connection drops.
In order to get the connection back I have to do the following steps:
1. Turn off the BT on my phone
2. Hold the button on the right headphone until it starts searching for a BT connection. Slow LED blinking...
3. Hold both volume buttons on the left headphone for about 10 sec, until the left one starts searching for the right one. Slow LED blinking until it finds the right headphone.
4. Start BT on the phone and connect to the MW07.

This is quite tedious to do, as it happens once per hour or so. I've also reported this via the Web site as a support ticket ,but so far no answer. I would love a fw update.
How do you know it found or is finding the right bud? What do you do if it doesn't pair?
 

Users who are viewing this thread

Top