Macbook audio out messed up?
Jul 25, 2007 at 3:51 AM Thread Starter Post #1 of 8

dozens

Head-Fier
Joined
Feb 12, 2007
Posts
82
Likes
10
Hey, my Macbook audio works fine when I hav e headphones in, but when I pull the plug out the audio does not come thru the speakers and the volume button shows a speaker with a slash thru it.

Also there is a red light in the plug port. Weird.
 
Jul 25, 2007 at 4:17 AM Post #2 of 8

gjustice

Head-Fier
Joined
Apr 15, 2007
Posts
60
Likes
10
A Few thoughts:
First MB's have seperate volume for the internal speakers and anything using audio out. Aka if you have the headphone volume turned to 50% then take them out the speakers will return to the volume they were set to previously. So maby you have your speakers turned off, but your headphones have volume.

The red light is because the audio out doubles as a opticial line out, so the red light is on because the computer thinks that an optical cable is plugged in, which may be the other reason you get no sound out of the speakers.
 
Jul 25, 2007 at 8:40 AM Post #4 of 8

Soundproof

New Head-Fier
Joined
Jun 24, 2007
Posts
23
Likes
0
There's a very useful Help manual embedded in the Mac OSX.
If you enter Sound Output in it, you'll be guided to numerous options.

Check System Preferences > Sound > Output. Have you chosen Internal Speakers. Are they muted?

Check your menu bar - the sound volume there (loudspeaker symbol) should show the same setting as in SysPrefs. But I have actually seen this at bottom, with the SysPref sound up on mine.

Next. Applications > Utilities > Audio MIDI Setup.
Check that you haven't chosen some weird setup there.
 
Jul 25, 2007 at 5:42 PM Post #6 of 8

Soundproof

New Head-Fier
Joined
Jun 24, 2007
Posts
23
Likes
0
Quote:

Originally Posted by dozens /img/forum/go_quote.gif

Also there is a red light in the plug port. Weird.



The minijack OUT port doubles for both analog minijack and for optical digital OUT. The red light is the optical signal. But on my Macs that only begins when I have a Toslink Optical minijack connected.

Check your output configuration again - seems you have set it to pipe optica, digital.
Do you have an y soundcards attached? If so, then the OS may have read that you want to output digital. That happens automatically with my computer when I connect my TosLink minijack to it.
 

Users who are viewing this thread

Top