Loose connection on SR225s
post-812979
Thread Starter
Post #1 of 3

gregeas

100+ Head-Fier
Joined
Feb 17, 2004
Messages
482
Reaction score
11
Joined
Feb 17, 2004
Posts
482
Likes
11
This must be a pretty common problem: every time I move the left channel cuts out on my Grado SR225s.

I can see the loose connection through the wire grill. Doesn't look like it would be tough to solder back if I could get the plastic casing open... But I can't.

Any suggestion on how to repair the Grados? Or should I just send them back (I believe the warranty has expired).

Anyone?
 
     Share This Post       
post-813582
Post #2 of 3

skitlets

500+ Head-Fier
Joined
Mar 14, 2004
Messages
944
Reaction score
10
Joined
Mar 14, 2004
Posts
944
Likes
10
see if u can send it back. theyre customer service isnt that bad. if they wont cover it, they mite charge u a little 2 repair. if not, i guess ur last resort is to solder it urself
 
     Share This Post       
post-813593
Post #3 of 3

Xanadu777

Member of the Trade: Headphile
Headphone Modder Extraordinaire
Joined
Aug 12, 2003
Messages
1,257
Reaction score
11
Joined
Aug 12, 2003
Posts
1,257
Likes
11
You can call Grado and ask, they may fix it for free. If you want to do it yourself, it's not too hard, just takes a bit of nerve.

Take off foam pad. Squeeze the outer ring near the screen in a twisting, circular motion. What you're trying to do is crack the hot glue but not take it off yet. Take a spoon that has a handle that gets bigger towards the opposite end of the spoon part. Slip it flat between the two plastic housings until the large part of the spoon handle makes contact with both sides. Once you have the leverage, slightly twist the spoon. Continue around till all the hot glue breaks. Resolder and pick glue hunks out of inside of screen. Dry fit to make sure it inserts back on far enough. Hot glue around the inside edge, you'll know where, and quickly and tightly hold till drys.
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top