Latest Firefox ver. 3.5.3, is it buggy???
Oct 2, 2009 at 3:55 AM Thread Starter Post #1 of 12

RYCeT

Headphoneus Supremus
Joined
Jan 23, 2003
Posts
3,114
Likes
56
Hi guys, since I've upgraded to ver. 3.5, I got several websites which I can't open with my firefox, both the windows n mac version.

The websites which I have problems with are:
Apple
I can't see apple welcome page correctly, I can only see the upper tab (apple logo, store, mac, ipod+itunes, etc) and the hot news headline on the lower tab. The usual products pics (Iphone, OSX leopard, Ipod) which is big on the middle of the page shown as blank. It's only on apple.com 1st page / welcome page, all the inside of the website work perfectly.

Mortgage Calculator - Bankrate.com
I can't even see this website, it's shown as blank.

I have no problem seeing those websites on my Safari (mac) or IE and Chrome (windows)

Anyone having the same problems as mine? I got adblock plus on both of my firefox.
 
Oct 2, 2009 at 1:52 PM Post #5 of 12

terrymx

Headphoneus Supremus
Joined
Apr 24, 2003
Posts
4,759
Likes
12
No it seem fine to me, are you running any addon like Flashblock and NoScript?

I usually uninstall a software before updating. If anymore problems I also delete the folder in %appdata%.
 
Oct 2, 2009 at 2:18 PM Post #9 of 12

krmathis

Head-Fi's Most Prolific Poster
Joined
Jan 13, 2004
Posts
34,764
Likes
74
It does not feel buggy here!
Runs quite nicely on Windows XP Pro on my work laptop.
 
Oct 3, 2009 at 5:11 AM Post #11 of 12

Jubei

Headphoneus Supremus
Joined
Jul 27, 2004
Posts
1,571
Likes
14
Quote:

Originally Posted by subtle /img/forum/go_quote.gif
I haven't upgraded from 2.0.20. I tried 3 for about an hour and had to revert back. They killed Firefox with the move to version 3 IMO.


Same for me. I had loads of problems loading pages for all sorts. Even tried FF 3.5.x on a new build with no luck.
 

Users who are viewing this thread

Top