1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

KOSS ESP-950 Thread

Discussion in 'High-end Audio Forum' started by milosz, Nov 22, 2011.
First
 
Back
228 229 230 231 232 233 234 235 236 237
239 240 241 242
Next
 
Last
  1. stuck limo
    My Koss should be arriving today. I went ahead and ordered the iFi iPower 9v/2A version as well as a generic 9v/3A wall wart which will be fed by a Furman power conditioner. I'll be interested to see if there's any big difference between the two.
     
    barondla likes this.
  2. barondla
    @stuck limo hope you get ifi working hum free. Mine hums like @adeadcrab 's. Never had time to trouble shoot the problem. Looking forward to reading about your solution.
     
  3. stuck limo
    I took the back plate off the Koss so I could fit AQ cables properly into the RCA jacks. I'll drill out the holes larger and re-attach the plate. So right now I'm running it without a back plate. Sounds good so far, fairly close to my Senn 600 in nature. I have no idea how much "burn-in" this guy put on them, so I'll run them all day.
     
  4. theangelboy
    Heads up, drilling out the back plate voids your lifetime warranty. Just be aware. https://www.head-fi.org/threads/koss-esp-950-thread.581491/page-169#post-13273812
     
    Philimon and stuck limo like this.
  5. stuck limo
    Last edited: Oct 17, 2019
  6. adeadcrab
    Not sure which thread I posted the hum problems in, since that time I stuck to turning the energizer + LPS off every night and did not encounter any issues. Some minor hum occasionally for 10s at a time, but not the same type which never went away, no matter what I tried.
     
  7. barondla
    @adeadcrab are you talking about driver whine/hum? The ifi makes a 60hz hum, like a turntable without a ground wire. It causes some kind of ground loop. My drivers have never hummed using the Koss power supply.
     
  8. adeadcrab
    That could be isolated to the LPS, as you said some kind of ground loop. As mentioned before I had a similar issue that was attributed to a motorized desk.
     
  9. llcook51
    Are there any videos or guides on how to replace the original pads with Vespers?
    Thanks.
     
  10. stuck limo
    This does NOT fit the Koss. I will have to see if there's an adapter in the box. Brought it to work today and got there only to discover it won't fit.
     
  11. Amish
    Not that I am aware of but it is super easy. Just watch how you remove the original pads, place the vespers on the same way. They just pull off.

    [​IMG]
     
    Last edited: Oct 19, 2019
    barondla likes this.
  12. llcook51
    Thanks.
     
  13. barondla
    Mine came with a few adapters in the box and one fit the Koss. Hope you can figure out how to make it work hum free.
     
  14. stuck limo
    I don't hear any hiss, whine or hum with the iFi. (finally got it in there with the adapter)
     
    barondla likes this.
  15. barondla
    That's strange. Mine hums no matter what source is used. Even battery powered Pono Player and Shanling M0 hum. Not a little hum either. Tried different interconnects. Only thing not tried is different ac wall receptacle. Since the ifi is a switcher it should be polarity agnostic so I doubt using another receptacle will matter. Will try it when I get a chance.

    So @stuck limo does the ifi improve things sonically?
     
First
 
Back
228 229 230 231 232 233 234 235 236 237
239 240 241 242
Next
 
Last

Share This Page