iFi audio xDSD- The Official Thread
post-15065720
Post #1,711 of 1,983

Gamblel254

New Head-Fier
Joined
Feb 14, 2017
Messages
21
Reaction score
12
Joined
Feb 14, 2017
Posts
21
Likes
12
Where can I see a photo of the Gen2 USB-C xDSD?

It's not on the iFi website?

Both the USB data and the USB power are Type C connections?

Can someone kindly share a photo @iFi audio

Edit: found this in this thread Post #1595
 

Attachments

     Share This Post       
  • Like
Reactions: RockStar2005
post-15065857
Post #1,712 of 1,983

TooPoorForHiFi

Previously known as MidNighTempest
Joined
Jan 14, 2014
Messages
1,177
Reaction score
228
Location
Earth
Joined
Jan 14, 2014
Location
Earth
Posts
1,177
Likes
228
Where can I see a photo of the Gen2 USB-C xDSD?

It's not on the iFi website?

Both the USB data and the USB power are Type C connections?

Can someone kindly share a photo @iFi audio

Edit: found this in this thread Post #1595
There is a Gen2 coming out? WHEN!?

Any more INFO?
 
     Share This Post       
post-15065869
Post #1,713 of 1,983

Joseph Lin

100+ Head-Fier
Joined
Nov 8, 2016
Messages
321
Reaction score
128
Joined
Nov 8, 2016
Posts
321
Likes
128
There is a Gen2 coming out? WHEN!?

Any more INFO?
The ones I received come with USB C port. The first one does charge but not holding a charge. The 2nd one does not charge at all not even with the original cable. The charging light is off, no idea how much battery capacity left. Both of them have USB C port assuming 2nd generation. Walk away from 2nd gen. I saw both Amazon and Head-Fi have a few reports of not charging as well.
 
     Share This Post       
post-15066273
Post #1,714 of 1,983

TooPoorForHiFi

Previously known as MidNighTempest
Joined
Jan 14, 2014
Messages
1,177
Reaction score
228
Location
Earth
Joined
Jan 14, 2014
Location
Earth
Posts
1,177
Likes
228
The ones I received come with USB C port. The first one does charge but not holding a charge. The 2nd one does not charge at all not even with the original cable. The charging light is off, no idea how much battery capacity left. Both of them have USB C port assuming 2nd generation. Walk away from 2nd gen. I saw both Amazon and Head-Fi have a few reports of not charging as well.

Did you order from Amazon US?
 
     Share This Post       
post-15066319
Post #1,715 of 1,983

iFi audio

Sponsor: iFi Audio
Joined
Mar 20, 2013
Messages
5,752
Reaction score
2,875
Location
Location: HQ in the UK, but spread far and wide.
Joined
Mar 20, 2013
Location
Location: HQ in the UK, but spread far and wide.
Posts
5,752
Likes
2,875
Website
ifi-audio.com
The ones I received come with USB C port. The first one does charge but not holding a charge. The 2nd one does not charge at all not even with the original cable. The charging light is off, no idea how much battery capacity left. Both of them have USB C port assuming 2nd generation. Walk away from 2nd gen. I saw both Amazon and Head-Fi have a few reports of not charging as well.
We're very sorry about this happening to you. Have you tried dropping us a line here: https://support.ifi-audio.com/

You probably tried many different ports/chergers already, but are the ones you used within specs?
 
     Share This Post       
post-15066434
Post #1,716 of 1,983

Gus141

New Head-Fier
Joined
Aug 14, 2018
Messages
39
Reaction score
32
Location
New England, USA
Joined
Aug 14, 2018
Location
New England, USA
Posts
39
Likes
32
I just purchased xDSD and is experiencing very weird symptom that it will pause for a 0.1 second like the buffer is trying to catch up with the data consumed and then it will resume. It makes it almost impossible to listen to music. I tried extra safe mode, it still stutters. I am on the newest firmware 5.3c. Did anyone experience this behavior? Any solution?

Problem 2: I have been charging it for whole day and the battery indicator is still red(very dim). When disconnected from power source, it won't turn on. I never have a device with so many problems. I am thinking of returning it now.
New xDSD user as well (rev 2 w/USB-C) and experienced something like the pause/stutter you describe (it was almost like a pop every 15 to 20 seconds). This only happened after I updated the firmware to 5.3c and only when listening to MQA tracks. I fell back to 5.3 and everything was fine again. I’m sticking to 5.3 because I think the 2 filters sound great (didn’t notice much difference with the GTO filter because it sounded good too) but I like the KHz LED to show the color applicable to the input rather than show the same color for everything except MQA, caused by the upsampling for the GTO filter.

As for the power problem you describe, I have not tried any USB-C chargers but have had no problem using USB-A chargers with the included A-C cable. In fact with a 5v/1.8A charger charging speed was quite fast.

I may go back to 5.3c and do more troubleshooting and see if it’s just certain MQA tracks that skip/pop (e.g., 24/44.1 -> 24/88.2 vs 24/48 -> 24/96). @iFi-Audio, is there any risk going back and forth multiple times on the firmware?

Cheers
Gus
 
     Share This Post       
post-15066506
Post #1,717 of 1,983

TooPoorForHiFi

Previously known as MidNighTempest
Joined
Jan 14, 2014
Messages
1,177
Reaction score
228
Location
Earth
Joined
Jan 14, 2014
Location
Earth
Posts
1,177
Likes
228
New xDSD user as well (rev 2 w/USB-C) and experienced something like the pause/stutter you describe (it was almost like a pop every 15 to 20 seconds). This only happened after I updated the firmware to 5.3c and only when listening to MQA tracks. I fell back to 5.3 and everything was fine again. I’m sticking to 5.3 because I think the 2 filters sound great (didn’t notice much difference with the GTO filter because it sounded good too) but I like the KHz LED to show the color applicable to the input rather than show the same color for everything except MQA, caused by the upsampling for the GTO filter.

As for the power problem you describe, I have not tried any USB-C chargers but have had no problem using USB-A chargers with the included A-C cable. In fact with a 5v/1.8A charger charging speed was quite fast.

I may go back to 5.3c and do more troubleshooting and see if it’s just certain MQA tracks that skip/pop (e.g., 24/44.1 -> 24/88.2 vs 24/48 -> 24/96). @iFi-Audio, is there any risk going back and forth multiple times on the firmware?

Cheers
Gus

May I ask where did you Buy your xDSD?
 
     Share This Post       
post-15066605
Post #1,719 of 1,983

Gus141

New Head-Fier
Joined
Aug 14, 2018
Messages
39
Reaction score
32
Location
New England, USA
Joined
Aug 14, 2018
Location
New England, USA
Posts
39
Likes
32
In an on-line review by Hi-Fi News, on the ‘Sidebar’ part of the article ‘Listen or Measure’
[this link
https://www.hifinews.com/content/ifi-audio-pro-idsd-headphone-ampdac-sidebar-listen-or-measure
or this link for a PDF
https://ifi-audio.com/wp-content/uploads/2018/06/xDSD_HiFiNewsReviewOutstaning.low-res.pdf ]

the author says about the filter switch, “iFi Audio has its screen printing reversed around this little switch, so ‘Listen’ is ‘Measure’ and vice-versa. So it’ll be interesting to discover which, if any, headphone bloggers can hear the difference!”

Is this true? I was assuming that with pre-5.3c-firmware, Measure was a linear phase fast filter and Listen was a minimum phase slow filter. But if the switch is reversed based on this reviewers measurements, what switch position is the GTO filter mapped to on firmware 5.3c?
 
Last edited:
     Share This Post       
post-15066619
Post #1,720 of 1,983

RockStar2005

Headphoneus Supremus
Joined
Oct 6, 2014
Messages
4,083
Reaction score
845
Location
Chicago Suburbs
Joined
Oct 6, 2014
Location
Chicago Suburbs
Posts
4,083
Likes
845
In an on-line review by Hi-Fi News, on the ‘Sidebar’ part of the article ‘Listen or Measure’
[this link
https://www.hifinews.com/content/ifi-audio-pro-idsd-headphone-ampdac-sidebar-listen-or-measure
or this link for a PDF
https://ifi-audio.com/wp-content/uploads/2018/06/xDSD_HiFiNewsReviewOutstaning.low-res.pdf ]

the author says about the filter switch, “iFi Audio has its screen printing reversed around this little switch, so ‘Listen’ is ‘Measure’ and vice-versa. So it’ll be interesting to discover which, if any, headphone bloggers can hear the difference!”

Is this true? I was assuming that with pre-5.3c-firmware, Measure was a linear phase fast filter and Listen was a minimum phase slow filter. But if the switch is reversed based on this reviewers measurements, what switch position is the GTO filter mapped to on firmware 5.3c?
Wait, WHAT?!! They're reversed-labeled??!! iFi, PLEASE confirm or deny this.
 
     Share This Post       
post-15066836
Post #1,721 of 1,983

flyte3333

Previously known as Em2016
Joined
Jan 21, 2017
Messages
1,201
Reaction score
384
Joined
Jan 21, 2017
Posts
1,201
Likes
384
Hi all / @iFi audio

What does it mean when the rotary LED is red and also input and kHz LED are both red (all solid red, not flashing) when xDSD is off and only charging at the wall?

This scenario isn’t covered in the manual...

5.3C firmware
 
Last edited:
     Share This Post       
post-15066843
Post #1,722 of 1,983

flyte3333

Previously known as Em2016
Joined
Jan 21, 2017
Messages
1,201
Reaction score
384
Joined
Jan 21, 2017
Posts
1,201
Likes
384
the author says about the filter switch, “iFi Audio has its screen printing reversed around this little switch, so ‘Listen’ is ‘Measure’ and vice-versa.
Would be great if @iFi audio can confirm what this is about.

Only taking a guess the reviewer means he looked at his measurements and saw the “listen” filter resulted in linear phase impulse response and the “measure” resulted in the minimum phase response. Which indeed would be backwards.

But it’s hard to know as the reviewer didn’t expand more. But hopefully iFi can clarify.
 
     Share This Post       
post-15066853
Post #1,723 of 1,983

Bansaku

1000+ Head-Fier
Joined
Feb 17, 2014
Messages
1,141
Reaction score
861
Location
Edmonton, AB
Joined
Feb 17, 2014
Location
Edmonton, AB
Posts
1,141
Likes
861
Age
41
Hi all / @iFi audio

What does it mean when the rotary LED is red and also input and kHz LED are both red (all solid red, not flashing) when xDSD is off and only charging at the wall?

This scenario isn’t covered in the manual...
This is a first for me and have yet to hear about nor experience this scenario. TBH, all red doesn't sound too good. @iFi audio is going to have a busy day tomorrow replying. :stuck_out_tongue_closed_eyes:
 
     Share This Post       
  • Like
Reactions: flyte3333
post-15068282
Post #1,724 of 1,983

iFi audio

Sponsor: iFi Audio
Joined
Mar 20, 2013
Messages
5,752
Reaction score
2,875
Location
Location: HQ in the UK, but spread far and wide.
Joined
Mar 20, 2013
Location
Location: HQ in the UK, but spread far and wide.
Posts
5,752
Likes
2,875
Website
ifi-audio.com
What does it mean when the rotary LED is red and also input and kHz LED are both red (all solid red, not flashing) when xDSD is off and only charging at the wall?
This would indicate little leakage that keeps the xDSD's circuit running: http://support.ifi-audio.com/kb/faq.php?id=896

Please reach us at our support platform, thanks!

@iFi audio is going to have a busy day tomorrow replying. :stuck_out_tongue_closed_eyes:
We're ALWAYS busy. Even when we sleep, we work. We're machines, not real people. Bzzt, bzzt.
 
Last edited:
     Share This Post       
  • Like
Reactions: docentore
post-15068290
Post #1,725 of 1,983

iFi audio

Sponsor: iFi Audio
Joined
Mar 20, 2013
Messages
5,752
Reaction score
2,875
Location
Location: HQ in the UK, but spread far and wide.
Joined
Mar 20, 2013
Location
Location: HQ in the UK, but spread far and wide.
Posts
5,752
Likes
2,875
Website
ifi-audio.com
Last edited:
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 3)

Top