iFi audio NEO iDSD - The Performance Edition is here! (INFO: Post 837, Page 56)
Dec 16, 2020 at 1:19 PM Post #466 of 1,022
Joined
Apr 24, 2016
Posts
2,968
Likes
3,734
Location
Colorado
Silent as I have not detected the hissing sound mentioned in previous posts.
Using LDAC from my phone steaming high resolution Qobuz.

Bluetooth implementation so far seems to be really excellent.
Just a slight loss of overall fidelity and some kind of harshness at the higher registers as is to be expected from bluetooth!
I'm using my Neo iDSD for a few days and it works flawless. Mostly with the HD660s, sometimes directly, sometimes with a Corda Jazz FF as external amp. Didn't encounter any noise issues.
So far I've used spdif coax, usb (asio, win10), bluetooth (pc, win10). SE and balanced out.
Functionality is great, sound is great, too. I'm looking forward to spend more time with it.

So glad to hear from you both and that you aren't experiencing any of the noise issues that have been previously discussed!

Looking forward to more of your impressions as they come along.
 
Dec 16, 2020 at 1:28 PM Post #467 of 1,022

Joaqu2n

Head-Fier
Joined
Feb 17, 2017
Posts
55
Likes
45
Location
Barcelona, España
Hi there! There was a miscommunication on our part and the site will be corrected accordingly.

5.3/5.c does not apply to the Neo at all.

Although it should have no effect on the Neo (such as bricking it), but it will now likely show the incorrect sample rate.

The Neo will have a software / firmware update in the next few weeks as per our aforementioned update.

If you end up having issues as a result of the install, please let us know!

I knew it :frowning2:

Since @iFi audio told me that it came with v5.3c installed and I saw v1.23 I knew that something was not right. On repeated firmware installs it would show me 48 khz and switch to bluetooth input. And without knowing too much, problems with noise and lack of power may be related to all this. Maybe it is blocked?

In fact tomorrow I return it to the store. If you think I should wait, let me know.

Thank you.
 
Dec 16, 2020 at 1:32 PM Post #468 of 1,022
Joined
Apr 24, 2016
Posts
2,968
Likes
3,734
Location
Colorado
I knew it :frowning2:

Since @iFi audio told me that it came with v5.3c installed and I saw v1.23 I knew that something was not right. On repeated firmware installs it would show me 48 khz and switch to bluetooth input. And without knowing too much, problems with noise and lack of power may be related to all this. Maybe it is blocked?

In fact tomorrow I return it to the store. If you think I should wait, let me know.

Thank you.

I would recommend getting a replacement and noting the firmware discrepancies when you return it.

Specifically, on your end, the 5.3/5.3c firmware installation does not relate to the issues other folks are having at all.

Thank you for the info on what happened when you installed the other firmware!
 
Dec 16, 2020 at 1:36 PM Post #469 of 1,022

Joaqu2n

Head-Fier
Joined
Feb 17, 2017
Posts
55
Likes
45
Location
Barcelona, España
I would recommend getting a replacement and noting the firmware discrepancies when you return it.

Specifically, on your end, the 5.3/5.3c firmware installation does not relate to the issues other folks are having at all.

Thank you for the info on what happened when you installed the other firmware!

Do you think the new update will solve the problems we are reporting? How much time can take?

Thank you.
 
Dec 16, 2020 at 1:42 PM Post #471 of 1,022
Joined
Apr 24, 2016
Posts
2,968
Likes
3,734
Location
Colorado
I think he just said it has no relation to the other issues.

@Baten ~ my response was specifically in relation to @Joaqu2n updating to 5.3/c and having other issues.

If he was already experiencing the noise issues beforehand, that is a separate response that Rob already covered and relates to the rest of the folks experiencing the same noises.

@Joaqu2n ~ We currently don't have an exact date other than a few weeks.

When we know, you all will!
 
Dec 16, 2020 at 1:45 PM Post #472 of 1,022

Joaqu2n

Head-Fier
Joined
Feb 17, 2017
Posts
55
Likes
45
Location
Barcelona, España
I think he just said it has no relation to the other issues.
@Baten ~ my response was specifically in relation to @Joaqu2n updating to 5.3/c and having other issues.

If he was already experiencing the noise issues beforehand, that is a separate response that Rob already covered and relates to the rest of the folks experiencing the same noises.

@Joaqu2n ~ We currently don't have an exact date other than a few weeks.

When we know, you all will!


Thanks a lot :wink:
 
Dec 16, 2020 at 1:47 PM Post #473 of 1,022
Joined
Apr 24, 2016
Posts
2,968
Likes
3,734
Location
Colorado
Dec 17, 2020 at 10:56 PM Post #474 of 1,022

JWahl

1000+ Head-Fier
Joined
Mar 26, 2011
Posts
1,174
Likes
404
Location
Central Mississippi
Last edited:
Dec 18, 2020 at 2:53 AM Post #476 of 1,022

Baten

Headphoneus Supremus
Joined
Sep 13, 2012
Posts
1,744
Likes
865
Could I use an adapter to connect a single-ended headphone to the 4,4 mm. balanced output (6,35 female - 4,4 male) ? If so a link would be helpful, thanks.
Why? There is a single ended output. You can't go balanced to unbalanced with an adapter. Unbalanced does not have the pin-out that a balanced connection needs...
 
Dec 18, 2020 at 3:05 AM Post #477 of 1,022

Sunstealer

500+ Head-Fier
Joined
Sep 19, 2018
Posts
564
Likes
494
Location
UK
Could I use an adapter to connect a single-ended headphone to the 4,4 mm. balanced output (6,35 female - 4,4 male) ? If so a link would be helpful, thanks.
Nope. You can go single-ended socket to balanced headphone with an adapter but NOT balanced socket to single ended headphone. You will fry your gear.
 
Dec 18, 2020 at 12:48 PM Post #479 of 1,022
Joined
Apr 24, 2016
Posts
2,968
Likes
3,734
Location
Colorado
Dec 18, 2020 at 1:09 PM Post #480 of 1,022

Cuthbert 80

Head-Fier
Joined
Sep 28, 2020
Posts
61
Likes
145
Location
London
I've posted my formal review for the tour loaner at exactly one week from its departure, because I am a master procrastinator :darthsmile:

https://www.head-fi.org/showcase/ifi-audio-neo-idsd.24765/review/24948/
Nice and detailed review mate :ok_hand:

It's funny how you mentioned the slight upper mid push of the NEO....that's exactly the area that I toned down a little with some software EQ, heh.

Am still debating whether or not I should "upgrade" my power supply to the iFi iPower X.

If I could extract an extra 5-10% of performance with iPower X, I'd bite lol
 

Users who are viewing this thread

Top