iBasso DX80 . . impressions and reviews. . and discussion NEW FW: 1.6.0 ** link . . 1st page . . .
Nov 24, 2017 at 7:47 AM Post #6,606 of 6,795

alexandros a

1000+ Head-Fier
Joined
Mar 28, 2016
Posts
1,081
Likes
3,168
Location
Atnens. Greece
How many hours of burn-in will take on DX80 to sound at its best guys??
 
Nov 24, 2017 at 8:15 AM Post #6,608 of 6,795

alexandros a

1000+ Head-Fier
Joined
Mar 28, 2016
Posts
1,081
Likes
3,168
Location
Atnens. Greece
Nov 27, 2017 at 12:58 AM Post #6,609 of 6,795

matique

100+ Head-Fier
Joined
Nov 11, 2017
Posts
121
Likes
97
Location
Singapore
Hi guys. My Ibasso DX80 (1.6.0) can't read my sdcards.

They are Sandisk 128GB cards. Fully working for over a year. One day after updating my music, the dx80 doesn't read them. I then proceeded with the following steps (if step continues, it means previous step didn't work):
  1. Reformatted to ExFat (quickformat)
  2. Reformatted to Fat32 (quickformat)
  3. Factory reset.
  4. Repeat steps 1-3 on 3 different MicroSD cards and also in overwrite mode. Took 3 hours to completely gut one card in overwrite mode. Hope it'd work, didn't.
  5. Still can't mount external MicroSD cards.
In recovery it says it can't mount external sd card (i/o error). The cards are working fine in my AK120ii and my Mac Pro. What am i doing wrong? Should I attempt to reformat the "iBasso__ DX80 Media"? But under the "scheme" there's GUID Partition Map, Master Boot Record, Apple Partition Map.

I was thinking it might be an issue with the firmware but I can't update it as it can't mount my MicroSD cards. Is the DX80 capable of being pushed an update through ADB in recovery? The device functions fine though. It can be used a dac no problem.

Edit*
Used batch tool to change firmwares. Doesn't seem to be a firmware problem. 1.5.8 and 1.6.0 both fail to mount SD slots in either slot. Tried lurkers version too, not working. Am at a complete loss at what to do next. I've tried every possible method I think.

Is this possibly...a hardware failure?
 
Last edited:
Nov 27, 2017 at 7:20 AM Post #6,610 of 6,795

Lurker0

Headphoneus Supremus
Joined
Jul 11, 2014
Posts
1,849
Likes
1,844
Location
Moscow, Russia
Nov 27, 2017 at 8:29 AM Post #6,611 of 6,795

matique

100+ Head-Fier
Joined
Nov 11, 2017
Posts
121
Likes
97
Location
Singapore
Nov 27, 2017 at 8:44 AM Post #6,612 of 6,795

jon parker

Headphoneus Supremus
Joined
Feb 22, 2011
Posts
2,180
Likes
1,979
Location
Lake District
Did you do a factory reset OR add a new firmware using the iBasso batch tool linked on page 1 ?
That has fixed issues for me in the past
 
Nov 27, 2017 at 8:54 AM Post #6,613 of 6,795

matique

100+ Head-Fier
Joined
Nov 11, 2017
Posts
121
Likes
97
Location
Singapore
Did you do a factory reset OR add a new firmware using the iBasso batch tool linked on page 1 ?
That has fixed issues for me in the past

Yes, I have done a factory reset, both from the UI and from recovery. Yes, i have tried new firmware using the ibasso batch tool. Used 1.5.8, 1.6.0, and also lurker's firmwares. It's unlikely a virus too as I strictly use my own ripped tracks and HDtracks. I have formatted the 128gb cars too, as well as a 8gb card formatted in fat32. The only steps i'm unsure is if i should format the DX80 drive itself, mac disk utility can format it but i'm unsure what parameters i should set; GUID Partition Map, Master Boot Record or Apple Partition Map and whether to be in fat32 or exfat..
 
Nov 27, 2017 at 9:17 AM Post #6,614 of 6,795

jon parker

Headphoneus Supremus
Joined
Feb 22, 2011
Posts
2,180
Likes
1,979
Location
Lake District
I have a sneaky suspicion you may need to do some or all of that on a PC - There is something in the back of my mind about MAC's & Dx80?
However, Ive had similar issues and it was a case of doing a few resets until it started working again - I had to do a few until something clicked!
I wouldn't reformat the device itself unless iBasso themselves advice that - Bear in mind iBasso as a company are incredibly helpful
Sounds like time to contact them directly
Sorry your'e having these troubles :/
 
Nov 27, 2017 at 9:36 AM Post #6,615 of 6,795

matique

100+ Head-Fier
Joined
Nov 11, 2017
Posts
121
Likes
97
Location
Singapore
I have a sneaky suspicion you may need to do some or all of that on a PC - There is something in the back of my mind about MAC's & Dx80?
However, Ive had similar issues and it was a case of doing a few resets until it started working again - I had to do a few until something clicked!
I wouldn't reformat the device itself unless iBasso themselves advice that - Bear in mind iBasso as a company are incredibly helpful
Sounds like time to contact them directly
Sorry your'e having these troubles :/

I have a pc and i have repeated the steps with it too. I've contacted them and would be sending my dx80 for inspection as well as for battery change. With flac files i'm only getting three hours playback. Past few days have just been using as a dac lol.
 

Users who are viewing this thread

Top