iBasso DX80 . . impressions and reviews. . and discussion NEW FW: 1.6.0 ** link . . 1st page . . .
Jul 27, 2016 at 5:07 PM Post #5,147 of 6,795

zombicube

Head-Fier
Joined
Mar 9, 2016
Posts
75
Likes
24
I've been pretty critical (sometimes regrettably so) of iBasso in the few posts I've ever made to this forum, so I thought it only fair to report that the 1.5.2 firmware has more or less fixed all the problems I had with the previous firmwares. If I had more money (or fewer dependents), I'd probably have given up on the DX80 months ago and plunked down the $$ for something like a DP-X1. But alas I'm in the "Grado SR60" price range, so I pretty much had to wait for iBasso to get their act together. And they did. And it was worth the wait. And I hope it's only up hill from here--past the break/fix mode and into adding features. But really, all I ever wanted was for the machine to work. And now it works.
 
Jul 27, 2016 at 5:19 PM Post #5,148 of 6,795

pholcus1975

500+ Head-Fier
Joined
Dec 7, 2014
Posts
793
Likes
180
Location
Italy
UI suggestion:when scrolling Album, Artist, All music, Genre, first letter should increase in size, just like Time when moving time bar in plying screen.
I missed that feature the other day, when I plugged dx80 into aux socket of car, and whike driving names are too small to read
 
Jul 28, 2016 at 12:27 AM Post #5,149 of 6,795

jeronim0

IP address matches known bad trader "thepooh"
Joined
Jul 3, 2016
Posts
76
Likes
10
Since I bought the DX80, all I can read in this thread is UI, artwork issues !

I don't really care about some of my album artworks not showing up, but I care about the main purpose of having a dap "the sound". It would be nice if we could get into future improvements in this area :)
 
Jul 28, 2016 at 2:45 AM Post #5,151 of 6,795

Yoones

Head-Fier
Joined
Feb 26, 2006
Posts
52
Likes
11
Since I bought the DX80, all I can read in this thread is UI, artwork issues !

I don't really care about some of my album artworks not showing up, but I care about the main purpose of having a dap "the sound". It would be nice if we could get into future improvements in this area
smily_headphones1.gif


most issue were about battery drain, or corrupted database (a few about line out and dac function of the player)
tags in general were suspected to cause the issue, then narrowed it to embedded artwork, it appears that it might be due to database size limitations.
 
"the sound" is a highly biased subject to work on, and so far most users seems to enjoy the sound quality of this DAP.
 
Jul 28, 2016 at 4:05 AM Post #5,152 of 6,795

jeronim0

IP address matches known bad trader "thepooh"
Joined
Jul 3, 2016
Posts
76
Likes
10
most issue were about battery drain, or corrupted database (a few about line out and dac function of the player)
tags in general were suspected to cause the issue, then narrowed it to embedded artwork, it appears that it might be due to database size limitations.

 
"the sound" is a highly biased subject to work on, and so far most users seems to enjoy the sound quality of this DAP.


I won't say that it should reach the level of an AK240 considering the same dual cirrus dac setup, but some improvements are more than welcome.

It actually sounds worst than my V10 and that's not a matter of preferences, the DX80 seems to be quite tricky to pair.

The best synergy I got from it is when pairing with the $5 budget Monk Plus, this should really tell you something considering that I have headphones over the $1000 range
 
Jul 28, 2016 at 6:32 AM Post #5,154 of 6,795

captblaze

Headphoneus Supremus
Joined
Feb 11, 2016
Posts
1,711
Likes
1,341
Location
Blazin' it up anywhere and everywhere
I just grabbed a DX80 and I am trying my best to like this device, but I am really getting frustrated with how it handles scanning and organizing my rather small (265 albums approx. 5500 songs) music collection. I am getting split albums because the scan is tagging some songs (NULL).
 
no matter which firmware I use the condition remains and is frustrating to a high degree. I have run my collection through 2 different tagging apps, and the collection is tagged as it should be. Naming and track numbers consistent and accurate. So what gives?
 
I have no complaints  other than this and to be honest it is gonna be a deal breaker if I cant resolve it quickly, especially since my LG Nexus 5 running UAPP doesn't do this. you would think a dedicated player would handle standard tags easily and efficiently, wouldn't you?
 
If anyone knows the magic that will correct this I will be forever grateful and so will IBasso because they wont lose the sale because of this device
 
Jul 28, 2016 at 6:38 AM Post #5,155 of 6,795

Lurker0

Headphoneus Supremus
Joined
Jul 11, 2014
Posts
1,857
Likes
1,868
Location
Moscow, Russia
  I am getting split albums because the scan is tagging some songs (NULL).


Do you run the latest (1.5.2 for today) firmware? It should have fixed this problem.
 
 

 
Jul 28, 2016 at 6:46 AM Post #5,158 of 6,795

captblaze

Headphoneus Supremus
Joined
Feb 11, 2016
Posts
1,711
Likes
1,341
Location
Blazin' it up anywhere and everywhere
 
I have had the same problems, but after using the batch-tool to install FW 1.5.2 my scanning-issues were solved!


​I will give that a try... thanks for the tip
 
Update-- tried the batch tool method and i ended up with the same result... Null folder that scavenges songs from other albums.
 
Any other suggestions? this is going back Monday otherwise and i will stick with my original setup
 
Jul 28, 2016 at 7:22 AM Post #5,159 of 6,795

Coyley

Head-Fier
Joined
Oct 18, 2014
Posts
96
Likes
18
Hi, on FW 1.5.2 I am now getting 17000 files scanned through fast with no problems at all.
 
I removed the embedded artwork in the files and just had a cover.jpg in each album folder, each file is 500x500 DPI.  This ultimately was my final issue.
 
I found that corrupt tags in some files were causing issues so I sorted those first.  This was true of badly tagged files I had downloaded.   I did scans, found it where dropped out, sorted those files, factory reset and started again.  It turned out only to be a few files in the 17K.
 
I used the free Album Art Tagger script available within MediaMonkey to retag the files and recopy them.
 
Then do a factory reset on the device to clear the library, remember to change the power management so the device doesn't time out in the scan, then do your scans.   First time 100% success, no null files, no drop outs or restarts.
 
I use the DX80 with various headphones and the sound is stunning.  I use High gain, do not touch the EQ and find the sound best of all the devices I've had for portable listening by far.
 
I am finally 100% happy and no need to revert back to 1.3.3 anymore.   I find 1.5.2 sound great and will carry on happily from here.
 
Thanks to iBasso and the forum.
 
Jul 28, 2016 at 7:24 AM Post #5,160 of 6,795

Coyley

Head-Fier
Joined
Oct 18, 2014
Posts
96
Likes
18
 
​I will give that a try... thanks for the tip
 
Update-- tried the batch tool method and i ended up with the same result... Null folder that scavenges songs from other albums.
 
Any other suggestions? this is going back Monday otherwise and i will stick with my original setup

 
 l feel your pain but have sorted this fully now and put a post up with how I did it.  ​
 

Users who are viewing this thread

Top