1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iBasso DX120 pure DAP player. Balanced, single ended, line out and 2 micro SD slots. FW 2.9.21 now out!

Discussion in 'Portable Source Gear' started by Paul - iBasso, Aug 31, 2018.
74 75 76 77 78 79 80 81 82 83
85 86 87 88 89 90 91 92 93 94
  1. JuanLuis91
    Oh, it was that. Yes I have read something about the sound modes.
  2. zaarog
    I got my dx120 yesterday and tried it out but I'm having some problems with it. The 32gb SD card I use shows only 242mb(I can only format it as much through the player) but if I connect it directly into a computer I can format it to 32gb just fine. How are you guys transferring your music onto the player? I've used the USB cable that came along with the player and connected the SD card into the player. Am I doing something wrong? I've tried a 64gb SD card and I have the same problem there. Is there a setting I've missed or something? I'm using a Samsung 32 gb micro SD card and the 64 gb card I tried is a Sandisk.

  3. crabdog
    Have you actually tried copying a large amount of data to the card on another device? Sounds like you might have received one of those fake cards.
  4. zaarog
    Yes, I have been using the card before on other devices. I tried again just to be sure, I copied several gb of music onto it but when I connected it into the dx120 it won't show anything. Just states that it's a 242mb SD card.
    I tried a new 4gb card now and it read that card well. I installed the latest firmware update but the problem with the other cards still remains. Is the DX120 not compatible with all brands of mSD cards? Or is my player faulty? (The 4gb card that worked is a Transcend and the cards that didn't work well are Samsung and Sandisk)
    Last edited: Mar 15, 2019
  5. crabdog
    I'm not sure what the problem is but it seems to be related to that specific card. I suppose you already tried both card slots?
  6. gmahler2u
    Have you try to factory reset and try to use SDcard.
  7. zaarog
    Yes, I've tried both slots several times and it keeps giving me the same result. Has anyone else had any similar problems? These 3 cards are the only ones I have at home but I will try more of them if i find any.

    Thanks for your help btw!
  8. zaarog
    Yeah, I've tried to factory reset it and I've also made a firmware update which also required a factory reset.
  9. DaYooper
    I have two 512gb cards in myDX120. When i connect the player to the computer through the usb port they show up as two usb devices and I transfer music two them just like any other card I attach to the machine.
    sandlapprs likes this.
  10. gmahler2u
    I have 200gb and 128gb sd card and I'm also connected directly to the computer and transferring the music. Also, I formatted to xfat before I transferred to dx120.
  11. crabdog
    Maybe @zaarog should try xfat or different formats. I didn't think of that.
  12. serg7891
    I have two samsung 2-256 gigabyte cards working fine.
  13. DaYooper
    Something I just thought about, usb settings on the DX120, it must be set to "reader" the settings menu has a spot for usb
  14. zaarog
    I tried formatting it to exfat but I got the same result. I tried another mSD card and it didn't even want to read it.

    Good to know that it should be working though, I think I'm gonna buy a new mSD card and try that, see how it works.

    Thanks for all your help, guys! It's much appreciated!

    Edit:Ok, I got the SD card working. We managed to remove a partition which wasn't being recognized by the dx120. We used a third-party software for removing and reformatting the SD card and it now works as it should. Hopefully this will help anyone with a similar problem.
    Thanks again for all of your help!
    Last edited: Mar 16, 2019
  15. crabdog
    My thoughts on the DX120 (those curves!) Enjoy.

74 75 76 77 78 79 80 81 82 83
85 86 87 88 89 90 91 92 93 94

Share This Page