1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iBasso DX120 pure DAP player. Balanced, single ended, line out and 2 micro SD slots. FW 2.9.21 now out!

Discussion in 'Portable Source Gear' started by Paul - iBasso, Aug 31, 2018.
93 94 95 96 97 98 99 100 101 102
104 105 106 107 108 109 110 111 112 113
  1. Lurker0
    It is not significant unless you have somehow damaged the "trust" partition.
    Sometimes it helps.
    Happosai420 likes this.
  2. Happosai420
    Thanks! It did seem to help! I switched cables and used a usb 2.0 port directly connected to the motherboard, and the upgrade worked this time! I feel like you understand this DAPs and tools better than any tech support! I didn't want to return the DX120, and you saved me from a lot of headache while teaching me a bit more about the FactoryTool itself too! Out of curiosity, is there a list of codes for the ones used in the log?
  3. Lurker0
    It is in pure English, isn't it? At least I think so and read it as such :D
  4. Rattle
    I've had the dx120 a couple days paired with KPE. Loaded up 128gb card and using balanced. Great sound very happy with that aspect of it. My only problem with the dap is unless I browse through directory once in a while the screen will go blank and music will stop. When it comes back from black screen it's paused at the beginning of the track I was playing. it does this if I browse through artist, album, etc. Even will do it when not playing music. If I browse through directory never an issue though. Is this a common thing? This is why i've stayed away from DAPS for years cuz there's always some douchebaggery software wise. All my album covers are .jpg and they all show fine, I get the feeling as it's buffering up the album covered on the fly it's bugging it out maybe ? Just clutching at straws I guess. Love it otherwise and I suppose just browsing through directory is not a deal breaker. I did update firmware and factory reset. did it on 2.0 and newest firmware.
    Last edited: Jul 1, 2019
  5. MarCo7
    Though I haven't encountered the issues you mentioned, I just wanted to suggest a couple of things:

    1. Though I usually browse thru directory like you do, maybe running a scan of the memory card to build the library might help? Also, have you tried using a different memory card?

    2. As for the screen turning off, have you checked the power saver settings? It almost sounds like the player is going to sleep/powering off so maybe your settings are set for a short length of time.

    Good luck!
  6. Rattle
    Thanks for the suggestions, I have scanned the memory card at least have a dozen times as I load more music into it each time. I have a 128gb SanDisk ultra that is new. Unfortunately it's the only card I have.

    The screen doesn't really turn off it's like it blanks out, you can see the backlight is still on. I'm pretty positive it's not going to sleep because it's set for 30 seconds for screen to shut off. It should not while am touching it over and over while browsing since it is not 30 seconds right? I suppose if it was shutting off the screen it still should not stop playback right ? I have it set to 20 minute shut off if inactive. Those 2 settings are stock.

    Paul - Ibasso suggested a wipe and fresh install of firmware using batch tool. I'll try that tomorrow.
    Last edited: Jul 2, 2019
  7. claudy
    I do have the same problems here, also 128gb sandisk class 10 A1 card. i'm running with the last filedizer version tho. usually the sudden blank screen appears when i choose 24bit file or dsf files from artist selection menu.
    Rattle likes this.
  8. Rattle
    Thanks for the post. I couldn't make a correlation between when it bugs out and file types. I did have some sacd iso on the card, I made dsf and replaced the ISO with the dsf versions. I have mostly 16bit flac some 24bit and dsf.

    Have you done a wipe and fresh firmware install with batch tool ?
  9. claudy
    well i don't have iso file on my card. after this problem appears on my x120 i haven't flash it with the batch tool yet.
    Rattle likes this.
  10. crabdog
    They also advise a factory reset after firmware upgrade too. Try that if you haven't done it yet.
  11. claudy
    Thank you for your info, maybe i give it a go later.
  12. Rattle
    Question for those familiar with using the batch tool. Do you have to put the firmware on the sd card like when you just update or can you just "point" batch tool to the firmware when you wipe and flash again ?
    Does this procedure wipe the sd card ?
  13. jamato8 Contributor
    There should be instructions with the Batch Tool. You load the firmware to the BT, hold the volume up key on the DX120 with it turned off and then plug it into the computer with the USB C cable. You won't wipe the card but it doesn't need to be in the DX120 as the firmware is in the BT.

    On the left side of the BT is a tab for Firmware. You click on that and then load your FW. You then plug in the DX120 and it will show up green down on the Port. You then hit Run and let it do its work.

    The Globe is the language and you click on that on click the bottom or second line of words in Mandarin and the BT changes to English.
    Last edited: Jul 2, 2019
    Rattle likes this.
  14. Rattle
    Yep there is instructions but not very clear, I'd prefer to flash with no sd card in it. thanks
  15. Rattle
    Did a clean wipe and flash with factory tool. Browsing in anything other than directory still exhibits this behavior for me. Swapping between 16bit/24/bit flac and SACD seems to trigger it. Kind of annoying this stuff doesn't get reported after all the reviews and support out there. Not a deal breaker for me, I'll just browse through directory. Kind of annoying to deal with however on a $300 device.
93 94 95 96 97 98 99 100 101 102
104 105 106 107 108 109 110 111 112 113

Share This Page