1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iBasso DX120 pure DAP player. Balanced, single ended, line out and 2 micro SD slots. FW 2.9.21 now out!

Discussion in 'Portable Source Gear' started by Paul - iBasso, Aug 31, 2018.
Tags:
First
 
Back
92 93 94 95 96 97 98 99 100 101
103 104 105 106 107 108 109 110 111 112
Next
 
Last
  1. Happosai420
    I don't think it's possible to connect to the pc in the mode that the Batch Tool needs with the power on. I've tried to connect in 2 different ways- with the power off and with the power off holding the vol+ button. Because of the boot looping, I can't enter card reader mode nor can I connect with the device on since it would just either keep looping or loop then freeze.
     
  2. Lurker0
    @Happosai420, just in case... To enter Loader mode for FactoryTool, you need the device to be turned off. To be sure it is turned off, disconnect it from the computer and charger, then press Power button and hold for 15 seconds. This way it works even in boot loop.
     
    Happosai420 likes this.
  3. hansuhumpty
    This. I paired both. Nice all-arounder, Right up my alley along with my Penon BS1 Official.
     
  4. Dark Helmet
    Would love to know if anyone has compared the DX120 sound quality wise to the Mojo?
     
  5. jamato8 Contributor
    I have both and enjoy the Mojo. It is open and has a smooth sound. I find the DX120 to be a bit more dynamic and the drive to the sound is more fun but enjoy both.
     
  6. Dark Helmet
    Which do you prefer between the two?
     
  7. jamato8 Contributor
    I prefer the DX120. An all in one package, excellent sound, light and very pocketable. I love it with the IT04, IT01s or the JH13 Pro Freqphase. Also the DX120 has a nice battery life and charges fast.
     
    Copland62 and Dark Helmet like this.
  8. Dark Helmet
    Thank you.
     
  9. Happosai420
    Thanks! I found that I had to also reopen the FactoryTool in order to have the DX120 be recognized as a loader and the light to turn green. The only issue I'm having now is that upgrades keep failing. What would make an upgrade fail while using the FactoryTool? I don't think I've ever had one fail while upgrading the DX80
     
  10. Lurker0
    Bad cable, USB port (on any end) or device's flash. FactoryTool creates log files in the Log folder, so you can read there what went wrong.
     
    Happosai420 likes this.
  11. MarCo7
    My replacement DX120 arrived yesterday. Thank you iBasso and Penon Audio for your assistance. The touch sensitivity is like night and day compared to my original purchase. The new one is running FW 2.4.56 and so far it's buttery smooth (knock on wood). P_20190622_190330_vHDR_On.jpg
     
  12. magicalmouse
    Hi, i have discovered an odd issue with my dx120 (using latest Lurker firmware)

    Twice i have had really loud static through my headphones while listening (this is so loud i have to immediately remove the headphones to prevent hearing damage). If i turn it off and then on it is still there BUT later on (next day) the dx120 plays normally.

    Any ideas/solutions (apart from returning the unit to the supplier)

    thanks

    d.
     
  13. Happosai420
    The below are from the log when I try to update the firmware. The cable and usb ports should be fine since I've used them to transfer music before the whole boot looping issue began. If the issue is with the device's flash, can anything be done?


    22:33:12 026 Factory Tool v1.3.9.0 start run
    22:33:42 838 Layer<20,9-2>:Test Device Start
    22:33:42 869 Error:RKU_Write-->WriteFile failed,bRet=0,err=87,size=31,write=0
    22:33:44 881 ERROR:RKU_ResetPipe-->DeviceIoControl failed,err=50
    22:33:44 897 <LAYER 9-2> ERROR:TestDevice-->RKU_TestDeviceReady failed,RetCode(-3),path=\\?\USB#VID_2207&PID_0000#GF43K2IF66#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
    22:33:45 912 Error:RKU_Write-->WriteFile failed,bRet=0,err=87,size=31,write=0
    22:33:47 940 ERROR:RKU_ResetPipe-->DeviceIoControl failed,err=50
     
  14. Lurker0
    This kind of log records means the data can't be sent to the device. It is only "Test Device" step which fails, no actual data transfer. You can try another cable (as short as possible) and\or another port (soldered on the motherboard is better than on the PC case).
    It means nothing. Firmware loader uses very simple transfer protocol and is very sensitive to transfer errors. When file transfer protocol just repeats sending, FactoryTool stops trying.

    To tell you that I know what I say, here is a quote from one of my logs (firmware loading stage):
    Code:
    10:29:36 396    <LAYER 8-6> INFO:Start download image,total=1859444228
    10:29:36 412    <LAYER 8-6> INFO:Start to download trust,offset=0x4000,size=4194304
    10:29:36 428    Error:RKU_Write-->WriteFile failed,bRet=0,err=31,size=1048576,write=0
    10:29:38 443    INFO:RKU_ResetPipe-->DeviceIoControl OK
    10:29:38 443    Error:RKU_Write-->WriteFile failed,bRet=0,err=31,size=1048576,write=0
    10:29:38 443    <LAYER 8-6> ERROR:RKA_File_Download-->RKU_WriteLBA failed,Written(0),RetCode(-3)
    10:29:38 443    <LAYER 8-6> ERROR:DownloadImage-->RKA_File_Download failed(trust)
    10:29:38 443    [Error] Layer<10,8-6>:Download Firmware Fail
    
    Another port, another cable, and I'm still able to flash and use this device :) It has no problems with usual file transfer either.

    Another option for you can be to put the update.img file to SD-card, and try to enter the recovery console (press and hold Play button when power on, and continue holding Play until recovery menu appears), and flash from recovery console. Sorry, I don't remember if you tried recovery console... Also, in the recovery console, you can clean data and cache, which works just like factory reset.
     
    Happosai420 likes this.
  15. Happosai420
    Thanks! I didn't realize that the loader could be that sensitive. I'll try both another port and another cable. I do have a very short cable I could use, but the port I used was soldered on to the motherboard. I can try the other one though. I have only used usb 3.0 ports with the DX120. Would a usb 2.0 port be more stable for the transfer?

    I did try recovery console first before the FactoryTool. I tried a few different updates in case it was the update that was corrupted somehow. When I ran the updates, I noticed that one of the messages that would always pop up was that the trust.img file couldn't be found. I'm not sure if that was significant. I also did a factory reset from the recovery console, and that didn't help.
     
First
 
Back
92 93 94 95 96 97 98 99 100 101
103 104 105 106 107 108 109 110 111 112
Next
 
Last

Share This Page