1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iBasso DX120 pure DAP player. Balanced, single ended, line out and 2 micro SD slots. FW 2.6.94 now out!

Discussion in 'Portable Source Gear' started by Paul - iBasso, Aug 31, 2018.
Tags:
First
 
Back
91 92 93 94 95 96 97 98 99 100
102 103 104 105 106 107 108 109 110 111
Next
 
Last
  1. Happosai420
    I've been having an issue for the past week or so, and I figured this would be the place to ask about it. A few days ago, the DX120 auto-shutdown, which is fine. However, after turning it back on, the screen would just stay black for a long time. After hard resetting, I was able to boot up, but my scans of everything were erased. I decided to upgrade the firmware at that point and did so through the device itself. I've been stuck in a boot loop ever since. I can't connect it to a pc since whenever I try to, the screen goes black, and the device becomes unresponsive. I'm able to boot into the advanced menu, and I've tried to use it to install a new upgrade to no avail. Has anyone encountered this before?
     
  2. serg7891
    Через рекавери установите прошивку 2.1.20
     
    Last edited: Jun 14, 2019
  3. Happosai420
    That's what I mean by updating through the device. Using the recovery menu
     
  4. gmahler2u
    Yes i tried that it still have problem. Qhen I bend the cable where plug is sound come on but when i un bend the cable no sound...it looks like cable but not sure..
     
  5. serg7891
    Happosai420, да
     
    Last edited: Jun 14, 2019
  6. expatriot
    I'm loving my DX120, but Ibasso, I really miss replay gain. Even my cheaper Fiio M6 has it. Can it be added later with a software update?
     
  7. gmahler2u
    I got a new pair of 2.5 cables, but not happy with the result. The sound quality is Superb. However, now it's dap causing the issue. I have listened to fellow headifer "Plugged all the way" The sound comes out one side or sometimes
    both side. I just can't enjoy the balance side of Dx120. It really starting to get annoying.
     
  8. Paul - iBasso
    Is it the cable or the DX120? Have you tried other 2.5 cables?
     
    iBasso Stay updated on iBasso at their sponsor page on Head-Fi.
     
    http://www.ibasso.com/
  9. gmahler2u
    I tried 2 other cables and same, I tried to plug the cable all the way. Still the same result. Now, it looks like a dap is the problem.
     
  10. Paul - iBasso
    It appears to be the DX120 then. I apologize for this. Depending upon when purchased and the sellers policies you may be able to get it replaced. Have you contacted the seller? You can contact me by email at paul@ibasso.com.
     
    iBasso Stay updated on iBasso at their sponsor page on Head-Fi.
     
    http://www.ibasso.com/
  11. gmahler2u
    Thank you for this, I got this dx120 2/14/19.
     
  12. Happosai420
    So no one has had this issue? Should I just return the DX120 then if this problem can't be fixed?
     
  13. Lurker0
    I'd suggest you to load full firmware image (any version you like from iBasso web site) using Rockchip FactoryTool. You may download the FactoryTool along with an instruction e.g. from here.
     
    Happosai420 and crabdog like this.
  14. Happosai420
    Thanks, but the DX120 freezes any time I try to connect to a computer. I have the Factory tool since I used it before for my DX80, but I haven't been able to use it now because of that. In trying to update any firmware, I did notice that one of the messages says that it is missing the trust.img. I'm not sure how I would add that.
     
  15. jamato8 Contributor
    When using the Batch Tool to do an wipe and install, the DX120 isn't supposed to be on. If it freezes, you have it on.
     
    Happosai420 likes this.
First
 
Back
91 92 93 94 95 96 97 98 99 100
102 103 104 105 106 107 108 109 110 111
Next
 
Last

Share This Page